]> git.pld-linux.org Git - packages/owncloudclient.git/blob - owncloudclient.spec
apidocs subpackage; resolve doc deps
[packages/owncloudclient.git] / owncloudclient.spec
1 # TODO
2 # - kf5 >= 5.16
3 #
4 # Conditional build:
5 %bcond_without  nautilus        # build Nautilus extension
6 %bcond_without  doc             # build docs
7 %bcond_without  gui             # build only libraries
8
9 %if %{without gui}
10 %undefine       with_nautilus
11 %undefine       with_doc
12 %endif
13
14 Summary:        The ownCloud client
15 Name:           owncloudclient
16 Version:        2.1.1
17 Release:        0.15
18 License:        GPL v2+
19 Group:          X11/Applications
20 Source0:        https://download.owncloud.com/desktop/stable/%{name}-%{version}.tar.xz
21 # Source0-md5:  63a971158201a8dffe96a02c54b86819
22 URL:            https://www.owncloud.com/
23 BuildRequires:  QtCore-devel
24 BuildRequires:  QtDBus-devel
25 BuildRequires:  QtGui-devel
26 BuildRequires:  QtKeychain-devel
27 BuildRequires:  QtNetwork-devel
28 BuildRequires:  QtSql-devel
29 BuildRequires:  QtWebKit-devel
30 BuildRequires:  QtXmlPatterns-devel
31 BuildRequires:  cmake >= 2.8.11
32 BuildRequires:  kf5-kconfig-devel
33 BuildRequires:  kf5-ki18n-devel
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  openssl-devel >= 1.0.0
36 BuildRequires:  pkgconfig
37 BuildRequires:  qt4-linguist
38 BuildRequires:  rpm-pythonprov
39 BuildRequires:  rpmbuild(macros) >= 1.596
40 BuildRequires:  sqlite3-devel >= 3.8.0
41 BuildRequires:  tar >= 1:1.22
42 BuildRequires:  xz
43 %if %{with doc}
44 BuildRequires:  doxygen
45 BuildRequires:  sphinx-pdg-2
46 BuildRequires:  texlive-format-pdflatex
47 BuildRequires:  texlive-latex-ams
48 BuildRequires:  texlive-makeindex
49 BuildRequires:  texlive-pdftex
50 BuildRequires:  texlive-plain
51 BuildRequires:  texlive-xetex
52 %endif
53 Requires:       %{name}-libs = %{version}-%{release}
54 Requires:       Qt5Gui-platform-xcb
55 Requires:       desktop-file-utils
56 Requires:       gtk-update-icon-cache
57 Requires:       hicolor-icon-theme
58 Suggests:       %{name}-nautilus
59 Suggests:       %{name}-nemo
60 Obsoletes:      mirall < 1.8
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 ownCloud client enables you to connect to your private ownCloud
65 Server. With it you can create folders in your home directory, and
66 keep the contents of those folders synced with your ownCloud server.
67 Simply copy a file into the directory and the ownCloud Client does the
68 rest.
69
70 ownCloud gives your employees anytime, anywhere access to the files
71 they need to get the job done, whether through this desktop
72 application, our mobile apps, the web interface, or other WebDAV
73 clients. With it, your employees can easily view and share documents
74 and information critical to the business, in a secure, flexible and
75 controlled architecture. You can easily extend ownCloud with plug-ins
76 from the community, or that you build yourself to meet the
77 requirements of your infrastructure and business.
78
79 %package libs
80 Summary:        Shared ownCloud client libraries
81 Group:          Libraries
82 Obsoletes:      mirall-libs < 1.8
83
84 %description libs
85 Shared ownCloud client libraries.
86
87 %package devel
88 Summary:        Header files for %{name} library
89 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
90 Group:          Development/Libraries
91 Requires:       %{name}-libs = %{version}-%{release}
92
93 %description devel
94 Header files for %{name} library.
95
96 %description devel -l pl.UTF-8
97 Pliki nagłówkowe biblioteki %{name}.
98
99 %package apidocs
100 Summary:        %{name} API documentation
101 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
102 Group:          Documentation
103 %if "%{_rpmversion}" >= "5"
104 BuildArch:      noarch
105 %endif
106
107 %description apidocs
108 API documentation for %{name} library.
109
110 %description apidocs -l pl.UTF-8
111 Dokumentacja API biblioteki %{name}.
112
113 %package nautilus
114 Summary:        Nautilus overlay icons
115 Group:          Applications
116 Requires:       %{name} = %{version}-%{release}
117 Requires:       nautilus-python
118
119 %description nautilus
120 This package provides overlay icons to visualize the sync state in the
121 Nautilus file manager.
122
123 %prep
124 %setup -q
125
126 %build
127 install -d build
128 cd build
129 %cmake \
130         -DQTKEYCHAIN_INCLUDE_DIR=/usr/include/qtkeychain \
131         -DQTKEYCHAIN_LIBRARY=/usr/%{_lib}/libqtkeychain.so \
132         -DQT_LRELEASE_EXECUTABLE=/usr/bin/lrelease-qt4 \
133 %if %{with doc}
134         -DSPHINX_EXECUTABLE=/usr/bin/sphinx-build-2 \
135         -DPDFLATEX_EXECUTABLE=/usr/bin/pdflatex \
136         -DDOXYGEN_EXECUTABLE=/usr/bin/doxygen \
137         -DCMAKE_INSTALL_DOCDIR=%{_docdir}/%{name} \
138 %else
139         -DWITH_DOC=NO \
140         -DSPHINX_FOUND=NO \
141         -DDOXYGEN_FOUND=NO \
142 %endif
143         %{!?with_gui:-DBUILD_LIBRARIES_ONLY=ON} \
144         ..
145 %{__make}
146
147 %if %{with doc}
148 %{__make} doc
149 rm doc/html/unthemed/.buildinfo
150 %endif
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154 %{__make} -C build install \
155         DESTDIR=$RPM_BUILD_ROOT
156
157 # owncloud client links without rpath
158 mv $RPM_BUILD_ROOT%{_libdir}/owncloud/libocsync.so* $RPM_BUILD_ROOT%{_libdir}
159
160 %if %{with nautilus}
161 # nemo not in pld
162 %{__rm} $RPM_BUILD_ROOT%{_datadir}/nemo-python/extensions/syncstate.py*
163 %endif
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %post
169 %update_desktop_database
170 %update_icon_cache hicolor
171
172 %postun
173 %update_desktop_database
174 %update_icon_cache hicolor
175
176 %post   libs -p /sbin/ldconfig
177 %postun libs -p /sbin/ldconfig
178
179 %if %{with gui}
180 %files
181 %defattr(644,root,root,755)
182 %doc README.md COPYING
183 %dir %{_sysconfdir}/ownCloud
184 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ownCloud/*
185 %attr(755,root,root) %{_bindir}/owncloud
186 %attr(755,root,root) %{_bindir}/owncloudcmd
187 %{_desktopdir}/owncloud.desktop
188 %{_iconsdir}/*/*/apps/*.png
189 %{_datadir}/owncloud
190 %dir %{_libdir}/owncloud
191 %if %{with doc}
192 %{_mandir}/man1/owncloud.1*
193 %{_mandir}/man1/owncloudcmd.1*
194 %endif
195 %endif
196
197 %files libs
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_libdir}/libowncloudsync.so.*.*.*
200 %ghost %{_libdir}/libowncloudsync.so.0
201 %attr(755,root,root) %{_libdir}/libocsync.so.*.*.*
202 %ghost %{_libdir}/libocsync.so.0
203
204 %files devel
205 %defattr(644,root,root,755)
206 %{_includedir}/owncloudsync
207 %{_libdir}/libowncloudsync.so
208 %{_libdir}/libocsync.so
209
210 %if %{with nautilus}
211 %files nautilus
212 %defattr(644,root,root,755)
213 %{_datadir}/nautilus-python/extensions/syncstate.py*
214 %endif
215
216 %if %{with doc}
217 %files apidocs
218 %defattr(644,root,root,755)
219 %doc %{_docdir}/%{name}
220 %endif
This page took 0.071923 seconds and 4 git commands to generate.