]> git.pld-linux.org Git - packages/owncloudclient.git/blob - owncloudclient.spec
add doc and gui bconds
[packages/owncloudclient.git] / owncloudclient.spec
1 #
2 # Conditional build:
3 %bcond_without  nautilus        # build Nautilus extension
4 %bcond_without  doc             # build docs
5 %bcond_without  gui             # build only libraries
6
7 %if %{without gui}
8 %undefine       with_nautilus
9 %undefine       with_doc
10 %endif
11
12 Summary:        The ownCloud client
13 Name:           owncloudclient
14 Version:        2.1.1
15 Release:        0.9
16 License:        GPL v2+
17 Group:          X11/Applications
18 Source0:        https://download.owncloud.com/desktop/stable/%{name}-%{version}.tar.xz
19 # Source0-md5:  63a971158201a8dffe96a02c54b86819
20 URL:            https://www.owncloud.com/
21 BuildRequires:  QtCore-devel
22 BuildRequires:  QtDBus-devel
23 BuildRequires:  QtGui-devel
24 BuildRequires:  QtKeychain-devel
25 BuildRequires:  QtNetwork-devel
26 BuildRequires:  QtSql-devel
27 BuildRequires:  QtWebKit-devel
28 BuildRequires:  QtXmlPatterns-devel
29 BuildRequires:  cmake >= 2.8.11
30 BuildRequires:  desktop-file-utils
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  openssl-devel
33 BuildRequires:  pkgconfig
34 BuildRequires:  python-Sphinx
35 BuildRequires:  sphinx-pdg
36 BuildRequires:  sqlite3-devel
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  texlive-latex-ams
39 BuildRequires:  xz
40 Requires:       %{name}-libs = %{version}-%{release}
41 Requires:       Qt5Gui-platform-xcb
42 Suggests:       %{name}-nautilus
43 Suggests:       %{name}-nemo
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 The ownCloud sync client - github.com/owncloud/client
48
49 ownCloud client enables you to connect to your private ownCloud
50 Server. With it you can create folders in your home directory, and
51 keep the contents of those folders synced with your ownCloud server.
52 Simply copy a file into the directory and the ownCloud Client does the
53 rest.
54
55 ownCloud gives your employees anytime, anywhere access to the files
56 they need to get the job done, whether through this desktop
57 application, our mobile apps, the web interface, or other WebDAV
58 clients. With it, your employees can easily view and share documents
59 and information critical to the business, in a secure, flexible and
60 controlled architecture. You can easily extend ownCloud with plug-ins
61 from the community, or that you build yourself to meet the
62 requirements of your infrastructure and business.
63
64 %package libs
65 Summary:        Shared ownCloud client libraries
66 Group:          Libraries
67
68 %description libs
69 Shared ownCloud client libraries.
70
71 %package devel
72 Summary:        Header files for %{name} library
73 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
74 Group:          Development/Libraries
75 Requires:       %{name}-libs = %{version}-%{release}
76
77 %description devel
78 Header files for %{name} library.
79
80 %description devel -l pl.UTF-8
81 Pliki nagłówkowe biblioteki %{name}.
82
83 %package nautilus
84 Summary:        Nautilus overlay icons
85 Group:          Applications
86 Requires:       %{name} = %{version}-%{release}
87 Requires:       nautilus-python
88
89 %description nautilus
90 This package provides overlay icons to visualize the sync state in the
91 Nautilus file manager.
92
93 %prep
94 %setup -q
95
96 %build
97 install -d build
98 cd build
99 %cmake \
100         -DQTKEYCHAIN_INCLUDE_DIR=/usr/include/qtkeychain \
101         -DQTKEYCHAIN_LIBRARY=/usr/%{_lib}/libqtkeychain.so \
102         %{!?with_gui:-DBUILD_LIBRARIES_ONLY=ON} \
103         ..
104 %{__make}
105
106 %if %{with doc}
107 # documentation here?
108 if [ -e conf.py ]; then
109         # for old cmake versions we need to move the conf.py.
110         mv conf.py doc/
111 fi
112 %{__make} doc
113 %endif
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 %{__make} -C build install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 %if %{with nautilus}
121 # nemo not in pld
122 %{__rm} $RPM_BUILD_ROOT%{_datadir}/nemo-python/extensions/syncstate.py*
123 %endif
124
125 %if %{with doc}
126 mv $RPM_BUILD_ROOT%{_docdir}/html ${RPM_BUILD_ROOT}%{_docdir}/%{name}
127 mv $RPM_BUILD_ROOT%{_docdir}/latex ${RPM_BUILD_ROOT}%{_docdir}/%{name}
128 rm $RPM_BUILD_ROOT%{_docdir}/%{name}/unthemed/.buildinfo
129 %endif
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post
135 %update_icon_cache_post hicolor
136
137 %postun
138 if [ $1 -eq 0 ] ; then
139         %update_icon_cache_post hicolor
140 fi
141
142 %post   libs -p /sbin/ldconfig
143 %postun libs -p /sbin/ldconfig
144
145 %if %{with gui}
146 %files
147 %defattr(644,root,root,755)
148 %doc README.md COPYING
149 %doc %{_docdir}/%{name}
150 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ownCloud/*
151 %attr(755,root,root) %{_bindir}/owncloud
152 %attr(755,root,root) %{_bindir}/owncloudcmd
153 %{_desktopdir}/owncloud.desktop
154 %{_iconsdir}/*/*/apps/*.png
155 %{_datadir}/owncloud
156 %{_libdir}/owncloud/libocsync.so.*
157 %dir %{_libdir}/owncloud
158 %{_mandir}/man1/owncloud*
159 %endif
160
161 %files libs
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/libowncloudsync.so.*.*.*
164 %ghost %{_libdir}/libowncloudsync.so.0
165 %attr(755,root,root) %{_libdir}/owncloud/libocsync.so.*.*.*
166 %ghost %{_libdir}/owncloud/libocsync.so.0
167
168 %files devel
169 %defattr(644,root,root,755)
170 %{_includedir}/owncloudsync
171 %{_libdir}/libowncloudsync.so
172 %{_libdir}/owncloud/libocsync.so
173
174 %if %{with nautilus}
175 %files nautilus
176 %defattr(644,root,root,755)
177 %{_datadir}/nautilus-python/extensions/syncstate.py*
178 %endif
This page took 0.048489 seconds and 4 git commands to generate.