]> git.pld-linux.org Git - packages/owncloudclient.git/blob - owncloudclient.spec
Nautilus from originally added .spec version
[packages/owncloudclient.git] / owncloudclient.spec
1 #
2 # Conditional build:
3 %bcond_without  nautilus                # build Nautilus extension
4
5 Summary:        The ownCloud client
6 Name:           owncloudclient
7 Version:        2.1.1
8 Release:        0.9
9 License:        GPL v2+
10 Group:          X11/Applications
11 Source0:        https://download.owncloud.com/desktop/stable/%{name}-%{version}.tar.xz
12 # Source0-md5:  63a971158201a8dffe96a02c54b86819
13 URL:            https://www.owncloud.com/
14 BuildRequires:  QtCore-devel
15 BuildRequires:  QtDBus-devel
16 BuildRequires:  QtGui-devel
17 BuildRequires:  QtKeychain-devel
18 BuildRequires:  QtNetwork-devel
19 BuildRequires:  QtSql-devel
20 BuildRequires:  QtWebKit-devel
21 BuildRequires:  QtXmlPatterns-devel
22 BuildRequires:  cmake >= 2.8.11
23 BuildRequires:  desktop-file-utils
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  openssl-devel
26 BuildRequires:  pkgconfig
27 BuildRequires:  python-Sphinx
28 BuildRequires:  sphinx-pdg
29 BuildRequires:  sqlite3-devel
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  texlive-latex-ams
32 BuildRequires:  xz
33 Requires:       %{name}-libs = %{version}-%{release}
34 Requires:       Qt5Gui-platform-xcb
35 Suggests:       %{name}-nautilus
36 Suggests:       %{name}-nemo
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 The ownCloud sync client - github.com/owncloud/client
41
42 ownCloud client enables you to connect to your private ownCloud
43 Server. With it you can create folders in your home directory, and
44 keep the contents of those folders synced with your ownCloud server.
45 Simply copy a file into the directory and the ownCloud Client does the
46 rest.
47
48 ownCloud gives your employees anytime, anywhere access to the files
49 they need to get the job done, whether through this desktop
50 application, our mobile apps, the web interface, or other WebDAV
51 clients. With it, your employees can easily view and share documents
52 and information critical to the business, in a secure, flexible and
53 controlled architecture. You can easily extend ownCloud with plug-ins
54 from the community, or that you build yourself to meet the
55 requirements of your infrastructure and business.
56
57 %package libs
58 Summary:        Shared ownCloud client libraries
59 Group:          Libraries
60
61 %description libs
62 Shared ownCloud client libraries.
63
64 %package devel
65 Summary:        Header files for %{name} library
66 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
67 Group:          Development/Libraries
68 Requires:       %{name}-libs = %{version}-%{release}
69
70 %description devel
71 Header files for %{name} library.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe biblioteki %{name}.
75
76 %package nautilus
77 Summary:        Nautilus overlay icons
78 Group:          Applications
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       nautilus-python
81
82 %description nautilus
83 This package provides overlay icons to visualize the sync state in the
84 Nautilus file manager.
85
86 %prep
87 %setup -q
88
89 %build
90 install -d build
91 cd build
92 %cmake \
93         -DQTKEYCHAIN_INCLUDE_DIR=/usr/include/qtkeychain \
94         -DQTKEYCHAIN_LIBRARY=/usr/%{_lib}/libqtkeychain.so \
95         ..
96 %{__make}
97
98 # documentation here?
99 if [ -e conf.py ]; then
100         # for old cmake versions we need to move the conf.py.
101         mv conf.py doc/
102 fi
103
104 %{__make} doc
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 %{__make} -C build install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 # nemo not in pld
112 %{__rm} $RPM_BUILD_ROOT%{_datadir}/nemo-python/extensions/syncstate.py*
113
114 mv $RPM_BUILD_ROOT%{_docdir}/html ${RPM_BUILD_ROOT}%{_docdir}/%{name}
115 mv $RPM_BUILD_ROOT%{_docdir}/latex ${RPM_BUILD_ROOT}%{_docdir}/%{name}
116 rm $RPM_BUILD_ROOT%{_docdir}/%{name}/unthemed/.buildinfo
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post
122 %update_icon_cache_post hicolor
123
124 %postun
125 if [ $1 -eq 0 ] ; then
126         %update_icon_cache_post hicolor
127 fi
128
129 %post   libs -p /sbin/ldconfig
130 %postun libs -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc README.md COPYING
135 %doc %{_docdir}/%{name}
136 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ownCloud/*
137 %attr(755,root,root) %{_bindir}/owncloud
138 %attr(755,root,root) %{_bindir}/owncloudcmd
139 %{_desktopdir}/owncloud.desktop
140 %{_iconsdir}/*/*/apps/*.png
141 %{_datadir}/owncloud
142 #%{_libdir}/owncloud/libocsync.so.*
143 %dir %{_libdir}/owncloud
144 %{_mandir}/man1/owncloud*
145
146 %files libs
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_libdir}/libowncloudsync.so.*.*.*
149 %ghost %{_libdir}/libowncloudsync.so.0
150 %attr(755,root,root) %{_libdir}/owncloud/libocsync.so.*.*.*
151 %ghost %{_libdir}/owncloud/libocsync.so.0
152
153 %files devel
154 %defattr(644,root,root,755)
155 %{_includedir}/owncloudsync
156 %{_libdir}/libowncloudsync.so
157 %{_libdir}/owncloud/libocsync.so
158
159 %if %{with nautilus}
160 %files nautilus
161 %defattr(644,root,root,755)
162 %{_datadir}/nautilus-python/extensions/syncstate.py*
163 %endif
This page took 0.091475 seconds and 4 git commands to generate.