]> git.pld-linux.org Git - packages/owncloudclient.git/blob - owncloudclient.spec
cleaner disable kf5
[packages/owncloudclient.git] / owncloudclient.spec
1 #
2 # Conditional build:
3 %bcond_without  nautilus        # build Nautilus extension
4 %bcond_with     dolphin         # build dolphin extension
5 %bcond_without  doc             # build docs
6 %bcond_without  gui             # build only libraries
7
8 %if %{without gui}
9 %undefine       with_nautilus
10 %undefine       with_dolphin
11 %undefine       with_doc
12 %endif
13
14 %define         qtver   5.4
15 Summary:        The ownCloud client
16 Name:           owncloudclient
17 Version:        2.1.1
18 Release:        0.16
19 License:        GPL v2+
20 Group:          X11/Applications
21 Source0:        https://download.owncloud.com/desktop/stable/%{name}-%{version}.tar.xz
22 # Source0-md5:  63a971158201a8dffe96a02c54b86819
23 URL:            https://www.owncloud.com/
24 BuildRequires:  Qt5Concurrent-devel
25 BuildRequires:  Qt5Core-devel >= %{qtver}
26 BuildRequires:  Qt5DBus-devel >= %{qtver}
27 BuildRequires:  Qt5Gui-devel >= %{qtver}
28 BuildRequires:  Qt5Keychain-devel
29 BuildRequires:  Qt5Network-devel >= %{qtver}
30 BuildRequires:  Qt5Sql-devel >= %{qtver}
31 BuildRequires:  Qt5WebKit-devel >= %{qtver}
32 BuildRequires:  Qt5Xml-devel >= %{qtver}
33 BuildRequires:  Qt5XmlPatterns-devel >= %{qtver}
34 BuildRequires:  cmake >= 2.8.11
35 BuildRequires:  libstdc++-devel
36 BuildRequires:  openssl-devel >= 1.0.0
37 BuildRequires:  pkgconfig
38 BuildRequires:  qt5-linguist >= %{qtver}
39 BuildRequires:  rpm-pythonprov
40 BuildRequires:  rpmbuild(macros) >= 1.596
41 BuildRequires:  sqlite3-devel >= 3.8.0
42 BuildRequires:  tar >= 1:1.22
43 BuildRequires:  xz
44 %if %{with dolphin}
45 BuildRequires:  kf5-attica-devel >= 5.16
46 BuildRequires:  kf5-extra-cmake-modules >= 5.16
47 BuildRequires:  kf5-kconfig-devel >= 5.16
48 BuildRequires:  kf5-ki18n-devel >= 5.16
49 BuildRequires:  kf5-kio-devel >= 5.16
50 %endif
51 %if %{with doc}
52 BuildRequires:  doxygen
53 BuildRequires:  sphinx-pdg-2
54 BuildRequires:  texlive-format-pdflatex
55 BuildRequires:  texlive-latex-ams
56 BuildRequires:  texlive-makeindex
57 BuildRequires:  texlive-pdftex
58 BuildRequires:  texlive-plain
59 BuildRequires:  texlive-xetex
60 %endif
61 Requires:       %{name}-libs = %{version}-%{release}
62 Requires:       Qt5Gui-platform-xcb
63 Requires:       desktop-file-utils
64 Requires:       gtk-update-icon-cache
65 Requires:       hicolor-icon-theme
66 Suggests:       %{name}-nautilus
67 Suggests:       %{name}-nemo
68 Obsoletes:      mirall < 1.8
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %description
72 ownCloud client enables you to connect to your private ownCloud
73 Server. With it you can create folders in your home directory, and
74 keep the contents of those folders synced with your ownCloud server.
75 Simply copy a file into the directory and the ownCloud Client does the
76 rest.
77
78 ownCloud gives your employees anytime, anywhere access to the files
79 they need to get the job done, whether through this desktop
80 application, our mobile apps, the web interface, or other WebDAV
81 clients. With it, your employees can easily view and share documents
82 and information critical to the business, in a secure, flexible and
83 controlled architecture. You can easily extend ownCloud with plug-ins
84 from the community, or that you build yourself to meet the
85 requirements of your infrastructure and business.
86
87 %package libs
88 Summary:        Shared ownCloud client libraries
89 Group:          Libraries
90 Obsoletes:      mirall-libs < 1.8
91
92 %description libs
93 Shared ownCloud client libraries.
94
95 %package devel
96 Summary:        Header files for %{name} library
97 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
98 Group:          Development/Libraries
99 Requires:       %{name}-libs = %{version}-%{release}
100
101 %description devel
102 Header files for %{name} library.
103
104 %description devel -l pl.UTF-8
105 Pliki nagłówkowe biblioteki %{name}.
106
107 %package apidocs
108 Summary:        %{name} API documentation
109 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
110 Group:          Documentation
111 %if "%{_rpmversion}" >= "5"
112 BuildArch:      noarch
113 %endif
114
115 %description apidocs
116 API documentation for %{name} library.
117
118 %description apidocs -l pl.UTF-8
119 Dokumentacja API biblioteki %{name}.
120
121 %package nautilus
122 Summary:        Nautilus overlay icons
123 Group:          Applications
124 Requires:       %{name} = %{version}-%{release}
125 Requires:       nautilus-python
126
127 %description nautilus
128 This package provides overlay icons to visualize the sync state in the
129 Nautilus file manager.
130
131 %prep
132 %setup -q
133
134 %build
135 install -d build
136 cd build
137 %cmake \
138         -DQTKEYCHAIN_INCLUDE_DIR=/usr/include/qt5keychain \
139         -DQTKEYCHAIN_LIBRARY=/usr/%{_lib}/libqt5keychain.so \
140         -DQT_LRELEASE_EXECUTABLE=/usr/bin/lrelease-qt5 \
141         -DBUILD_WITH_QT4=NO \
142 %if %{with doc}
143         -DSPHINX_EXECUTABLE=/usr/bin/sphinx-build-2 \
144         -DPDFLATEX_EXECUTABLE=/usr/bin/pdflatex \
145         -DDOXYGEN_EXECUTABLE=/usr/bin/doxygen \
146         -DCMAKE_INSTALL_DOCDIR=%{_docdir}/%{name} \
147 %else
148         -DWITH_DOC=NO \
149         -DSPHINX_FOUND=NO \
150         -DDOXYGEN_FOUND=NO \
151 %endif
152 %if %{without dolphin}
153         -DCMAKE_DISABLE_FIND_PACKAGE_ECM=TRUE \
154         -DCMAKE_DISABLE_FIND_PACKAGE_KF5=TRUE \
155 %endif
156         %{!?with_gui:-DBUILD_LIBRARIES_ONLY=ON} \
157         ..
158 %{__make}
159
160 %if %{with doc}
161 %{__make} doc
162 rm doc/html/unthemed/.buildinfo
163 %endif
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167 %{__make} -C build install \
168         DESTDIR=$RPM_BUILD_ROOT
169
170 # owncloud client links without rpath
171 mv $RPM_BUILD_ROOT%{_libdir}/owncloud/libocsync.so* $RPM_BUILD_ROOT%{_libdir}
172
173 %if %{with nautilus}
174 # nemo not in pld
175 %{__rm} $RPM_BUILD_ROOT%{_datadir}/nemo-python/extensions/syncstate.py*
176 %endif
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %post
182 %update_desktop_database
183 %update_icon_cache hicolor
184
185 %postun
186 %update_desktop_database
187 %update_icon_cache hicolor
188
189 %post   libs -p /sbin/ldconfig
190 %postun libs -p /sbin/ldconfig
191
192 %if %{with gui}
193 %files
194 %defattr(644,root,root,755)
195 %doc README.md COPYING
196 %dir %{_sysconfdir}/ownCloud
197 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ownCloud/*
198 %attr(755,root,root) %{_bindir}/owncloud
199 %attr(755,root,root) %{_bindir}/owncloudcmd
200 %{_desktopdir}/owncloud.desktop
201 %{_iconsdir}/*/*/apps/*.png
202 %{_datadir}/owncloud
203 %dir %{_libdir}/owncloud
204 %if %{with doc}
205 %{_mandir}/man1/owncloud.1*
206 %{_mandir}/man1/owncloudcmd.1*
207 %endif
208 %endif
209
210 %files libs
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_libdir}/libowncloudsync.so.*.*.*
213 %ghost %{_libdir}/libowncloudsync.so.0
214 %attr(755,root,root) %{_libdir}/libocsync.so.*.*.*
215 %ghost %{_libdir}/libocsync.so.0
216
217 %files devel
218 %defattr(644,root,root,755)
219 %{_includedir}/owncloudsync
220 %{_libdir}/libowncloudsync.so
221 %{_libdir}/libocsync.so
222
223 %if %{with nautilus}
224 %files nautilus
225 %defattr(644,root,root,755)
226 %{_datadir}/nautilus-python/extensions/syncstate.py*
227 %endif
228
229 %if %{with doc}
230 %files apidocs
231 %defattr(644,root,root,755)
232 %doc %{_docdir}/%{name}
233 %endif
This page took 0.088734 seconds and 4 git commands to generate.