]> git.pld-linux.org Git - packages/ostree.git/blob - ostree.spec
- updated to 2020.6
[packages/ostree.git] / ostree.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 Summary:        OSTree - Git for operating system binaries
6 Summary(pl.UTF-8):      OSTree - Git dla binariów systemów operacyjnych
7 Name:           ostree
8 Version:        2020.6
9 Release:        1
10 License:        LGPL v2+
11 Group:          Libraries
12 #Source0Download: https://github.com/ostreedev/ostree/releases
13 Source0:        https://github.com/ostreedev/ostree/releases/download/v%{version}/libostree-%{version}.tar.xz
14 # Source0-md5:  cd512208fba2cfd122edffbe398cea49
15 # for non-release checkouts
16 #Source1:       https://github.com/GNOME/libglnx/archive/03138641298fd6799f46b16423871f959332bacf/libglnx.tar.gz
17 ## Source1-md5: c7234e0156af5480e9fa8eef85f7d107
18 #Source2:       https://github.com/mendsley/bsdiff/archive/1edf9f656850c0c64dae260960fabd8249ea9c60/bsdiff.tar.gz
19 ## Source2-md5: 38464abb5e66b0c8dfbcf94fba6a8004
20 Patch0:         grub2-pld.patch
21 URL:            https://wiki.gnome.org/OSTree
22 BuildRequires:  attr-devel
23 BuildRequires:  autoconf >= 2.63
24 BuildRequires:  automake >= 1:1.13
25 BuildRequires:  avahi-devel >= 0.6.31
26 BuildRequires:  avahi-glib-devel >= 0.6.31
27 BuildRequires:  bison
28 BuildRequires:  curl-devel >= 7.29.0
29 BuildRequires:  e2fsprogs-devel
30 BuildRequires:  glib2-devel >= 1:2.40.0
31 BuildRequires:  gobject-introspection-devel >= 1.34.0
32 BuildRequires:  gpgme-devel >= 1.1.8
33 BuildRequires:  gtk-doc >= 1.15
34 BuildRequires:  libarchive-devel >= 2.8.0
35 BuildRequires:  libfuse-devel >= 2.9.2
36 BuildRequires:  libgpg-error-devel
37 BuildRequires:  libmount-devel >= 2.23.0
38 BuildRequires:  libselinux-devel >= 2.2
39 BuildRequires:  libsodium-devel >= 1.0.14
40 BuildRequires:  libsoup-devel >= 2.39.1
41 BuildRequires:  libtool >= 2:2.2.4
42 BuildRequires:  libxslt-progs
43 BuildRequires:  pkgconfig
44 BuildRequires:  sed >= 4.0
45 BuildRequires:  systemd-devel >= 1:209
46 BuildRequires:  tar >= 1:1.22
47 BuildRequires:  xz
48 BuildRequires:  xz-devel >= 1:5.0.5
49 BuildRequires:  zlib-devel
50 Requires:       glib2 >= 1:2.40.0
51 Requires:       gpgme >= 1.1.8
52 Requires:       libarchive >= 2.8.0
53 Requires:       libmount >= 2.23.0
54 Requires:       libselinux >= 2.2
55 Requires:       libsodium >= 1.0.14
56 Requires:       libsoup >= 2.39.1
57 Requires:       xz-libs >= 1:5.0.5
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %description
61 OSTree is a tool for managing bootable, immutable, versioned
62 filesystem trees. While it takes over some of the roles of tradtional
63 "package managers" like dpkg and rpm, it is not a package system; nor
64 is it a tool for managing full disk images. Instead, it sits between
65 those levels, offering a blend of the advantages (and disadvantages)
66 of both.
67
68 %description -l pl.UTF-8
69 OSTree to narzędzie do zarządzania uruchamialnymi, niezmiennymi,
70 wersjonowanymi drzewami systemów plików. O ile przejmuje niektóre
71 funkcje tradycyjnych "zarządców pakietów", takich jak dpkg i rpm, nie
72 jest to system pakietów; nie jest to także narzędzie do zarządzania
73 pełnymi obrazami dysków. Jest to poziom pośredni, oferujący połączenie
74 zalet (i wad) obu.
75
76 %package devel
77 Summary:        Header files for OSTree library
78 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OSTree
79 Group:          Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       glib2-devel >= 1:2.40.0
82
83 %description devel
84 Header files for OSTree library.
85
86 %description devel -l pl.UTF-8
87 Pliki nagłówkowe biblioteki OSTree.
88
89 %package static
90 Summary:        Static OSTree library
91 Summary(pl.UTF-8):      Statyczna biblioteka OSTree
92 Group:          Development/Libraries
93 Requires:       %{name}-devel = %{version}-%{release}
94
95 %description static
96 Static OSTree library.
97
98 %description static -l pl.UTF-8
99 Statyczna biblioteka OSTree.
100
101 %package apidocs
102 Summary:        OSTree API documentation
103 Summary(pl.UTF-8):      Dokumentacja API biblioteki OSTree
104 Group:          Documentation
105 %if "%{_rpmversion}" >= "4.6"
106 BuildArch:      noarch
107 %endif
108
109 %description apidocs
110 OSTree API documentation.
111
112 %description apidocs -l pl.UTF-8
113 Dokumentacja API biblioteki OSTree.
114
115 %package grub2
116 Summary:        GRUB2 integration for OSTree
117 Summary(pl.UTF-8):      Integracja bootloadera GRUB2 z OSTree
118 Group:          Libraries
119 Requires:       %{name} = %{version}-%{release}
120 Requires:       grub2
121
122 %description grub2
123 GRUB2 integration for OSTree.
124
125 %description grub2 -l pl.UTF-8
126 Integracja bootloadera GRUB2 z OSTree.
127
128 %package -n bash-completion-ostree
129 Summary:        Bash completion for ostree command
130 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów polecenia ostree
131 Group:          Applications/Shells
132 Requires:       %{name} = %{version}-%{release}
133 Requires:       bash-completion >= 2.0
134
135 %description -n bash-completion-ostree
136 Bash completion for ostree command.
137
138 %description -n bash-completion-ostree -l pl.UTF-8
139 Bashowe uzupełnianie parametrów polecenia ostree.
140
141 %package -n dracut-ostree
142 Summary:        OSTree support for Dracut
143 Summary(pl.UTF-8):      Obsługa OSTree dla Dracuta
144 Group:          Applications/System
145 Requires:       %{name} = %{version}-%{release}
146 Requires:       dracut
147
148 %description -n dracut-ostree
149 OSTree support for Dracut.
150
151 %description -n dracut-ostree -l pl.UTF-8
152 Obsługa OSTree dla Dracuta.
153
154 %prep
155 %setup -q -n libostree-%{version}
156 %patch0 -p1
157
158 # for non-release checkouts
159 #rmdir libglnx bsdiff
160 #%{__mv} libglnx-* libglnx
161 #%{__mv} bsdiff-* bsdiff
162
163 # see autogen.sh
164 sed -e 's,$(libglnx_srcpath),libglnx,g' < libglnx/Makefile-libglnx.am >libglnx/Makefile-libglnx.am.inc
165 sed -e 's,$(libbsdiff_srcpath),bsdiff,g' < bsdiff/Makefile-bsdiff.am >bsdiff/Makefile-bsdiff.am.inc
166
167 %build
168 %{__libtoolize}
169 %{__gtkdocize}
170 %{__aclocal} -I buildutil -I libglnx
171 %{__autoconf}
172 %{__autoheader}
173 %{__automake}
174 %configure \
175         GJS=/usr/bin/gjs \
176         --enable-gtk-doc \
177         --disable-silent-rules \
178         %{?with_static_libs:--enable-static} \
179         --with-dracut \
180         --with-ed25519-libsodium \
181         --with-html-dir=%{_gtkdocdir} \
182         --with-systemdsystemunitdir=%{systemdunitdir}
183 %{__make}
184
185 %install
186 rm -rf $RPM_BUILD_ROOT
187
188 %{__make} install \
189         DESTDIR=$RPM_BUILD_ROOT
190
191 # obsoleted by pkg-config
192 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libostree-1.la
193
194 %clean
195 rm -rf $RPM_BUILD_ROOT
196
197 %post   -p /sbin/ldconfig
198 %postun -p /sbin/ldconfig
199
200 %files
201 %defattr(644,root,root,755)
202 %doc README.md TODO
203 %attr(755,root,root) %{_bindir}/ostree
204 %attr(755,root,root) %{_bindir}/rofiles-fuse
205 %attr(755,root,root) %{_libdir}/libostree-1.so.*.*.*
206 %attr(755,root,root) %ghost %{_libdir}/libostree-1.so.1
207 %{_libdir}/girepository-1.0/OSTree-1.0.typelib
208 %dir %{_libexecdir}/libostree
209 %attr(755,root,root) %{_libexecdir}/libostree/ostree-trivial-httpd
210 %{_datadir}/ostree
211 %{_mandir}/man1/ostree.1*
212 %{_mandir}/man1/ostree-*.1*
213 %{_mandir}/man1/rofiles-fuse.1*
214 %{_mandir}/man5/ostree.repo.5*
215 %{_mandir}/man5/ostree.repo-config.5*
216
217 %files devel
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{_libdir}/libostree-1.so
220 %{_includedir}/ostree-1
221 %{_datadir}/gir-1.0/OSTree-1.0.gir
222 %{_pkgconfigdir}/ostree-1.pc
223
224 %if %{with static_libs}
225 %files static
226 %defattr(644,root,root,755)
227 %{_libdir}/libostree-1.a
228 %endif
229
230 %files apidocs
231 %defattr(644,root,root,755)
232 %{_gtkdocdir}/ostree
233
234 %files grub2
235 %defattr(644,root,root,755)
236 /lib/grub.d/15_ostree
237 %attr(755,root,root) %{_libexecdir}/libostree/grub2-15_ostree
238
239 %files -n bash-completion-ostree
240 %defattr(644,root,root,755)
241 %{bash_compdir}/ostree
242
243 %files -n dracut-ostree
244 %defattr(644,root,root,755)
245 %dir %{_prefix}/lib/ostree
246 %attr(755,root,root) %{_prefix}/lib/ostree/ostree-prepare-root
247 %attr(755,root,root) %{_prefix}/lib/ostree/ostree-remount
248 %{systemdunitdir}/ostree-finalize-staged.path
249 %{systemdunitdir}/ostree-finalize-staged.service
250 %{systemdunitdir}/ostree-prepare-root.service
251 %{systemdunitdir}/ostree-remount.service
252 %{systemdtmpfilesdir}/ostree-tmpfiles.conf
253 %attr(755,root,root) /lib/systemd/system-generators/ostree-system-generator
254 %dir %{_prefix}/lib/dracut/modules.d/98ostree
255 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/98ostree/module-setup.sh
256 %config(noreplace) %verify(not md5 mtime size) /etc/dracut.conf.d/ostree.conf
This page took 0.106955 seconds and 3 git commands to generate.