]> git.pld-linux.org Git - packages/ostree.git/blob - ostree.spec
- updated to 2021.6
[packages/ostree.git] / ostree.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        OSTree - Git for operating system binaries
6 Summary(pl.UTF-8):      OSTree - Git dla binariów systemów operacyjnych
7 Name:           ostree
8 Version:        2021.6
9 Release:        1
10 License:        LGPL v2+
11 Group:          Libraries
12 #Source0Download: https://github.com/ostreedev/ostree/releases
13 Source0:        https://github.com/ostreedev/ostree/releases/download/v%{version}/libostree-%{version}.tar.xz
14 # Source0-md5:  7fbc23549c41dceb3a91e94944477325
15 # for non-release checkouts
16 #Source1:       https://github.com/GNOME/libglnx/archive/03138641298fd6799f46b16423871f959332bacf/libglnx.tar.gz
17 ## Source1-md5: c7234e0156af5480e9fa8eef85f7d107
18 #Source2:       https://github.com/mendsley/bsdiff/archive/1edf9f656850c0c64dae260960fabd8249ea9c60/bsdiff.tar.gz
19 ## Source2-md5: 38464abb5e66b0c8dfbcf94fba6a8004
20 Patch0:         grub2-pld.patch
21 URL:            https://wiki.gnome.org/OSTree
22 BuildRequires:  attr-devel
23 BuildRequires:  autoconf >= 2.63
24 BuildRequires:  automake >= 1:1.13
25 BuildRequires:  avahi-devel >= 0.6.31
26 BuildRequires:  avahi-glib-devel >= 0.6.31
27 BuildRequires:  bison
28 BuildRequires:  curl-devel >= 7.29.0
29 BuildRequires:  e2fsprogs-devel
30 BuildRequires:  glib2-devel >= 1:2.44.0
31 BuildRequires:  gobject-introspection-devel >= 1.34.0
32 BuildRequires:  gpgme-devel >= 1.1.8
33 BuildRequires:  gtk-doc >= 1.15
34 BuildRequires:  libarchive-devel >= 2.8.0
35 BuildRequires:  libfuse-devel >= 2.9.2
36 BuildRequires:  libgpg-error-devel
37 BuildRequires:  libmount-devel >= 2.23.0
38 BuildRequires:  libselinux-devel >= 2.2
39 BuildRequires:  libsodium-devel >= 1.0.14
40 BuildRequires:  libsoup-devel >= 2.39.1
41 BuildRequires:  libtool >= 2:2.2.4
42 BuildRequires:  libxslt-progs
43 BuildRequires:  pkgconfig
44 BuildRequires:  rpm-build >= 4.6
45 BuildRequires:  rpmbuild(macros) >= 1.644
46 BuildRequires:  sed >= 4.0
47 BuildRequires:  systemd-devel >= 1:209
48 BuildRequires:  tar >= 1:1.22
49 BuildRequires:  xz
50 BuildRequires:  xz-devel >= 1:5.0.5
51 BuildRequires:  zlib-devel
52 Requires:       glib2 >= 1:2.44.0
53 Requires:       gpgme >= 1.1.8
54 Requires:       libarchive >= 2.8.0
55 Requires:       libmount >= 2.23.0
56 Requires:       libselinux >= 2.2
57 Requires:       libsodium >= 1.0.14
58 Requires:       libsoup >= 2.39.1
59 Requires:       xz-libs >= 1:5.0.5
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 OSTree is a tool for managing bootable, immutable, versioned
64 filesystem trees. While it takes over some of the roles of tradtional
65 "package managers" like dpkg and rpm, it is not a package system; nor
66 is it a tool for managing full disk images. Instead, it sits between
67 those levels, offering a blend of the advantages (and disadvantages)
68 of both.
69
70 %description -l pl.UTF-8
71 OSTree to narzędzie do zarządzania uruchamialnymi, niezmiennymi,
72 wersjonowanymi drzewami systemów plików. O ile przejmuje niektóre
73 funkcje tradycyjnych "zarządców pakietów", takich jak dpkg i rpm, nie
74 jest to system pakietów; nie jest to także narzędzie do zarządzania
75 pełnymi obrazami dysków. Jest to poziom pośredni, oferujący połączenie
76 zalet (i wad) obu.
77
78 %package devel
79 Summary:        Header files for OSTree library
80 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OSTree
81 Group:          Development/Libraries
82 Requires:       %{name} = %{version}-%{release}
83 Requires:       glib2-devel >= 1:2.44.0
84
85 %description devel
86 Header files for OSTree library.
87
88 %description devel -l pl.UTF-8
89 Pliki nagłówkowe biblioteki OSTree.
90
91 %package static
92 Summary:        Static OSTree library
93 Summary(pl.UTF-8):      Statyczna biblioteka OSTree
94 Group:          Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96
97 %description static
98 Static OSTree library.
99
100 %description static -l pl.UTF-8
101 Statyczna biblioteka OSTree.
102
103 %package apidocs
104 Summary:        OSTree API documentation
105 Summary(pl.UTF-8):      Dokumentacja API biblioteki OSTree
106 Group:          Documentation
107 BuildArch:      noarch
108
109 %description apidocs
110 OSTree API documentation.
111
112 %description apidocs -l pl.UTF-8
113 Dokumentacja API biblioteki OSTree.
114
115 %package grub2
116 Summary:        GRUB2 integration for OSTree
117 Summary(pl.UTF-8):      Integracja bootloadera GRUB2 z OSTree
118 Group:          Libraries
119 Requires:       %{name} = %{version}-%{release}
120 Requires:       grub2
121 BuildArch:      noarch
122
123 %description grub2
124 GRUB2 integration for OSTree.
125
126 %description grub2 -l pl.UTF-8
127 Integracja bootloadera GRUB2 z OSTree.
128
129 %package -n bash-completion-ostree
130 Summary:        Bash completion for ostree command
131 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów polecenia ostree
132 Group:          Applications/Shells
133 Requires:       %{name} = %{version}-%{release}
134 Requires:       bash-completion >= 2.0
135 BuildArch:      noarch
136
137 %description -n bash-completion-ostree
138 Bash completion for ostree command.
139
140 %description -n bash-completion-ostree -l pl.UTF-8
141 Bashowe uzupełnianie parametrów polecenia ostree.
142
143 %package -n dracut-ostree
144 Summary:        OSTree support for Dracut
145 Summary(pl.UTF-8):      Obsługa OSTree dla Dracuta
146 Group:          Applications/System
147 Requires:       %{name} = %{version}-%{release}
148 Requires:       dracut
149
150 %description -n dracut-ostree
151 OSTree support for Dracut.
152
153 %description -n dracut-ostree -l pl.UTF-8
154 Obsługa OSTree dla Dracuta.
155
156 %prep
157 %setup -q -n libostree-%{version}
158 %patch0 -p1
159
160 # for non-release checkouts
161 #rmdir libglnx bsdiff
162 #%{__mv} libglnx-* libglnx
163 #%{__mv} bsdiff-* bsdiff
164
165 # see autogen.sh
166 sed -e 's,$(libglnx_srcpath),libglnx,g' < libglnx/Makefile-libglnx.am >libglnx/Makefile-libglnx.am.inc
167 sed -e 's,$(libbsdiff_srcpath),bsdiff,g' < bsdiff/Makefile-bsdiff.am >bsdiff/Makefile-bsdiff.am.inc
168
169 %build
170 %{__libtoolize}
171 %{__gtkdocize}
172 %{__aclocal} -I buildutil -I libglnx
173 %{__autoconf}
174 %{__autoheader}
175 %{__automake}
176 %configure \
177         GJS=/usr/bin/gjs \
178         --enable-gtk-doc \
179         --disable-silent-rules \
180         %{?with_static_libs:--enable-static} \
181         --with-dracut \
182         --with-ed25519-libsodium \
183         --with-html-dir=%{_gtkdocdir} \
184         --with-systemdsystemunitdir=%{systemdunitdir}
185 %{__make}
186
187 %install
188 rm -rf $RPM_BUILD_ROOT
189
190 %{__make} install \
191         DESTDIR=$RPM_BUILD_ROOT
192
193 # obsoleted by pkg-config
194 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libostree-1.la
195
196 %clean
197 rm -rf $RPM_BUILD_ROOT
198
199 %post   -p /sbin/ldconfig
200 %postun -p /sbin/ldconfig
201
202 %files
203 %defattr(644,root,root,755)
204 %doc README.md TODO
205 %attr(755,root,root) %{_bindir}/ostree
206 %attr(755,root,root) %{_bindir}/rofiles-fuse
207 %attr(755,root,root) %{_libdir}/libostree-1.so.*.*.*
208 %attr(755,root,root) %ghost %{_libdir}/libostree-1.so.1
209 %{_libdir}/girepository-1.0/OSTree-1.0.typelib
210 %dir %{_libexecdir}/libostree
211 %attr(755,root,root) %{_libexecdir}/libostree/ostree-trivial-httpd
212 %{_datadir}/ostree
213 %{_mandir}/man1/ostree.1*
214 %{_mandir}/man1/ostree-*.1*
215 %{_mandir}/man1/rofiles-fuse.1*
216 %{_mandir}/man5/ostree.repo.5*
217 %{_mandir}/man5/ostree.repo-config.5*
218
219 %files devel
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{_libdir}/libostree-1.so
222 %{_includedir}/ostree-1
223 %{_datadir}/gir-1.0/OSTree-1.0.gir
224 %{_pkgconfigdir}/ostree-1.pc
225
226 %if %{with static_libs}
227 %files static
228 %defattr(644,root,root,755)
229 %{_libdir}/libostree-1.a
230 %endif
231
232 %files apidocs
233 %defattr(644,root,root,755)
234 %{_gtkdocdir}/ostree
235
236 %files grub2
237 %defattr(644,root,root,755)
238 /lib/grub.d/15_ostree
239 %attr(755,root,root) %{_libexecdir}/libostree/grub2-15_ostree
240
241 %files -n bash-completion-ostree
242 %defattr(644,root,root,755)
243 %{bash_compdir}/ostree
244
245 %files -n dracut-ostree
246 %defattr(644,root,root,755)
247 %dir %{_prefix}/lib/ostree
248 %attr(755,root,root) %{_prefix}/lib/ostree/ostree-prepare-root
249 %attr(755,root,root) %{_prefix}/lib/ostree/ostree-remount
250 %{systemdunitdir}/ostree-finalize-staged.path
251 %{systemdunitdir}/ostree-finalize-staged.service
252 %{systemdunitdir}/ostree-prepare-root.service
253 %{systemdunitdir}/ostree-remount.service
254 %{systemdtmpfilesdir}/ostree-tmpfiles.conf
255 %attr(755,root,root) /lib/systemd/system-generators/ostree-system-generator
256 %dir %{_prefix}/lib/dracut/modules.d/98ostree
257 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/98ostree/module-setup.sh
258 %config(noreplace) %verify(not md5 mtime size) /etc/dracut.conf.d/ostree.conf
This page took 0.080355 seconds and 3 git commands to generate.