]> git.pld-linux.org Git - packages/ossp-uuid.git/blob - ossp-uuid.spec
- rel 21
[packages/ossp-uuid.git] / ossp-uuid.spec
1 #
2 # Conditional build:
3 %bcond_without  php             # don't build PHP binding
4 %bcond_without  perl            # don't build Perl binding
5 %bcond_with     pgsql           # build postgresql binding
6 %bcond_without  static_libs     # don't build static libraries
7
8 Summary:        Universally Unique Identifier library
9 Summary(pl.UTF-8):      Biblioteka unikalnych identyfikatorów UUID
10 Name:           ossp-uuid
11 Version:        1.6.2
12 Release:        21
13 License:        MIT
14 Group:          Libraries
15 Source0:        ftp://ftp.ossp.org/pkg/lib/uuid/uuid-%{version}.tar.gz
16 # Source0-md5:  5db0d43a9022a6ebbbc25337ae28942f
17 Patch0:         uuid-ossp-prefix.patch
18 Patch1:         php3.patch
19 URL:            http://www.ossp.org/pkg/lib/uuid/
20 %{?with_php:BuildRequires:      /usr/bin/php}
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool
23 %{?with_perl:BuildRequires:     perl-devel}
24 %{?with_php:BuildRequires:      php-devel >= 3:5.0.0}
25 %{?with_pgsql:BuildRequires:    postgresql-backend-devel}
26 %{?with_pgsql:BuildRequires:    postgresql-devel}
27 BuildRequires:  rpmbuild(macros) >= 1.519
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 OSSP uuid is a ISO-C:1999 application programming interface (API) and
32 corresponding command line interface (CLI) for the generation of DCE
33 1.1, ISO/IEC 11578:1996 and RFC 4122 compliant Universally Unique
34 Identifier (UUID). It supports DCE 1.1 variant UUIDs of version 1
35 (time and node based), version 3 (name based, MD5), version 4 (random
36 number based) and version 5 (name based, SHA-1). Additional API
37 bindings are provided for the languages ISO-C++:1998, Perl:5 and
38 PHP:4/5. Optional backward compatibility exists for the ISO-C DCE-1.1
39 and Perl Data::UUID APIs.
40
41 %description -l pl.UTF-8
42 OSSP uuid to interfejs programistyczny (API) ISO-C:1999 i
43 odpowiadający mu interfejs linii poleceń (CLI) do generowania
44 całkowicie unikalnych identyfikatorów UUID (Universally Unique
45 Identifier) zgodnych z DCE 1.1, ISO/IEC 11578:1996 i RFC 4122.
46 Obsługuje wariant DCE 1.1 UUID-ów w wersji 1 (oparty na czasie i
47 węzłach), w wersji 3 (oparty na nazwie i MD5), w wersji 4 (oparty na
48 liczbach losowych) oraz w wersji 5 (oparty na nazwach i SHA-1).
49 Załączone są dodatkowe wiązania API do języków ISO-C++:1998, Perl:5
50 oraz PHP:4/5. Istnieje też opcjonalna warstwa kompatybilności dla API
51 ISO-C DCE-1.1 i perlowego Data::UUID.
52
53 %package devel
54 Summary:        Development files for Universally Unique Identifier library
55 Summary(pl.UTF-8):      Pliki programistyczne biblioteki OSSP uuid
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58
59 %description devel
60 Development headers and libraries for OSSP uuid.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki OSSP uuid.
64
65 %package static
66 Summary:        Universally Unique Identifier library - static library
67 Summary(pl.UTF-8):      Biblioteka statyczna OSSP uuid
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Universally Unique Identifier library - static library
73
74 %description static -l pl.UTF-8
75 Biblioteka statyczna OSSP uuid
76
77 %package c++
78 Summary:        C++ support for Universally Unique Identifier library
79 Summary(pl.UTF-8):      Wiązania C++ dla biblioteki OSSP uuid
80 Group:          Libraries
81 Requires:       %{name} = %{version}-%{release}
82
83 %description c++
84 C++ binding for OSSP uuid library.
85
86 %description c++ -l pl.UTF-8
87 Wiązania C++ dla biblioteki OSSP uuid.
88
89 %package c++-devel
90 Summary:        C++ development support for Universally Unique Identifier library
91 Summary(pl.UTF-8):      Pliki programistyczne wiązania C++ biblioteki OSSP uuid
92 Group:          Development/Libraries
93 Requires:       %{name}-c++ = %{version}-%{release}
94 Requires:       %{name}-devel = %{version}-%{release}
95 Requires:       libstdc++-devel
96
97 %description c++-devel
98 C++ development headers and libraries for OSSP uuid.
99
100 %description c++-devel -l pl.UTF-8
101 Pliki programistyczne wiązania C++ biblioteki OSSP uuid.
102
103 %package c++-static
104 Summary:        C++ support for Universally Unique Identifier library - static library
105 Summary(pl.UTF-8):      Wiązania C++ dla biblioteki OSSP uuid - biblioteka statyczna
106 Group:          Development/Libraries
107 Requires:       %{name}-c++-devel = %{version}-%{release}
108
109 %description c++-static
110 C++ support for Universally Unique Identifier library - static library
111
112 %description c++-static -l pl.UTF-8
113 Wiązania C++ dla biblioteki OSSP uuid - biblioteka statyczna
114
115 %package dce
116 Summary:        DCE support for Universally Unique Identifier library
117 Summary(pl.UTF-8):      Obsługa DCE dla biblioteki OSSP uuid
118 Group:          Development/Libraries
119 Requires:       %{name} = %{version}-%{release}
120
121 %description dce
122 DCE OSSP uuid library.
123
124 %description dce -l pl.UTF-8
125 Biblioteka DCE OSSP uuid.
126
127 %package dce-devel
128 Summary:        DCE development support for Universally Unique Identifier library
129 Summary(pl.UTF-8):      Pliki programistyczne obsługi DCE dla biblioteki OSSP uuid
130 Group:          Development/Libraries
131 Requires:       %{name}-dce = %{version}-%{release}
132 Requires:       %{name}-devel = %{version}-%{release}
133
134 %description dce-devel
135 DCE development headers and libraries for OSSP uuid.
136
137 %description dce-devel -l pl.UTF-8
138 Pliki programistyczne obsługi DCE dla biblioteki OSSP uuid.
139
140 %package dce-static
141 Summary:        DCE development support for Universally Unique Identifier library - static library
142 Summary(pl.UTF-8):      Pliki programistyczne obsługi DCE dla biblioteki OSSP uuid - biblioteka statyczna
143 Group:          Development/Libraries
144 Requires:       %{name}-dce-devel = %{version}-%{release}
145
146 %description dce-static
147 DCE development support for Universally Unique Identifier library -
148 static library
149
150 %description dce-static -l pl.UTF-8
151 Pliki programistyczne obsługi DCE dla biblioteki OSSP uuid -
152 biblioteka statyczna
153
154 %package -n perl-uuid
155 Summary:        OSSP uuid Perl Binding
156 Summary(pl.UTF-8):      Perlowe wiązania biblioteki OSSP uuid
157 Group:          Development/Libraries
158 Requires:       %{name} = %{version}-%{release}
159
160 %description -n perl-uuid
161 Perl OSSP uuid modules, which includes a Data::UUID replacement.
162
163 %description -n perl-uuid -l pl.UTF-8
164 Moduły Perla OSSP uuid, zawierające zamiennik Data::UUID.
165
166 %package -n php-uuid
167 Summary:        PHP support for Universally Unique Identifier library
168 Summary(pl.UTF-8):      Wiązania PHP dla biblioteki OSSP UUID
169 Group:          Development/Libraries
170 Requires:       %{name} = %{version}-%{release}
171 %{?requires_php_extension}
172 Requires:       php(core) >= 5.0.4
173
174 %description -n php-uuid
175 UUID is a PHP extension for the creation of Universally Unique
176 Identifiers (UUID).
177
178 %description -n php-uuid -l pl.UTF-8
179 UUID to rozrzeszenie PHP do tworzenia całkowicie unikalnych
180 identyfikatorów UUID.
181
182 %package -n postgresql-uuid
183 Summary:        OSSP uuid bindings for PostgreSQL
184 Summary(pl.UTF-8):      Wiązania OSSP uuid dla PostgreSQL-a
185 Group:          Development/Libraries
186 Requires:       %{name} = %{version}-%{release}
187
188 %description -n postgresql-uuid
189 PostgreSQL OSSP uuid module.
190
191 %description -n postgresql-uuid -l pl.UTF-8
192 Moduł OSSP uuid dla PostgreSQL-a.
193
194 %prep
195 %setup -q -n uuid-%{version}
196 %patch0 -p1
197 %patch1 -p1
198
199 %build
200 # Build the library.
201 %configure \
202         --includedir=%{_includedir}/ossp-uuid \
203         %{!?with_static_libs:--disable-static} \
204         --with-dce \
205         --with-cxx \
206         --with%{!?with_perl:out}-perl \
207         --with%{!?with_php:out}-php \
208         --with%{!?with_pgsql:out}-pgsql
209
210 %{__make}
211
212 %install
213 rm -rf $RPM_BUILD_ROOT
214 install -d $RPM_BUILD_ROOT/%{_lib}
215 %{__make} install \
216         WITH_PHP=no \
217         WITH_PERL=no \
218         DESTDIR=$RPM_BUILD_ROOT
219
220 mv -f $RPM_BUILD_ROOT%{_libdir}/libossp-uuid.so.* $RPM_BUILD_ROOT/%{_lib}
221 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libossp-uuid.so.*.*) $RPM_BUILD_ROOT%{_libdir}/libossp-uuid.so
222
223 %if %{with perl}
224 %{__make} pure_install \
225         -C perl \
226         INSTALLDIRS=vendor \
227         DESTDIR=$RPM_BUILD_ROOT
228
229 rm $RPM_BUILD_ROOT%{perl_vendorarch}/OSSP/uuid.pod
230 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/OSSP/uuid/.packlist
231 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/OSSP/uuid/uuid.bs
232 %endif
233
234 %if %{with php}
235 install -d $RPM_BUILD_ROOT{%{php_data_dir},%{php_sysconfdir}/conf.d}
236 %{__make} install \
237         -C php \
238         -f Makefile.local \
239         EXTDIR=%{php_extensiondir} \
240         DESTDIR=$RPM_BUILD_ROOT
241
242 mv $RPM_BUILD_ROOT{%{php_extensiondir},%{php_data_dir}}/uuid.php
243 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{name}.ini
244 ; Enable %{name} extension module
245 extension=%{name}.so
246 EOF
247 %endif
248
249 %clean
250 rm -rf $RPM_BUILD_ROOT
251
252 %post   -p /sbin/ldconfig
253 %postun -p /sbin/ldconfig
254
255 %post   c++ -p /sbin/ldconfig
256 %postun c++ -p /sbin/ldconfig
257
258 %post   dce -p /sbin/ldconfig
259 %postun dce -p /sbin/ldconfig
260
261 %files
262 %defattr(644,root,root,755)
263 %doc AUTHORS ChangeLog HISTORY NEWS PORTING README SEEALSO THANKS TODO USERS
264 %attr(755,root,root) %{_bindir}/uuid
265 %attr(755,root,root) /%{_lib}/libossp-uuid.so.*.*.*
266 %attr(755,root,root) %ghost /%{_lib}/libossp-uuid.so.16
267 %{_mandir}/man1/uuid.1*
268
269 %files devel
270 %defattr(644,root,root,755)
271 %attr(755,root,root) %{_bindir}/uuid-config
272 %attr(755,root,root) %{_libdir}/libossp-uuid.so
273 %{_libdir}/libossp-uuid.la
274 %dir %{_includedir}/ossp-uuid
275 %{_includedir}/ossp-uuid/uuid.h
276 %{_pkgconfigdir}/ossp-uuid.pc
277 %{_mandir}/man1/uuid-config.1*
278 %{_mandir}/man3/ossp-uuid.3*
279
280 %if %{with static_libs}
281 %files static
282 %defattr(644,root,root,755)
283 %{_libdir}/libossp-uuid.a
284 %endif
285
286 %files c++
287 %defattr(644,root,root,755)
288 %attr(755,root,root) %{_libdir}/libossp-uuid++.so.*.*.*
289 %attr(755,root,root) %ghost %{_libdir}/libossp-uuid++.so.16
290
291 %files c++-devel
292 %defattr(644,root,root,755)
293 %attr(755,root,root) %{_libdir}/libossp-uuid++.so
294 %{_libdir}/libossp-uuid++.la
295 %{_includedir}/ossp-uuid/uuid++.hh
296 %{_mandir}/man3/uuid++.3*
297
298 %if %{with static_libs}
299 %files c++-static
300 %defattr(644,root,root,755)
301 %{_libdir}/libossp-uuid++.a
302 %endif
303
304 %files dce
305 %defattr(644,root,root,755)
306 %attr(755,root,root) %{_libdir}/libossp-uuid_dce.so.*.*.*
307 %attr(755,root,root) %ghost %{_libdir}/libossp-uuid_dce.so.16
308
309 %files dce-devel
310 %defattr(644,root,root,755)
311 %attr(755,root,root) %{_libdir}/libossp-uuid_dce.so
312 %{_libdir}/libossp-uuid_dce.la
313 %{_includedir}/ossp-uuid/uuid_dce.h
314
315 %if %{with static_libs}
316 %files dce-static
317 %defattr(644,root,root,755)
318 %{_libdir}/libossp-uuid_dce.a
319 %endif
320
321 %if %{with perl}
322 %files -n perl-uuid
323 %defattr(644,root,root,755)
324 %dir %{perl_vendorarch}/OSSP
325 %{perl_vendorarch}/OSSP/uuid.pm
326 %dir %{perl_vendorarch}/auto/OSSP
327 %dir %{perl_vendorarch}/auto/OSSP/uuid
328 %attr(755,root,root) %{perl_vendorarch}/auto/OSSP/uuid/uuid.so
329 %{_mandir}/man3/OSSP::uuid.3*
330 %endif
331
332 %if %{with php}
333 %files -n php-uuid
334 %defattr(644,root,root,755)
335 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{name}.ini
336 %attr(755,root,root) %{php_extensiondir}/%{name}.so
337 %{php_data_dir}/uuid.php
338 %endif
339
340 %if %{with pgsql}
341 %files -n postgresql-uuid
342 %defattr(644,root,root,755)
343 %attr(755,root,root) %{_libdir}/postgresql/ossp-uuid.so
344 %{_datadir}/postgresql/uuid.sql
345 %endif
This page took 0.09688 seconds and 3 git commands to generate.