]> git.pld-linux.org Git - packages/osquery.git/blob - osquery.spec
d3d82244f5ec90154328bded941abcd82b1f49e9
[packages/osquery.git] / osquery.spec
1 Summary:        osquery is an operating system instrumentation toolchain
2 Name:           osquery
3 Version:        1.5.0
4 Release:        0.1
5 License:        BSD
6 Group:          Applications/Databases
7 Source0:        https://github.com/facebook/osquery/archive/%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  af772f7fe7b9b9a3e8ef2abfa69c2d04
9 Source1:        https://github.com/osquery/third-party/archive/%{version}/%{name}-third-party-%{version}.tar.gz
10 # Source1-md5:  940f351cef7965b0f57df70d54885ded
11 Patch0:         platform.patch
12 Patch1:         gcc-flags.patch
13 URL:            https://osquery.io/
14 BuildRequires:  bison
15 BuildRequires:  boost-devel
16 BuildRequires:  byacc
17 BuildRequires:  bzip2-devel
18 BuildRequires:  cmake
19 BuildRequires:  cryptsetup-devel
20 BuildRequires:  device-mapper-devel
21 BuildRequires:  doxygen
22 BuildRequires:  flex
23 BuildRequires:  gettext-devel
24 BuildRequires:  gflags-devel
25 BuildRequires:  gmock-devel
26 BuildRequires:  iptables-devel
27 BuildRequires:  libblkid-devel
28 BuildRequires:  libdpkg-devel
29 BuildRequires:  libgcrypt-devel
30 BuildRequires:  libuuid-devel
31 BuildRequires:  ncurses-devel
32 BuildRequires:  openssl-devel
33 BuildRequires:  python
34 BuildRequires:  python-argparse
35 BuildRequires:  python-jinja2
36 BuildRequires:  python-psutil
37 BuildRequires:  readline-devel
38 BuildRequires:  rocksdb-devel
39 BuildRequires:  rocksdb-static
40 BuildRequires:  snappy-devel
41 BuildRequires:  snappy-static
42 BuildRequires:  thrift-devel
43 BuildRequires:  udev-devel
44 BuildRequires:  yara-devel
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 # build fails with CC having spaces
48 %undefine       with_ccache
49
50 %description
51 osquery exposes an operating system as a high-performance relational
52 database. This allows you to write SQL-based queries to explore
53 operating system data. With osquery, SQL tables represent abstract
54 concepts such as running processes, loaded kernel modules, open
55 network connections, browser plugins, hardware events or file hashes.
56
57 %prep
58 %setup -q -a1
59 %patch0 -p1
60 %patch1 -p1
61
62 mv third-party-%{version}/* third-party
63
64 %build
65 install -d build
66 cd build
67
68 OSQUERY_PLATFORM="pld;%{pld_release}" \
69 OSQUERY_BUILD_VERSION=%{version} \
70 BUILD_LINK_SHARED=True \
71 SDK_VERSION=%{version} \
72 SKIP_TESTS=True \
73 %cmake \
74         ..
75 %{__make} \
76         CTEST_OUTPUT_ON_FAILURE=1
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 %{__make} -C build install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %dir %{_sysconfdir}/%{name}
89 %attr(755,root,root) %{_bindir}/osqueryctl
90 %attr(755,root,root) %{_bindir}/osqueryd
91 %attr(755,root,root) %{_bindir}/osqueryi
92 %{_datadir}/%{name}
93 %dir /var/log/%{name}
This page took 0.056428 seconds and 2 git commands to generate.