]> git.pld-linux.org Git - packages/os-prober.git/blob - os-prober.spec
97a09487170a5a69705118be16f1fdb2400949c1
[packages/os-prober.git] / os-prober.spec
1 Summary:        Utilities that detect other operating system installs on a set of drives
2 Summary(pl.UTF-8):      Narzędzia wykrywające instalacje innych systemów operacyjnych na dyskach
3 Name:           os-prober
4 Version:        1.75
5 Release:        1
6 License:        GPL v2+
7 Group:          Applications/System
8 Source0:        http://ftp.debian.org/debian/pool/main/o/os-prober/%{name}_%{version}.tar.xz
9 # Source0-md5:  acf4f8818af3cee051aa6f927a451e55
10 URL:            http://packages.qa.debian.org/o/os-prober.html
11 BuildRequires:  tar >= 1:1.22
12 BuildRequires:  xz
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         _libdir         %{_prefix}/lib
16
17 %description
18 This is a small package that may be depended on by any bootloader
19 installer package to detect other filesystems with operating systems
20 on them, and work out how to boot other Linux installs.
21
22 %description -l pl.UTF-8
23 Ten mały pakiet może być wykorzystywany przez dowolne instalatory
24 bootloaderów w celu wykrycia innych systemów plików zawierających
25 systemy operacyjne i określenia sposobu uruchomienia innych instalacji
26 Linuksa.
27
28 %prep
29 %setup -q
30
31 %build
32 %{__make} \
33         CC="%{__cc}" \
34         CFLAGS="%{rpmcflags}"
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT{/var/lib/%{name},%{_bindir},%{_datadir}/%{name},%{_libdir}/%{name}}
39 install -p %{name} $RPM_BUILD_ROOT%{_bindir}
40 install -p linux-boot-prober $RPM_BUILD_ROOT%{_bindir}
41 cp -p common.sh $RPM_BUILD_ROOT%{_datadir}/%{name}
42 install -p newns $RPM_BUILD_ROOT%{_libdir}/%{name}
43
44 ARCH=other
45 %ifarch m68k
46 ARCH=m68k
47 %endif
48 %ifarch ppc ppc64
49 ARCH=powerpc
50 %endif
51 %ifarch sparc sparc64
52 ARCH=sparc
53 %endif
54 %ifarch %{ix86} %{x8664}
55 ARCH=x86
56 %endif
57 for probes in os-probes os-probes/mounted os-probes/init \
58                           linux-boot-probes linux-boot-probes/mounted; do \
59         install -d $RPM_BUILD_ROOT%{_libdir}/$probes
60         cp -a $probes/common/* $RPM_BUILD_ROOT%{_libdir}/$probes
61         if [ -e "$probes/$ARCH" ]; then
62                 cp -a $probes/$ARCH/* $RPM_BUILD_ROOT%{_libdir}/$probes
63         fi
64 done
65
66 if [ "$ARCH" = x86 ]; then
67         cp -p os-probes/mounted/powerpc/20macosx $RPM_BUILD_ROOT%{_libdir}/os-probes/mounted
68 fi
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc README TODO debian/changelog debian/copyright
76 %attr(755,root,root) %{_bindir}/linux-boot-prober
77 %attr(755,root,root) %{_bindir}/os-prober
78 %dir %{_libdir}/linux-boot-probes
79 %attr(755,root,root) %{_libdir}/linux-boot-probes/50mounted-tests
80 %dir %{_libdir}/linux-boot-probes/mounted
81 %attr(755,root,root) %{_libdir}/linux-boot-probes/mounted/*
82 %dir %{_libdir}/os-prober
83 %attr(755,root,root) %{_libdir}/os-prober/newns
84 %dir %{_libdir}/os-probes
85 %attr(755,root,root) %{_libdir}/os-probes/50mounted-tests
86 %dir %{_libdir}/os-probes/init
87 %attr(755,root,root) %{_libdir}/os-probes/init/*
88 %dir %{_libdir}/os-probes/mounted
89 %attr(755,root,root) %{_libdir}/os-probes/mounted/*
90 %dir %{_datadir}/%{name}
91 %{_datadir}/%{name}/common.sh
92 %dir /var/lib/os-prober
This page took 0.175715 seconds and 2 git commands to generate.