]> git.pld-linux.org Git - packages/os-prober.git/blob - os-prober.spec
5176ab4d98b27cd9143c17bcf8b9550beac398b1
[packages/os-prober.git] / os-prober.spec
1 Summary:        Utilities that detect other operating system installs on a set of drives
2 Summary(pl.UTF-8):      Narzędzia wykrywające instalacje innych systemów operacyjnych na dyskach
3 Name:           os-prober
4 Version:        1.60
5 Release:        1
6 License:        GPL v2+
7 Group:          Applications/System
8 Source0:        http://ftp.debian.org/debian/pool/main/o/os-prober/%{name}_%{version}.tar.gz
9 # Source0-md5:  998045b9f281a0f6463f0caa43855b49
10 URL:            http://packages.qa.debian.org/o/os-prober.html
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %define         _libdir         %{_prefix}/lib
14
15 %description
16 This is a small package that may be depended on by any bootloader
17 installer package to detect other filesystems with operating systems
18 on them, and work out how to boot other Linux installs.
19
20 %description -l pl.UTF-8
21 Ten mały pakiet może być wykorzystywany przez dowolne instalatory
22 bootloaderów w celu wykrycia innych systemów plików zawierających
23 systemy operacyjne i określenia sposobu uruchomienia innych instalacji
24 Linuksa.
25
26 %prep
27 %setup -q
28
29 %build
30 %{__make} \
31         CC="%{__cc}" \
32         CFLAGS="%{rpmcflags}"
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT{/var/lib/%{name},%{_bindir},%{_datadir}/%{name},%{_libdir}/%{name}}
37 install -p %{name} $RPM_BUILD_ROOT%{_bindir}
38 install -p linux-boot-prober $RPM_BUILD_ROOT%{_bindir}
39 cp -p common.sh $RPM_BUILD_ROOT%{_datadir}/%{name}
40 install -p newns $RPM_BUILD_ROOT%{_libdir}/%{name}
41
42 ARCH=other
43 %ifarch m68k
44 ARCH=m68k
45 %endif
46 %ifarch ppc ppc64
47 ARCH=powerpc
48 %endif
49 %ifarch sparc sparc64
50 ARCH=sparc
51 %endif
52 %ifarch %{ix86} %{x8664}
53 ARCH=x86
54 %endif
55 for probes in os-probes os-probes/mounted os-probes/init \
56                           linux-boot-probes linux-boot-probes/mounted; do \
57         install -d $RPM_BUILD_ROOT%{_libdir}/$probes
58         cp -a $probes/common/* $RPM_BUILD_ROOT%{_libdir}/$probes
59         if [ -e "$probes/$ARCH" ]; then
60                 cp -a $probes/$ARCH/* $RPM_BUILD_ROOT%{_libdir}/$probes
61         fi
62 done
63
64 if [ "$ARCH" = x86 ]; then
65         cp -p os-probes/mounted/powerpc/20macosx $RPM_BUILD_ROOT%{_libdir}/os-probes/mounted
66 fi
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc README TODO debian/changelog debian/copyright
74 %attr(755,root,root) %{_bindir}/linux-boot-prober
75 %attr(755,root,root) %{_bindir}/os-prober
76 %dir %{_libdir}/linux-boot-probes
77 %attr(755,root,root) %{_libdir}/linux-boot-probes/50mounted-tests
78 %dir %{_libdir}/linux-boot-probes/mounted
79 %attr(755,root,root) %{_libdir}/linux-boot-probes/mounted/*
80 %dir %{_libdir}/os-prober
81 %attr(755,root,root) %{_libdir}/os-prober/newns
82 %dir %{_libdir}/os-probes
83 %attr(755,root,root) %{_libdir}/os-probes/50mounted-tests
84 %dir %{_libdir}/os-probes/init
85 %attr(755,root,root) %{_libdir}/os-probes/init/*
86 %dir %{_libdir}/os-probes/mounted
87 %attr(755,root,root) %{_libdir}/os-probes/mounted/*
88 %dir %{_datadir}/%{name}
89 %{_datadir}/%{name}/common.sh
90 %dir /var/lib/os-prober
This page took 0.053252 seconds and 2 git commands to generate.