]> git.pld-linux.org Git - packages/os-prober.git/blob - os-prober.spec
up to 1.81
[packages/os-prober.git] / os-prober.spec
1 Summary:        Utilities that detect other operating system installs on a set of drives
2 Summary(pl.UTF-8):      Narzędzia wykrywające instalacje innych systemów operacyjnych na dyskach
3 Name:           os-prober
4 Version:        1.81
5 Release:        1
6 License:        GPL v2+
7 Group:          Applications/System
8 Source0:        http://ftp.debian.org/debian/pool/main/o/os-prober/%{name}_%{version}.tar.xz
9 # Source0-md5:  fbd9a262e596bf5cc45a062f18515d50
10 URL:            http://packages.qa.debian.org/o/os-prober.html
11 BuildRequires:  tar >= 1:1.22
12 BuildRequires:  xz
13 Requires:       mount
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _libdir         %{_prefix}/lib
17
18 %description
19 This is a small package that may be depended on by any bootloader
20 installer package to detect other filesystems with operating systems
21 on them, and work out how to boot other Linux installs.
22
23 %description -l pl.UTF-8
24 Ten mały pakiet może być wykorzystywany przez dowolne instalatory
25 bootloaderów w celu wykrycia innych systemów plików zawierających
26 systemy operacyjne i określenia sposobu uruchomienia innych instalacji
27 Linuksa.
28
29 %prep
30 %setup -q
31
32 %build
33 %{__make} \
34         CC="%{__cc}" \
35         CFLAGS="%{rpmcflags}"
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT{/var/lib/%{name},%{_bindir},%{_datadir}/%{name},%{_libdir}/%{name}}
40 install -p %{name} $RPM_BUILD_ROOT%{_bindir}
41 install -p linux-boot-prober $RPM_BUILD_ROOT%{_bindir}
42 cp -p common.sh $RPM_BUILD_ROOT%{_datadir}/%{name}
43 install -p newns $RPM_BUILD_ROOT%{_libdir}/%{name}
44
45 ARCH=other
46 %ifarch m68k
47 ARCH=m68k
48 %endif
49 %ifarch ppc ppc64
50 ARCH=powerpc
51 %endif
52 %ifarch sparc sparc64
53 ARCH=sparc
54 %endif
55 %ifarch %{ix86} %{x8664}
56 ARCH=x86
57 %endif
58 for probes in os-probes os-probes/mounted os-probes/init \
59                           linux-boot-probes linux-boot-probes/mounted; do \
60         install -d $RPM_BUILD_ROOT%{_libdir}/$probes
61         cp -a $probes/common/* $RPM_BUILD_ROOT%{_libdir}/$probes
62         if [ -e "$probes/$ARCH" ]; then
63                 cp -a $probes/$ARCH/* $RPM_BUILD_ROOT%{_libdir}/$probes
64         fi
65 done
66
67 if [ "$ARCH" = x86 ]; then
68         cp -p os-probes/mounted/powerpc/20macosx $RPM_BUILD_ROOT%{_libdir}/os-probes/mounted
69 fi
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc README TODO debian/changelog debian/copyright
77 %attr(755,root,root) %{_bindir}/linux-boot-prober
78 %attr(755,root,root) %{_bindir}/os-prober
79 %dir %{_libdir}/linux-boot-probes
80 %attr(755,root,root) %{_libdir}/linux-boot-probes/50mounted-tests
81 %dir %{_libdir}/linux-boot-probes/mounted
82 %attr(755,root,root) %{_libdir}/linux-boot-probes/mounted/*
83 %dir %{_libdir}/os-prober
84 %attr(755,root,root) %{_libdir}/os-prober/newns
85 %dir %{_libdir}/os-probes
86 %attr(755,root,root) %{_libdir}/os-probes/50mounted-tests
87 %dir %{_libdir}/os-probes/init
88 %attr(755,root,root) %{_libdir}/os-probes/init/*
89 %dir %{_libdir}/os-probes/mounted
90 %attr(755,root,root) %{_libdir}/os-probes/mounted/*
91 %dir %{_datadir}/%{name}
92 %{_datadir}/%{name}/common.sh
93 %dir /var/lib/os-prober
This page took 0.116243 seconds and 3 git commands to generate.