]> git.pld-linux.org Git - packages/orc.git/blob - orc.spec
d3fcce6291ab3f2c93ee698e584825ddf2698db4
[packages/orc.git] / orc.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static libraries build
4
5 %define libver  0.4
6 Summary:        The Oil Runtime Compiler
7 Summary(pl.UTF-8):      Oil Runtime Compiler - kompilator zoptymalizowanych pętli wewnętrznych
8 Name:           orc
9 Version:        0.4.29
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 Source0:        https://gstreamer.freedesktop.org/src/orc/%{name}-%{version}.tar.xz
14 # Source0-md5:  25799917c7d31a891d5e32b83ad08f6d
15 URL:            https://gstreamer.freedesktop.org/modules/orc.html
16 BuildRequires:  autoconf >= 2.68
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  gtk-doc >= 1.12
19 BuildRequires:  libtool >= 2:2.2.6
20 BuildRequires:  pkgconfig
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  which
23 BuildRequires:  xz
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Orc is a library and set of tools for compiling and executing very
28 simple programs that operate on arrays of data. The "language" is a
29 generic assembly language that represents many of the features
30 available in SIMD architectures, including saturated addition and
31 subtraction, and many arithmetic operations.
32
33 %description -l pl.UTF-8
34 Orc to biblioteka i zestaw narzędzi do kompilowania i wykonywania
35 bardzo prostych programów operujących na tablicach danych. "Język" to
36 ogólny asembler reprezentujący wiele możliwości dostępnych w
37 architekturach SIMD, w tym ograniczone dodawanie i odejmowanie oraz
38 wiele operacji arytmetycznych.
39
40 %package devel
41 Summary:        Header files for orc library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki orc
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 Header files for orc library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki orc.
51
52 %package static
53 Summary:        Static orc library
54 Summary(pl.UTF-8):      Statyczna biblioteka orc
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static orc library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka orc.
63
64 %prep
65 %setup -q
66
67 %{__rm} m4/libtool.m4 m4/lt*.m4
68
69 %build
70 %{__libtoolize}
71 %{__aclocal} -I m4
72 %{__autoconf}
73 %{__autoheader}
74 %{__automake}
75 %configure \
76         --disable-silent-rules \
77         %{?with_static_libs:--enable-static} \
78         --with-html-dir=%{_gtkdocdir}
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc COPYING README RELEASE TODO
96 %attr(755,root,root) %{_bindir}/orc-bugreport
97 %attr(755,root,root) %{_bindir}/orcc
98 %attr(755,root,root) %{_libdir}/liborc-%{libver}.so.*.*.*
99 %attr(755,root,root) %ghost %{_libdir}/liborc-%{libver}.so.0
100 %attr(755,root,root) %{_libdir}/liborc-test-%{libver}.so.*.*.*
101 %attr(755,root,root) %ghost %{_libdir}/liborc-test-%{libver}.so.0
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_libdir}/liborc-%{libver}.so
106 %attr(755,root,root) %{_libdir}/liborc-test-%{libver}.so
107 %{_libdir}/liborc-%{libver}.la
108 %{_libdir}/liborc-test-%{libver}.la
109 %{_includedir}/orc-%{libver}
110 %{_pkgconfigdir}/orc-%{libver}.pc
111 %{_pkgconfigdir}/orc-test-%{libver}.pc
112 %{_aclocaldir}/orc.m4
113 %{_gtkdocdir}/orc
114
115 %if %{with static_libs}
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/liborc-%{libver}.a
119 %{_libdir}/liborc-test-%{libver}.a
120 %endif
This page took 0.093716 seconds and 2 git commands to generate.