]> git.pld-linux.org Git - packages/orc.git/blob - orc.spec
c8da4152ded8a78409a2464158396370d5cc59ed
[packages/orc.git] / orc.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static libraries build
4
5 %define libver  0.4
6 Summary:        The Oil Runtime Compiler
7 Summary(pl.UTF-8):      Oil Runtime Compiler - kompilator zoptymalizowanych pętli wewnętrznych
8 Name:           orc
9 Version:        0.4.32
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 Source0:        https://gstreamer.freedesktop.org/src/orc/%{name}-%{version}.tar.xz
14 # Source0-md5:  4fd61be43bb222fac1ecc486f4d055db
15 URL:            https://gstreamer.freedesktop.org/modules/orc.html
16 BuildRequires:  gcc >= 5:3.2
17 BuildRequires:  gtk-doc >= 1.12
18 BuildRequires:  meson >= 0.49.0
19 BuildRequires:  ninja >= 1.5
20 BuildRequires:  pkgconfig
21 BuildRequires:  rpmbuild(macros) >= 1.749
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  which
24 BuildRequires:  xz
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Orc is a library and set of tools for compiling and executing very
29 simple programs that operate on arrays of data. The "language" is a
30 generic assembly language that represents many of the features
31 available in SIMD architectures, including saturated addition and
32 subtraction, and many arithmetic operations.
33
34 %description -l pl.UTF-8
35 Orc to biblioteka i zestaw narzędzi do kompilowania i wykonywania
36 bardzo prostych programów operujących na tablicach danych. "Język" to
37 ogólny asembler reprezentujący wiele możliwości dostępnych w
38 architekturach SIMD, w tym ograniczone dodawanie i odejmowanie oraz
39 wiele operacji arytmetycznych.
40
41 %package devel
42 Summary:        Header files for orc library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki orc
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 Header files for orc library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki orc.
52
53 %package static
54 Summary:        Static orc library
55 Summary(pl.UTF-8):      Statyczna biblioteka orc
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static orc library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka orc.
64
65 %package apidocs
66 Summary:        API documentation for orc library
67 Summary(pl.UTF-8):      Dokumentacja API biblioteki orc
68 Group:          Documentation
69 %if 0%{?ver_ge "%{_rpmversion}" "4.6"}
70 BuildArch:      noarch
71 %endif
72
73 %description apidocs
74 API documentation for orc library.
75
76 %description apidocs -l pl.UTF-8
77 Dokumentacja API biblioteki orc.
78
79 %prep
80 %setup -q
81
82 %build
83 %meson build
84
85 %ninja_build -C build
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %ninja_install -C build
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc COPYING README RELEASE TODO
101 %attr(755,root,root) %{_bindir}/orc-bugreport
102 %attr(755,root,root) %{_bindir}/orcc
103 %attr(755,root,root) %{_libdir}/liborc-%{libver}.so.*.*.*
104 %attr(755,root,root) %ghost %{_libdir}/liborc-%{libver}.so.0
105 %attr(755,root,root) %{_libdir}/liborc-test-%{libver}.so.*.*.*
106 %attr(755,root,root) %ghost %{_libdir}/liborc-test-%{libver}.so.0
107
108 %files devel
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_libdir}/liborc-%{libver}.so
111 %attr(755,root,root) %{_libdir}/liborc-test-%{libver}.so
112 %{_includedir}/orc-%{libver}
113 %{_pkgconfigdir}/orc-%{libver}.pc
114 %{_pkgconfigdir}/orc-test-%{libver}.pc
115 %{_aclocaldir}/orc.m4
116
117 %if %{with static_libs}
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/liborc-%{libver}.a
121 %{_libdir}/liborc-test-%{libver}.a
122 %endif
123
124 %files apidocs
125 %defattr(644,root,root,755)
126 %{_gtkdocdir}/orc
This page took 0.055913 seconds and 2 git commands to generate.