]> git.pld-linux.org Git - packages/oprofile.git/blob - oprofile.spec
- updated to 1.1.0
[packages/oprofile.git] / oprofile.spec
1 # TODO:
2 # Warning: The user account 'oprofile:oprofile' does not exist on the system.
3 #         To profile JITed code, this special user account must exist.
4 #         Please ask your system administrator to add the following user and group:
5 #               user name : 'oprofile'
6 #               group name: 'oprofile'
7 #             The 'oprofile' group must be the default group for the 'oprofile' user.
8 #
9 Summary:        System-wide profiler
10 Summary(pl.UTF-8):      Ogólnosystemowy profiler
11 Name:           oprofile
12 Version:        1.1.0
13 Release:        1
14 License:        GPL v2 (oprofile), LGPL v2.1+ (libopagent)
15 Group:          Applications/System
16 Source0:        http://downloads.sourceforge.net/oprofile/%{name}-%{version}.tar.gz
17 # Source0-md5:  248c4c069f9476f427fa7195563f9867
18 URL:            http://oprofile.sourceforge.net/
19 # not used directly, but build fails without it
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  binutils-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  linux-libc-headers >= 7:2.6.31
24 BuildRequires:  popt-devel
25 BuildRequires:  rpmbuild(macros) >= 1.217
26 Requires:       uname(release) >= 2.6.31
27 Conflicts:      kernel < 2.6.31
28 ExclusiveArch:  alpha arm %{ix86} ia64 mips ppc ppc64 %{x8664} x32
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define oprofile_arch   %(echo "%{_target_base_arch}" | sed -e 's#x86_64#x86-64#')
32
33 %description
34 It consists of a kernel driver and a daemon for collecting sample
35 data, and several post-profiling tools for turning data into
36 information.
37
38 OProfile leverages the hardware performance counters of the CPU to
39 enable profiling of a wide variety of interesting statistics, which
40 can also be used for basic time-spent profiling. All code is profiled:
41 hardware and software interrupt handlers, kernel modules, the kernel,
42 shared libraries, and applications.
43
44 %description -l pl.UTF-8
45 Pakiet składa się ze sterownika dla jądra oraz demona zbierającego
46 próbki danych, a także kilku narzędzi do postprocesingu,
47 przekształcających dane na informacje.
48
49 OProfile utrzymuje liczniki wydajności sprzętu dla CPU, aby umożliwić
50 profilowanie wielorakich interesujących statystyk, których można
51 używać także do podstawowego profilowania czasu wykonywania.
52 Profilowany jest cały kod: procedury obsługi przerwań sprzętowych i
53 programowych, moduły jądra, jądro, biblioteki współdzielone oraz
54 aplikacje.
55
56 %package devel
57 Summary:        Header file for libopagent library
58 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki libopagent
59 License:        LGPL v2.1+
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62
63 %description devel
64 Header file for libopagent library.
65
66 %description devel -l pl.UTF-8
67 Plik nagłówkowy biblioteki libopagent.
68
69 %package static
70 Summary:        Static libopagent library
71 Summary(pl.UTF-8):      Statyczna biblioteka libopagent
72 License:        LGPL v2.1+
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static libopagent library.
78
79 %description static -l pl.UTF-8
80 Statyczna biblioteka libopagent.
81
82 %prep
83 %setup -q
84
85 %build
86 %configure
87
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT%{_var}/lib/oprofile
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %preun
101 if [ "$1" = 0 ]; then
102         %{_bindir}/opcontrol --shutdown 2>/dev/null 1>&2
103         rm -rf %{_var}/lib/oprofile/*
104 fi
105
106 %files
107 %defattr(644,root,root,755)
108 %doc ChangeLog* README TODO doc/*.html doc/*.png doc/*.xsd
109 %attr(755,root,root) %{_bindir}/ocount
110 %attr(755,root,root) %{_bindir}/opannotate
111 %attr(755,root,root) %{_bindir}/oparchive
112 %attr(755,root,root) %{_bindir}/op-check-perfevents
113 %attr(755,root,root) %{_bindir}/operf
114 %attr(755,root,root) %{_bindir}/opgprof
115 %attr(755,root,root) %{_bindir}/ophelp
116 %attr(755,root,root) %{_bindir}/opimport
117 %attr(755,root,root) %{_bindir}/opjitconv
118 %attr(755,root,root) %{_bindir}/opreport
119 %dir %{_libdir}/oprofile
120 %attr(755,root,root) %{_libdir}/oprofile/libopagent.so.*.*.*
121 %attr(755,root,root) %{_libdir}/oprofile/libopagent.so.1
122 %{_datadir}/%{name}
123 %dir %{_var}/lib/oprofile
124 %{_mandir}/man1/ocount.1*
125 %{_mandir}/man1/opannotate.1*
126 %{_mandir}/man1/oparchive.1*
127 %{_mandir}/man1/op-check-perfevents.1*
128 %{_mandir}/man1/operf.1*
129 %{_mandir}/man1/opgprof.1*
130 %{_mandir}/man1/ophelp.1*
131 %{_mandir}/man1/opimport.1*
132 %{_mandir}/man1/opreport.1*
133 %{_mandir}/man1/oprofile.1*
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/oprofile/libopagent.so
138 %{_libdir}/oprofile/libopagent.la
139 %{_includedir}/opagent.h
140
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/oprofile/libopagent.a
This page took 0.091392 seconds and 3 git commands to generate.