]> git.pld-linux.org Git - packages/oprofile.git/blob - oprofile.spec
c47ca501c55500bd3fe6ab2fca9a925089619062
[packages/oprofile.git] / oprofile.spec
1 # TODO:
2 # - java agents
3 # Warning: The user account 'oprofile:oprofile' does not exist on the system.
4 #         To profile JITed code, this special user account must exist.
5 #         Please ask your system administrator to add the following user and group:
6 #               user name : 'oprofile'
7 #               group name: 'oprofile'
8 #             The 'oprofile' group must be the default group for the 'oprofile' user.
9 #
10 Summary:        System-wide profiler
11 Summary(pl.UTF-8):      Ogólnosystemowy profiler
12 Name:           oprofile
13 Version:        1.4.0
14 Release:        6
15 License:        GPL v2 (oprofile), LGPL v2.1+ (libopagent)
16 Group:          Applications/System
17 Source0:        http://downloads.sourceforge.net/oprofile/%{name}-%{version}.tar.gz
18 # Source0-md5:  ac0ff685ec9735e30d6a4d19de0efed7
19 URL:            http://oprofile.sourceforge.net/
20 # not used directly, but build fails without it
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  binutils-devel
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  linux-libc-headers >= 7:2.6.31
25 BuildRequires:  pkgconfig
26 BuildRequires:  popt-devel
27 BuildRequires:  rpmbuild(macros) >= 1.217
28 Requires:       uname(release) >= 2.6.31
29 Conflicts:      kernel < 2.6.31
30 ExclusiveArch:  alpha %{arm} %{ix86} ia64 mips ppc ppc64 %{x8664} x32
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define oprofile_arch   %(echo "%{_target_base_arch}" | sed -e 's#x86_64#x86-64#')
34
35 %description
36 It consists of a kernel driver and a daemon for collecting sample
37 data, and several post-profiling tools for turning data into
38 information.
39
40 OProfile leverages the hardware performance counters of the CPU to
41 enable profiling of a wide variety of interesting statistics, which
42 can also be used for basic time-spent profiling. All code is profiled:
43 hardware and software interrupt handlers, kernel modules, the kernel,
44 shared libraries, and applications.
45
46 %description -l pl.UTF-8
47 Pakiet składa się ze sterownika dla jądra oraz demona zbierającego
48 próbki danych, a także kilku narzędzi do postprocesingu,
49 przekształcających dane na informacje.
50
51 OProfile utrzymuje liczniki wydajności sprzętu dla CPU, aby umożliwić
52 profilowanie wielorakich interesujących statystyk, których można
53 używać także do podstawowego profilowania czasu wykonywania.
54 Profilowany jest cały kod: procedury obsługi przerwań sprzętowych i
55 programowych, moduły jądra, jądro, biblioteki współdzielone oraz
56 aplikacje.
57
58 %package devel
59 Summary:        Header file for libopagent library
60 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki libopagent
61 License:        LGPL v2.1+
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64
65 %description devel
66 Header file for libopagent library.
67
68 %description devel -l pl.UTF-8
69 Plik nagłówkowy biblioteki libopagent.
70
71 %package static
72 Summary:        Static libopagent library
73 Summary(pl.UTF-8):      Statyczna biblioteka libopagent
74 License:        LGPL v2.1+
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static libopagent library.
80
81 %description static -l pl.UTF-8
82 Statyczna biblioteka libopagent.
83
84 %prep
85 %setup -q
86
87 %build
88 %configure
89
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT%{_var}/lib/oprofile
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %preun
103 if [ "$1" = 0 ]; then
104         %{_bindir}/opcontrol --shutdown 2>/dev/null 1>&2
105         rm -rf %{_var}/lib/oprofile/*
106 fi
107
108 %files
109 %defattr(644,root,root,755)
110 %doc ChangeLog* README TODO doc/*.html doc/*.png doc/*.xsd
111 %attr(755,root,root) %{_bindir}/ocount
112 %attr(755,root,root) %{_bindir}/op-check-perfevents
113 %attr(755,root,root) %{_bindir}/opannotate
114 %attr(755,root,root) %{_bindir}/oparchive
115 %attr(755,root,root) %{_bindir}/operf
116 %attr(755,root,root) %{_bindir}/opgprof
117 %attr(755,root,root) %{_bindir}/ophelp
118 %attr(755,root,root) %{_bindir}/opimport
119 %attr(755,root,root) %{_bindir}/opjitconv
120 %attr(755,root,root) %{_bindir}/opreport
121 %dir %{_libdir}/oprofile
122 %attr(755,root,root) %{_libdir}/oprofile/libopagent.so.*.*.*
123 %attr(755,root,root) %{_libdir}/oprofile/libopagent.so.1
124 %{_datadir}/%{name}
125 %dir %{_var}/lib/oprofile
126 %{_mandir}/man1/op-check-perfevents.1*
127 %{_mandir}/man1/ocount.1*
128 %{_mandir}/man1/opannotate.1*
129 %{_mandir}/man1/oparchive.1*
130 %{_mandir}/man1/operf.1*
131 %{_mandir}/man1/opgprof.1*
132 %{_mandir}/man1/ophelp.1*
133 %{_mandir}/man1/opimport.1*
134 %{_mandir}/man1/opjitconv.1*
135 %{_mandir}/man1/opreport.1*
136 %{_mandir}/man1/oprofile.1*
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/oprofile/libopagent.so
141 %{_libdir}/oprofile/libopagent.la
142 %{_includedir}/opagent.h
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/oprofile/libopagent.a
This page took 0.04398 seconds and 2 git commands to generate.