]> git.pld-linux.org Git - packages/oprofile.git/blob - oprofile.spec
9f7855826419b10d2f7f398f6dfd303f10757057
[packages/oprofile.git] / oprofile.spec
1 # TODO:
2 # Warning: The user account 'oprofile:oprofile' does not exist on the system.
3 #         To profile JITed code, this special user account must exist.
4 #         Please ask your system administrator to add the following user and group:
5 #               user name : 'oprofile'
6 #               group name: 'oprofile'
7 #             The 'oprofile' group must be the default group for the 'oprofile' user.
8 #
9 Summary:        System-wide profiler
10 Summary(pl.UTF-8):      Ogólnosystemowy profiler
11 Name:           oprofile
12 Version:        1.0.0
13 Release:        5
14 License:        GPL v2 (oprofile), LGPL v2.1+ (libopagent)
15 Group:          Applications/System
16 Source0:        http://downloads.sourceforge.net/oprofile/%{name}-%{version}.tar.gz
17 # Source0-md5:  ba0b340e5c421a93959776c836ed35b3
18 URL:            http://oprofile.sourceforge.net/
19 # not used directly, but build fails without it
20 BuildRequires:  autoconf
21 BuildRequires:  binutils-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  popt-devel
24 BuildRequires:  rpmbuild(macros) >= 1.217
25 Requires:       uname(release) >= 2.6
26 Conflicts:      kernel < 2.6
27 ExclusiveArch:  alpha arm %{ix86} ia64 mips ppc ppc64 %{x8664} x32
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define oprofile_arch   %(echo "%{_target_base_arch}" | sed -e 's#x86_64#x86-64#')
31
32 %description
33 It consists of a kernel driver and a daemon for collecting sample
34 data, and several post-profiling tools for turning data into
35 information.
36
37 OProfile leverages the hardware performance counters of the CPU to
38 enable profiling of a wide variety of interesting statistics, which
39 can also be used for basic time-spent profiling. All code is profiled:
40 hardware and software interrupt handlers, kernel modules, the kernel,
41 shared libraries, and applications.
42
43 %description -l pl.UTF-8
44 Pakiet składa się ze sterownika dla jądra oraz demona zbierającego
45 próbki danych, a także kilku narzędzi do postprocesingu,
46 przekształcających dane na informacje.
47
48 OProfile utrzymuje liczniki wydajności sprzętu dla CPU, aby umożliwić
49 profilowanie wielorakich interesujących statystyk, których można
50 używać także do podstawowego profilowania czasu wykonywania.
51 Profilowany jest cały kod: procedury obsługi przerwań sprzętowych i
52 programowych, moduły jądra, jądro, biblioteki współdzielone oraz
53 aplikacje.
54
55 %package devel
56 Summary:        Header file for libopagent library
57 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki libopagent
58 License:        LGPL v2.1+
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description devel
63 Header file for libopagent library.
64
65 %description devel -l pl.UTF-8
66 Plik nagłówkowy biblioteki libopagent.
67
68 %package static
69 Summary:        Static libopagent library
70 Summary(pl.UTF-8):      Statyczna biblioteka libopagent
71 License:        LGPL v2.1+
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static libopagent library.
77
78 %description static -l pl.UTF-8
79 Statyczna biblioteka libopagent.
80
81 %prep
82 %setup -q
83
84 %build
85 %configure
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT%{_var}/lib/oprofile
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %preun
100 if [ "$1" = 0 ]; then
101         %{_bindir}/opcontrol --shutdown 2>/dev/null 1>&2
102         rm -rf %{_var}/lib/oprofile/*
103 fi
104
105 %files
106 %defattr(644,root,root,755)
107 %doc ChangeLog* README TODO doc/*.html doc/*.png doc/*.xsd
108 %attr(755,root,root) %{_bindir}/ocount
109 %attr(755,root,root) %{_bindir}/opannotate
110 %attr(755,root,root) %{_bindir}/oparchive
111 %attr(755,root,root) %{_bindir}/op-check-perfevents
112 %attr(755,root,root) %{_bindir}/operf
113 %attr(755,root,root) %{_bindir}/opgprof
114 %attr(755,root,root) %{_bindir}/ophelp
115 %attr(755,root,root) %{_bindir}/opimport
116 %attr(755,root,root) %{_bindir}/opjitconv
117 %attr(755,root,root) %{_bindir}/opreport
118 %dir %{_libdir}/oprofile
119 %attr(755,root,root) %{_libdir}/oprofile/libopagent.so.*.*.*
120 %attr(755,root,root) %{_libdir}/oprofile/libopagent.so.1
121 %{_datadir}/%{name}
122 %dir %{_var}/lib/oprofile
123 %{_mandir}/man1/ocount.1*
124 %{_mandir}/man1/opannotate.1*
125 %{_mandir}/man1/oparchive.1*
126 %{_mandir}/man1/op-check-perfevents.1*
127 %{_mandir}/man1/operf.1*
128 %{_mandir}/man1/opgprof.1*
129 %{_mandir}/man1/ophelp.1*
130 %{_mandir}/man1/opimport.1*
131 %{_mandir}/man1/opreport.1*
132 %{_mandir}/man1/oprofile.1*
133
134 %files devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/oprofile/libopagent.so
137 %{_libdir}/oprofile/libopagent.la
138 %{_includedir}/opagent.h
139
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/oprofile/libopagent.a
This page took 0.065295 seconds and 2 git commands to generate.