]> git.pld-linux.org Git - packages/oprofile.git/blob - oprofile.spec
- rebuild with binutils 2.29
[packages/oprofile.git] / oprofile.spec
1 # TODO:
2 # Warning: The user account 'oprofile:oprofile' does not exist on the system.
3 #         To profile JITed code, this special user account must exist.
4 #         Please ask your system administrator to add the following user and group:
5 #               user name : 'oprofile'
6 #               group name: 'oprofile'
7 #             The 'oprofile' group must be the default group for the 'oprofile' user.
8 #
9 Summary:        System-wide profiler
10 Summary(pl.UTF-8):      Ogólnosystemowy profiler
11 Name:           oprofile
12 Version:        1.1.0
13 Release:        5
14 License:        GPL v2 (oprofile), LGPL v2.1+ (libopagent)
15 Group:          Applications/System
16 Source0:        http://downloads.sourceforge.net/oprofile/%{name}-%{version}.tar.gz
17 # Source0-md5:  248c4c069f9476f427fa7195563f9867
18 Patch0:         %{name}-c++.patch
19 URL:            http://oprofile.sourceforge.net/
20 # not used directly, but build fails without it
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  binutils-devel
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  linux-libc-headers >= 7:2.6.31
25 BuildRequires:  popt-devel
26 BuildRequires:  rpmbuild(macros) >= 1.217
27 Requires:       uname(release) >= 2.6.31
28 Conflicts:      kernel < 2.6.31
29 ExclusiveArch:  alpha arm %{ix86} ia64 mips ppc ppc64 %{x8664} x32
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define oprofile_arch   %(echo "%{_target_base_arch}" | sed -e 's#x86_64#x86-64#')
33
34 %description
35 It consists of a kernel driver and a daemon for collecting sample
36 data, and several post-profiling tools for turning data into
37 information.
38
39 OProfile leverages the hardware performance counters of the CPU to
40 enable profiling of a wide variety of interesting statistics, which
41 can also be used for basic time-spent profiling. All code is profiled:
42 hardware and software interrupt handlers, kernel modules, the kernel,
43 shared libraries, and applications.
44
45 %description -l pl.UTF-8
46 Pakiet składa się ze sterownika dla jądra oraz demona zbierającego
47 próbki danych, a także kilku narzędzi do postprocesingu,
48 przekształcających dane na informacje.
49
50 OProfile utrzymuje liczniki wydajności sprzętu dla CPU, aby umożliwić
51 profilowanie wielorakich interesujących statystyk, których można
52 używać także do podstawowego profilowania czasu wykonywania.
53 Profilowany jest cały kod: procedury obsługi przerwań sprzętowych i
54 programowych, moduły jądra, jądro, biblioteki współdzielone oraz
55 aplikacje.
56
57 %package devel
58 Summary:        Header file for libopagent library
59 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki libopagent
60 License:        LGPL v2.1+
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63
64 %description devel
65 Header file for libopagent library.
66
67 %description devel -l pl.UTF-8
68 Plik nagłówkowy biblioteki libopagent.
69
70 %package static
71 Summary:        Static libopagent library
72 Summary(pl.UTF-8):      Statyczna biblioteka libopagent
73 License:        LGPL v2.1+
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static libopagent library.
79
80 %description static -l pl.UTF-8
81 Statyczna biblioteka libopagent.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86
87 %build
88 %configure
89
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT%{_var}/lib/oprofile
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %preun
103 if [ "$1" = 0 ]; then
104         %{_bindir}/opcontrol --shutdown 2>/dev/null 1>&2
105         rm -rf %{_var}/lib/oprofile/*
106 fi
107
108 %files
109 %defattr(644,root,root,755)
110 %doc ChangeLog* README TODO doc/*.html doc/*.png doc/*.xsd
111 %attr(755,root,root) %{_bindir}/ocount
112 %attr(755,root,root) %{_bindir}/opannotate
113 %attr(755,root,root) %{_bindir}/oparchive
114 %attr(755,root,root) %{_bindir}/op-check-perfevents
115 %attr(755,root,root) %{_bindir}/operf
116 %attr(755,root,root) %{_bindir}/opgprof
117 %attr(755,root,root) %{_bindir}/ophelp
118 %attr(755,root,root) %{_bindir}/opimport
119 %attr(755,root,root) %{_bindir}/opjitconv
120 %attr(755,root,root) %{_bindir}/opreport
121 %dir %{_libdir}/oprofile
122 %attr(755,root,root) %{_libdir}/oprofile/libopagent.so.*.*.*
123 %attr(755,root,root) %{_libdir}/oprofile/libopagent.so.1
124 %{_datadir}/%{name}
125 %dir %{_var}/lib/oprofile
126 %{_mandir}/man1/ocount.1*
127 %{_mandir}/man1/opannotate.1*
128 %{_mandir}/man1/oparchive.1*
129 %{_mandir}/man1/op-check-perfevents.1*
130 %{_mandir}/man1/operf.1*
131 %{_mandir}/man1/opgprof.1*
132 %{_mandir}/man1/ophelp.1*
133 %{_mandir}/man1/opimport.1*
134 %{_mandir}/man1/opreport.1*
135 %{_mandir}/man1/oprofile.1*
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/oprofile/libopagent.so
140 %{_libdir}/oprofile/libopagent.la
141 %{_includedir}/opagent.h
142
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/oprofile/libopagent.a
This page took 0.080455 seconds and 3 git commands to generate.