]> git.pld-linux.org Git - packages/openvpn-plugin-auth-ldap.git/blob - openvpn-plugin-auth-ldap.spec
ca78a0a4b675f0ecb0cbb724fc7bd9bcfc1dcee2
[packages/openvpn-plugin-auth-ldap.git] / openvpn-plugin-auth-ldap.spec
1 # Conditional build:
2 %bcond_with     tests           # check-based tests
3
4 Summary:        OpenVPN Auth-LDAP Plugin
5 Summary(pl.UTF-8):      Wtyczka Auth-LDAP dla OpenVPN
6 Name:           openvpn-plugin-auth-ldap
7 Version:        2.0.4
8 Release:        1
9 License:        BSD + others
10 Group:          Applications
11 Source0:        https://github.com/threerings/openvpn-auth-ldap/archive/auth-ldap-%{version}.tar.gz
12 # Source0-md5:  c4985fbbf88042e28efd1521d03bf658
13 Patch1:         %{name}-objc-include.patch
14 URL:            https://github.com/threerings/openvpn-auth-ldap
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 %{?with_tests:BuildRequires:    check}
18 BuildRequires:  gcc-objc
19 BuildRequires:  openldap-devel
20 BuildRequires:  openvpn-devel
21 BuildRequires:  re2c
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _libdir         %{_prefix}/%{_lib}/openvpn/plugins
25 %define         _sysconfdir     /etc/openvpn
26
27 %description
28 The openvpn-auth-ldap plugin implements username/password
29 authentication via LDAP.
30
31 %description -l pl.UTF-8
32 Wtyczka openvpn-auth-ldap implementuje uwierzytelnianie nazwą
33 użytkownika i hasłem poprzez LDAP.
34
35 %prep
36 %setup -q -n openvpn-auth-ldap-auth-ldap-%{version}
37 #%%patch1 -p1
38
39 #:> objc.m4
40
41 %build
42 #%%{__aclocal}
43 %{__autoconf}
44 %{__autoheader}
45 cp -f /usr/share/automake/config.sub .
46 %configure \
47         OBJCFLAGS="-std=gnu11" \
48         --with-objc-runtime=GNU \
49         --with-check=%{!?with_tests:/proc}%{?with_tests:/usr} \
50         --with-openldap=/usr \
51         --with-openvpn=/usr
52
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_libdir}}
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61 cp -a auth-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc LICENSE README.md
69 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/auth-ldap.conf
70 %attr(755,root,root) %{_libdir}/openvpn-auth-ldap.so
This page took 0.06909 seconds and 2 git commands to generate.