]> git.pld-linux.org Git - packages/openvpn-plugin-auth-ldap.git/blob - openvpn-plugin-auth-ldap.spec
try to circumvent some autocr*p problem that doesn't manifest in my env
[packages/openvpn-plugin-auth-ldap.git] / openvpn-plugin-auth-ldap.spec
1 # Conditional build:
2 %bcond_with     tests           # check-based tests
3
4 Summary:        OpenVPN Auth-LDAP Plugin
5 Summary(pl.UTF-8):      Wtyczka Auth-LDAP dla OpenVPN
6 Name:           openvpn-plugin-auth-ldap
7 Version:        2.0.4
8 Release:        1
9 License:        BSD
10 Group:          Applications
11 Source0:        https://github.com/threerings/openvpn-auth-ldap/archive/auth-ldap-%{version}.tar.gz
12 # Source0-md5:  c4985fbbf88042e28efd1521d03bf658
13 Patch0:         %{name}-make.patch
14 Patch1:         %{name}-objc-include.patch
15 URL:            https://github.com/threerings/openvpn-auth-ldap
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 %{?with_tests:BuildRequires:    check}
19 BuildRequires:  gcc-objc
20 BuildRequires:  openldap-devel
21 BuildRequires:  openvpn-devel
22 BuildRequires:  pkgconfig
23 BuildRequires:  re2c
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _libdir         %{_prefix}/%{_lib}/openvpn/plugins
27 %define         _sysconfdir     /etc/openvpn
28
29 %description
30 The openvpn-auth-ldap plugin implements username/password
31 authentication via LDAP.
32
33 %description -l pl.UTF-8
34 Wtyczka openvpn-auth-ldap implementuje uwierzytelnianie nazwą
35 użytkownika i hasłem poprzez LDAP.
36
37 %prep
38 %setup -q -n openvpn-auth-ldap-auth-ldap-%{version}
39 #%%patch0 -p1
40 #%%patch1 -p1
41
42 > objc.m4
43
44 %build
45 %{__aclocal}
46 %{__autoconf}
47 %{__autoheader}
48 cp -f /usr/share/automake/config.sub .
49 %configure \
50         --with-objc-runtime=GNU \
51         --with-check=%{!?with_tests:/proc}%{?with_tests:/usr} \
52         --with-openldap=/usr \
53         --with-openvpn=/usr
54
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_libdir}}
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63 cp -a auth-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc LICENSE README
71 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/auth-ldap.conf
72 %attr(755,root,root) %{_libdir}/openvpn-auth-ldap.so
This page took 0.175304 seconds and 3 git commands to generate.