]> git.pld-linux.org Git - packages/openvpn-plugin-auth-ldap.git/blob - openvpn-plugin-auth-ldap.spec
I can reproduce the problem by removing aclocal.m4, try not breaking the provided one
[packages/openvpn-plugin-auth-ldap.git] / openvpn-plugin-auth-ldap.spec
1 # Conditional build:
2 %bcond_with     tests           # check-based tests
3
4 Summary:        OpenVPN Auth-LDAP Plugin
5 Summary(pl.UTF-8):      Wtyczka Auth-LDAP dla OpenVPN
6 Name:           openvpn-plugin-auth-ldap
7 Version:        2.0.4
8 Release:        1
9 License:        BSD
10 Group:          Applications
11 Source0:        https://github.com/threerings/openvpn-auth-ldap/archive/auth-ldap-%{version}.tar.gz
12 # Source0-md5:  c4985fbbf88042e28efd1521d03bf658
13 Patch0:         %{name}-make.patch
14 Patch1:         %{name}-objc-include.patch
15 URL:            https://github.com/threerings/openvpn-auth-ldap
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 %{?with_tests:BuildRequires:    check}
19 BuildRequires:  gcc-objc
20 BuildRequires:  openldap-devel
21 BuildRequires:  openvpn-devel
22 BuildRequires:  re2c
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _libdir         %{_prefix}/%{_lib}/openvpn/plugins
26 %define         _sysconfdir     /etc/openvpn
27
28 %description
29 The openvpn-auth-ldap plugin implements username/password
30 authentication via LDAP.
31
32 %description -l pl.UTF-8
33 Wtyczka openvpn-auth-ldap implementuje uwierzytelnianie nazwą
34 użytkownika i hasłem poprzez LDAP.
35
36 %prep
37 %setup -q -n openvpn-auth-ldap-auth-ldap-%{version}
38 #%%patch0 -p1
39 #%%patch1 -p1
40
41 #:> objc.m4
42
43 %build
44 #%%{__aclocal}
45 %{__autoconf}
46 %{__autoheader}
47 cp -f /usr/share/automake/config.sub .
48 %configure \
49         --with-objc-runtime=GNU \
50         --with-check=%{!?with_tests:/proc}%{?with_tests:/usr} \
51         --with-openldap=/usr \
52         --with-openvpn=/usr
53
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_libdir}}
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62 cp -a auth-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc LICENSE README
70 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/auth-ldap.conf
71 %attr(755,root,root) %{_libdir}/openvpn-auth-ldap.so
This page took 0.035473 seconds and 3 git commands to generate.