]> git.pld-linux.org Git - packages/openscad.git/blob - openscad.spec
- cmake does not generate all rules (no install)
[packages/openscad.git] / openscad.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build with tests
4
5 %ifarch x32
6 %undefine       with_tests
7 %endif
8 Summary:        The Programmers Solid 3D CAD Modeller
9 Name:           openscad
10 Version:        2021.01
11 Release:        1
12 # COPYING contains a linking exception for CGAL
13 # Appdata file is CC0
14 # Examples are CC0
15 License:        GPLv2 with exceptions and CC0
16 Group:          Applications/Engineering
17 Source0:        http://files.openscad.org/%{name}-%{version}.src.tar.gz
18 # Source0-md5:  79f8e3a42bcfeeb3ddde9e5bc2311f76
19 Patch0:         %{name}-polyclipping.patch
20 Patch1:         localedir.patch
21 URL:            http://www.openscad.org/
22 BuildRequires:  CGAL-devel >= 4.9
23 BuildRequires:  ImageMagick
24 BuildRequires:  Mesa-dri-driver-swrast
25 BuildRequires:  Qt5Concurrent-devel
26 BuildRequires:  Qt5DBus-devel
27 BuildRequires:  Qt5Multimedia-devel
28 BuildRequires:  Qt5Network-devel
29 BuildRequires:  Qt5PrintSupport-devel
30 BuildRequires:  bison >= 2.4
31 BuildRequires:  boost-devel >= 1.35
32 BuildRequires:  desktop-file-utils
33 BuildRequires:  double-conversion-devel
34 BuildRequires:  eigen3
35 BuildRequires:  flex >= 2.5.35
36 BuildRequires:  fontconfig-devel >= 2.10
37 BuildRequires:  freetype-devel >= 2.4
38 BuildRequires:  gettext
39 BuildRequires:  glew-devel >= 1.6
40 BuildRequires:  glib2-devel
41 BuildRequires:  gmp-devel >= 5.0.0
42 BuildRequires:  harfbuzz-devel >= 0.9.19
43 BuildRequires:  lib3mf-devel >= 1.8.1
44 BuildRequires:  libxml2-devel
45 BuildRequires:  libzip-devel
46 BuildRequires:  mpfr-devel >= 3.0.0
47 BuildRequires:  opencsg-devel >= 1.3.2
48 BuildRequires:  pkgconfig
49 BuildRequires:  polyclipping-devel >= 6.1.3
50 BuildRequires:  procps
51 BuildRequires:  python
52 BuildRequires:  qscintilla2-qt5-devel >= 2.11.2
53 BuildRequires:  qt5-build
54 BuildRequires:  xorg-xserver-Xvfb
55 Requires:       font(liberationmono)
56 Requires:       font(liberationsans)
57 Requires:       font(liberationserif)
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 ### LICENSES:
61
62 ##  LGPLv2+:
63 #   2Dshapes.scad
64 #   3d_triangle.scad
65 #   fonts.scad
66 #   gridbeam.scad
67 #   hardware.scad
68 #   libtriangles.scad
69 #   multiply.scad
70 #   shapes.scad
71 #   screw.scad
72
73 ##  LGPLv2:
74 #   gears.scad
75 #   involute_gears.scad
76 #   servos.scad
77 #   transformations.scad
78 #   triangles.scad
79 #   unregular_shapes.scad
80 #   bitmap/letter_necklace.scad
81
82 ##  LGPLv3+:
83 #   teardrop.scad
84
85 ##  GPLv3 or LGPLv2:
86 #   motors.scad
87 #   nuts_and_bolts.scad
88
89
90 ##  GPLv3+ or LGPLv2:
91 #   metric_fastners.scad
92 #   regular_shapes.scad
93
94 ##  CC-BY-SA or LGPLv2+:
95 #   bearing.scad
96 #   materials.scad
97 #   stepper.scad
98 #   utilities.scad
99
100 ##  CC-BY-SA or LGPLv2:
101 #   units.scad
102
103 ##  CC-BY:
104 #   polyholes.scad
105 #   bitmap/alphabet_block.scad
106 #   bitmap/bitmap.scad
107 #   bitmap/height_map.scad
108 #   bitmap/name_tag.scad
109
110 ## BSD
111 #   boxes.scad
112
113 ## MIT
114 #   constants.scad
115 #   curves.scad
116 #   math.scad
117
118 ## Public Domain
119 #   lego_compatibility.scad
120 #   trochoids.scad
121
122 ###############################################
123
124 %description
125 OpenSCAD is a software for creating solid 3D CAD objects. Unlike most
126 free software for creating 3D models (such as the famous application
127 Blender) it does not focus on the artistic aspects of 3D modeling but
128 instead on the CAD aspects. Thus it might be the application you are
129 looking for when you are planning to create 3D models of machine parts
130 but pretty sure is not what you are looking for when you are more
131 interested in creating computer-animated movies.
132
133 %package MCAD
134 Summary:        OpenSCAD Parametric CAD Library
135 License:        LGPLv2+ and LGPLv2 and LGPLv3+ and (GPLv3 or LGPLv2) and (GPLv3+ or LGPLv2) and (CC-BY-SA or LGPLv2+) and (CC-BY-SA or LGPLv2) and CC-BY and BSD and MIT and Public Domain
136 URL:            https://www.github.com/openscad/MCAD
137 Requires:       %{name} = %{version}-%{release}
138 BuildArch:      noarch
139
140 %description    MCAD
141 This library contains components commonly used in designing and
142 moching up mechanical designs. It is currently unfinished and you can
143 expect some API changes, however many things are already working.
144
145 %prep
146 %setup -q
147 %patch0 -p1
148 %patch1 -p1
149
150 # use system package
151 %{__rm} -r src/ext/polyclipping
152
153 %build
154 qmake-qt5 \
155         PREFIX=%{_prefix} \
156         CONFIG+=experimental
157 %{__make}
158
159 %if %{with tests}
160 export OPENSCAD_BINARY=$(pwd)/openscad
161 cd tests
162 %cmake .
163 %{__make}
164 %{__make} -j1 test
165 %endif
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169 %{__make} install \
170         INSTALL_ROOT=$RPM_BUILD_ROOT
171
172 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/lgpl-2.1.txt
173 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/README.markdown
174 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/libraries/MCAD/TODO
175 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
176
177 %{__mv} $RPM_BUILD_ROOT%{_datadir}/{%{name},}/locale
178
179 %find_lang %{name}
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %files -f %{name}.lang
185 %defattr(644,root,root,755)
186 %doc README.md RELEASE_NOTES.md
187 %attr(755,root,root) %{_bindir}/%{name}
188 %{_datadir}/metainfo/*.xml
189 %{_desktopdir}/%{name}.desktop
190 %{_iconsdir}/hicolor/*x*/apps/openscad.png
191 %{_datadir}/mime/packages/%{name}.xml
192 %dir %{_datadir}/%{name}
193 %{_datadir}/%{name}/examples
194 %{_datadir}/%{name}/color-schemes
195 %dir %{_datadir}/%{name}/libraries
196 %{_datadir}/%{name}/templates
197 %{_mandir}/man1/*
198
199 %files MCAD
200 %defattr(644,root,root,755)
201 %doc libraries/MCAD/README.markdown libraries/MCAD/TODO
202 %{_datadir}/%{name}/libraries/MCAD
This page took 0.093436 seconds and 3 git commands to generate.