]> git.pld-linux.org Git - packages/openfec.git/blob - openfec.spec
67495c2a44eb600dbb472cc5f225b13f5480e034
[packages/openfec.git] / openfec.spec
1 Summary:        Application-Level Forward Erasure Correction codes
2 Summary(pl.UTF-8):      Kody korygujące dla usuniętych informacji działające w warstwie aplikacji
3 Name:           openfec
4 Version:        1.4.2
5 %define tagver  %(echo %{version} | tr . _)
6 Release:        1
7 License:        CeCILL-C
8 Group:          Libraries
9 #Source0Download: http://openfec.org/downloads.html
10 Source0:        http://openfec.org/files/%{name}_v%{tagver}.tgz
11 # Source0-md5:  c4f8b0aa3e9352f2e713e3db2885ea1c
12 URL:            http://openfec.org/
13 BuildRequires:  cmake >= 2.6
14 BuildRequires:  rpmbuild(macros) >= 1.605
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 OpenFEC library implements Application-Level Forward Erasure
19 Correction codes, or AL-FEC (also called UL-FEC, for Upper-Layers
20 FEC). The idea, in one line, is to add redundancy in order to be able
21 to recover from erasures. Because of their position in the
22 communication stack, these codes are implemented as software codecs,
23 and they find many applications in robust transmission and distrituted
24 storage systems.
25
26 %description -l pl.UTF-8
27 Biblioteka OpenFEC implementuje kody korygujące dla usuniętych
28 informacji działające w warstwie aplikacji (AL-FEC, UL-FEC -
29 Application-Level Forward Erasure Correction, Upper-Layers Forward
30 Erasure Correction). Idea to w skrócie dodanie redundancji, aby
31 umożliwić odtworzenie usuniętych informacji. Ze względu na położenie w
32 stosie komunikacyjnym kody te są zaimplementowane jako programowe
33 kodeki, mające zastosowanie w mocnych systemach transmisji i
34 przechowywania danych.
35
36 %package devel
37 Summary:        Header files for OpenFEC library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenFEC
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41
42 %description devel
43 Header files for OpenFEC library.
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe biblioteki OpenFEC.
47
48 %prep
49 %setup -q -n %{name}_v%{version}
50
51 %build
52 install -d build
53 cd build
54 %cmake ..
55
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}}
61 install -d $RPM_BUILD_ROOT%{_includedir}/openfec/{lib_advanced/ldpc_from_file,lib_common,lib_stable/{2d_parity_matrix,ldpc_staircase,reed-solomon_gf_2_{8,m}}}
62
63 install bin/Release/eperftool $RPM_BUILD_ROOT%{_bindir}
64 cp -a bin/Release/libopenfec.so* $RPM_BUILD_ROOT%{_libdir}
65
66 cp -p src/lib_advanced/ldpc_from_file/{of_codec_profile,of_ldpc_ff_api}.h $RPM_BUILD_ROOT%{_includedir}/openfec/lib_advanced/ldpc_from_file
67 cp -p src/lib_common/{of_debug,of_openfec_api,of_openfec_profile,of_types}.h $RPM_BUILD_ROOT%{_includedir}/openfec/lib_common
68 cp -p src/lib_stable/2d_parity_matrix/{of_2d_parity_api,of_codec_profile}.h $RPM_BUILD_ROOT%{_includedir}/openfec/lib_stable/2d_parity_matrix
69 cp -p src/lib_stable/ldpc_staircase/{of_codec_profile,of_ldpc_staircase_api}.h $RPM_BUILD_ROOT%{_includedir}/openfec/lib_stable/ldpc_staircase
70 cp -p src/lib_stable/reed-solomon_gf_2_8/{of_codec_profile,of_reed-solomon_gf_2_8_api}.h $RPM_BUILD_ROOT%{_includedir}/openfec/lib_stable/reed-solomon_gf_2_8
71 cp -p src/lib_stable/reed-solomon_gf_2_m/{of_codec_profile,of_reed-solomon_gf_2_m_api}.h $RPM_BUILD_ROOT%{_includedir}/openfec/lib_stable/reed-solomon_gf_2_m
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post   -p /sbin/ldconfig
77 %postun -p /sbin/ldconfig
78
79 %files
80 %defattr(644,root,root,755)
81 %doc CHANGELOG LICENCE_CeCILL-C_V1-en.txt Licence_CeCILL_V2-en.txt README
82 %attr(755,root,root) %{_bindir}/eperftool
83 %attr(755,root,root) %{_libdir}/libopenfec.so.*.*.*
84 %attr(755,root,root) %ghost %{_libdir}/libopenfec.so.1
85
86 %files devel
87 %defattr(644,root,root,755)
88 %attr(755,root,root) %{_libdir}/libopenfec.so
89 %{_includedir}/openfec
This page took 0.046065 seconds and 2 git commands to generate.