]> git.pld-linux.org Git - packages/open-mx.git/blob - open-mx.spec
- initial
[packages/open-mx.git] / open-mx.spec
1 # TODO: finish PLDizing kernel module package
2 #
3 # Conditional build:
4 %bcond_without  dist_kernel     # allow non-distribution kernel
5 %bcond_without  kernel          # kernel module
6 %bcond_without  userspace       # userspace programs
7
8 %if %{without kernel}
9 %undefine       with_dist_kernel
10 %endif
11 Summary:        OpenMX - Myrinet Express over generic Ethernet hardware
12 Summary(pl.UTF-8):      OpenMX - Myrinet Express po zwykłym sprzęcie ethernetowym
13 Name:           open-mx
14 Version:        1.5.3
15 Release:        0.1
16 License:        GPL v2 (tools), LGPL v2.1 (libraries)
17 Group:          Applications
18 Source0:        http://gforge.inria.fr/frs/download.php/32114/%{name}-%{version}.tar.gz
19 # Source0-md5:  b0eb065f7df5aa888fd4d15846b7b023
20 URL:            http://open-mx.org/
21 BuildRequires:  hwloc-devel >= 1.0
22 %{?with_dist_kernel:BuildRequires:      kernel-module-build}
23 BuildRequires:  pkgconfig
24 Requires:       %{name}-libs = %{version}-%{release}
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Open-MX is a high-performance implementation of the Myrinet Express
29 message-passing stack over generic Ethernet networks. It provides
30 application-level and wire-protocol compatibility with the native MXoE
31 (Myrinet Express over Ethernet) stack.
32
33 %description -l pl.UTF-8
34 Open-MX to wysoko wydajna implementacja stosu przekazywania
35 komunikatów Myrinet Express po zwykłych sieciach Ethernet. Zapewnia
36 zgodność na poziomie aplikacji oraz protokołu sieciowego z natywnym
37 stosem MXoE (Myrinet Express over Ethernet).
38
39 %package libs
40 Summary:        Open-MX library
41 Summary(pl.UTF-8):      Biblioteka Open-MX
42 Group:          Libraries
43
44 %description libs
45 Open-MX library.
46
47 %description libs -l pl.UTF-8
48 Biblioteka Open-MX.
49
50 %package devel
51 Summary:        Header files for Open-MX library
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Open-MX
53 Group:          Development/Libraries
54 Requires:       %{name}-libs = %{version}-%{release}
55
56 %description devel
57 Header files for Open-MX library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki Open-MX.
61
62 %package static
63 Summary:        Static Open-MX library
64 Summary(pl.UTF-8):      Statyczna biblioteka Open-MX
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static Open-MX library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka Open-MX.
73
74 %package -n kernel%{_alt_kernel}-misc-open-mx
75 Summary:        Linux driver for Open-MX
76 Summary(pl.UTF-8):      Sterownik Open-MX dla Linuksa
77 Group:          Base/Kernel
78 Requires(post,postun):  /sbin/depmod
79 %if %{with dist_kernel}
80 %requires_releq_kernel
81 Requires(postun):       %releq_kernel
82 %endif
83
84 %description -n kernel%{_alt_kernel}-misc-open-mx
85 Linux driver for Open-MX.
86
87 %description -n kernel%{_alt_kernel}-misc-open-mx -l pl.UTF-8
88 Sterownik Open-MX dla Linuksa.
89
90 %prep
91 %setup -q
92
93 %build
94 %configure \
95         --disable-debug \
96         %{!?with_kernel:--disable-driver-build} \
97         --disable-silent-rules \
98         --with-linux=%{_kernelsrcdir} \
99         --with-linux-build=%{_kernelsrcdir} \
100         --with-linux-release=%{_kernel_ver}
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT \
108         installmoddir=/lib/modules/%{_kernel_ver}/misc
109
110 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
111 %{__rm} -r $RPM_BUILD_ROOT%{_bindir}/tests
112
113 %py_postclean
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   libs -p /sbin/ldconfig
119 %postun libs -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_bindir}/omx_check
124 %attr(755,root,root) %{_bindir}/omx_counters
125 %attr(755,root,root) %{_bindir}/omx_endpoint_info
126 %attr(755,root,root) %{_bindir}/omx_hostname
127 %attr(755,root,root) %{_bindir}/omx_info
128 %attr(755,root,root) %{_bindir}/omx_init_peers
129 %attr(755,root,root) %{_bindir}/omx_prepare_binding
130 %attr(755,root,root) %{_bindir}/omxoed
131 %attr(755,root,root) %{_sbindir}/omx_init
132 %attr(755,root,root) %{_sbindir}/omx_local_install
133 %dir %{_sysconfdir}/open-mx
134 %{_sysconfdir}/open-mx/10-open-mx.rules
135 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/open-mx/open-mx.conf
136 %{_mandir}/man1/omx_counters.1*
137 %{_mandir}/man1/omx_endpoint_info.1*
138 %{_mandir}/man1/omx_hostname.1*
139 %{_mandir}/man1/omx_info.1*
140 %{_mandir}/man1/omx_init_peers.1*
141 %{_mandir}/man1/omx_perf.1*
142 %{_mandir}/man1/omx_prepare_binding.1*
143
144 %files libs
145 %defattr(644,root,root,755)
146 %doc AUTHORS COPYING ChangeLog README REPORTING-BUGS TODO
147 %attr(755,root,root) %{_libdir}/libopen-mx.so.*.*.*
148 %attr(755,root,root) %ghost %{_libdir}/libopen-mx.so.0
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libopen-mx.so
153 # compatibility symlink
154 %attr(755,root,root) %{_libdir}/libmyriexpress.so
155 %{_includedir}/mx_internals
156 %{_includedir}/mx_extensions.h
157 %{_includedir}/mx_io.h
158 %{_includedir}/mx_raw.h
159 %{_includedir}/myriexpress.h
160 %{_includedir}/open-mx.h
161
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/libopen-mx.a
165 # compatibility symlink
166 %{_libdir}/libmyriexpress.a
167
168 %if %{with kernel}
169 %files -n kernel%{_alt_kernel}-misc-open-mx
170 %defattr(644,root,root,755)
171 /lib/modules/%{_kernel_ver}/misc/open-mx.ko*
172 %endif
This page took 0.076545 seconds and 3 git commands to generate.