]> git.pld-linux.org Git - packages/opal.git/blob - opal.spec
- updated to 3.18.8
[packages/opal.git] / opal.spec
1 # TODO:
2 #       SBC plugin is missing bluez_sbc subdir
3 #       fix static libname (libopal_s.a)
4 #       MPEG4 rate control correction requires libavcodec sources
5 # NOTE: IPv6 support requires IPv6 support in ptlib
6 #
7 # WARNING: opal version should match Ekiga and ptlib versions
8 #       Recommendations: http://wiki.ekiga.org/index.php/Download_Ekiga_sources
9 #       (for ekiga 4.0.x it's ptlib 2.10.x + opal 3.10.x)
10 #
11 # Conditional build:
12 %bcond_with     sip_fax_only    # minimal build for t38modem + SIP
13 %bcond_without  celt            # CELT codec support
14 %bcond_without  srtp            # SRTP protocol support (mutually exclusive with zrtp)
15 %bcond_with     zrtp            # ZRTP protocol support (mutually exclusive with srtp; broken as of 3.10.9)
16 %bcond_with     capi            # CAPI support
17 %bcond_with     vpb             # Voicetronix VPB support
18 %bcond_with     java            # Java JNI interface (only swig wrapper, Java part not built)
19 %bcond_with     ruby            # Ruby interface (very initial, only swig wrapper)
20 #
21 %if %{with zrtp}
22 %undefine       with_srtp
23 %endif
24 %if %{with sip_fax_only}
25 %undefine       with_java
26 %undefine       with_ruby
27 %undefine       with_srtp
28 %undefine       with_zrtp
29 %endif
30 Summary:        Open Phone Abstraction Library (aka OpenH323 v2)
31 Summary(pl.UTF-8):      Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
32 Name:           opal
33 Version:        3.18.8
34 Release:        1
35 License:        MPL v1.0
36 Group:          Libraries
37 Source0:        http://downloads.sourceforge.net/opalvoip/%{name}-%{version}.tar.bz2
38 # Source0-md5:  1f48ea0bef4b0731b4af19928eb02c36
39 Patch0:         celt.patch
40 Patch1:         g7221.patch
41 Patch2:         %{name}-cxx11.patch
42 # domain suspended (2022.04)
43 #URL:           http://www.opalvoip.org/
44 URL:            https://sourceforge.net/projects/opalvoip/
45 BuildRequires:  autoconf >= 2.50
46 BuildRequires:  automake
47 %{?with_capi:BuildRequires:     capi4k-utils-devel}
48 %{?with_celt:BuildRequires:     celt-devel}
49 BuildRequires:  expat-devel
50 %{?with_srtp:BuildRequires:     libsrtp2-devel}
51 BuildRequires:  libstdc++-devel
52 %{?with_zrtp:BuildRequires:     libzrtp-devel}
53 BuildRequires:  pkgconfig
54 BuildRequires:  ptlib-devel >= 1:2.18.5
55 BuildRequires:  sed >= 4.0
56 BuildRequires:  speex-devel >= 1:1.2
57 BuildRequires:  speexdsp-devel >= 1.2
58 %if %{without sip_fax_only}
59 BuildRequires:  SDL-devel
60 # libavcodec >= 51.11.0 libavutil
61 BuildRequires:  ffmpeg-devel
62 %{?with_java:BuildRequires:     jdk}
63 BuildRequires:  libgsm-devel
64 BuildRequires:  libtheora-devel
65 %{?with_vpb:BuildRequires:      vpb-devel}
66 # ABI 0.102
67 BuildRequires:  libx264-devel >= 0.1.3-1.20101031_2245.1
68 BuildRequires:  openh264-devel
69 BuildRequires:  openssl-devel
70 %{?with_ruby:BuildRequires:     ruby-devel}
71 BuildRequires:  spandsp-devel
72 BuildRequires:  swig
73 BuildRequires:  unixODBC-devel
74 BuildRequires:  webrtc-libilbc-devel
75 %endif
76 %requires_eq    ptlib
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %description
80 The OPAL project aims to create a full featured, interoperable, Open
81 Source implementation of the ITU H.323 teleconferencing protocol that
82 can be used by personal developers and commercial users without
83 charge.
84
85 %description -l pl.UTF-8
86 Celem projektu OPAL jest stworzenie w pełni funkcjonalnej i
87 wyposażonej implementacji protokołu telekonferencyjnego ITU H.323,
88 który może być używany przez użytkowników prywatnych i komercyjnych
89 bez opłat.
90
91 %package lid-vpb
92 Summary:        Opal LID plugin for Voicetronix VPB devices
93 Summary(pl.UTF-8):      Wtyczka Opal LID dla urządzeń VPB firmy Voicetronix
94 Group:          Libraries
95 Requires:       %{name} = %{version}-%{release}
96
97 %description lid-vpb
98 Opal LID plugin for Voicetronix VPB devices.
99
100 %description lid-vpb -l pl.UTF-8
101 Wtyczka Opal LID dla urządzeń VPB firmy Voicetronix.
102
103 %package devel
104 Summary:        Opal development files
105 Summary(pl.UTF-8):      Pliki dla developerów Opal
106 Group:          Development/Libraries
107 Requires:       %{name} = %{version}-%{release}
108 %{?with_capi:Requires: capi4k-utils-devel}
109 %{?with_srtp:Requires: libsrtp2-devel}
110 Requires:       libstdc++-devel
111 %{?with_zrtp:Requires: libzrtp-devel}
112 Requires:       ptlib-devel >= 1:2.18.5
113 Requires:       speex-devel >= 1:1.2
114
115 %description devel
116 Header files and libraries for developing applications that use OPAL.
117
118 %description devel -l pl.UTF-8
119 Pliki nagłówkowe i biblioteki konieczne do rozwoju aplikacji
120 używających OPAL.
121
122 %package static
123 Summary:        OPAL static libraries
124 Summary(pl.UTF-8):      Biblioteki statyczne OPAL
125 Group:          Development/Libraries
126 Requires:       %{name}-devel = %{version}-%{release}
127
128 %description static
129 OPAL static libraries.
130
131 %description static -l pl.UTF-8
132 Biblioteki statyczne OPAL.
133
134 %prep
135 %setup -q
136 %patch0 -p1
137 %patch1 -p1
138 %patch2 -p1
139
140 %build
141 PWLIBDIR=%{_prefix}; export PWLIBDIR
142 OPALDIR=`pwd`; export OPALDIR
143 OPAL_BUILD="yes"; export OPAL_BUILD
144 cd plugins
145 %{__aclocal}
146 %{__autoconf}
147 cd ..
148 # Run  grep '^OPAL_.*=' configure.ac|grep 'yes\|no'  to check current defaults
149 %configure \
150         %{?with_java:JDK_ROOT=%{_jvmdir}/java} \
151 %if %{with sip_fax_only}
152         --disable-aec \
153         --disable-g711plc \
154         --disable-h224 \
155         --disable-h281 \
156         --disable-h323 \
157         --disable-h450 \
158         --disable-h460 \
159         --disable-h501 \
160         --disable-iax \
161         --disable-ivr \
162         --disable-lid \
163         --disable-plugins
164         --disable-rfc4103 \
165         --disable-rfc4175 \
166         --disable-sipim \
167         --disable-video \
168 %else
169         --enable-ixj \
170 %endif
171         %{!?with_capi:--disable-capi} \
172         %{!?with_celt:--disable-celt} \
173         --disable-dahdi \
174         %{!?with_java:--disable-java} \
175         %{!?with_ruby:--disable-ruby} \
176         %{!?with_srtp:--disable-srtp} \
177         %{?with_vpb:--enable-vpb} \
178 %if %{with zrtp}
179         --enable-zrtp \
180         --with-bn-includedir=/usr/include \
181         --with-bn-libdir=%{_libdir} \
182         --with-zrtp-includedir=/usr/include/libzrtp \
183         --with-zrtp-libdir=%{_libdir}
184 %endif
185
186 %{__make} %{?debug:debug}%{!?debug:opt} \
187         CC="%{__cc}" \
188         CPLUS="%{__cxx}" \
189         OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}" \
190         VERBOSE=1
191
192 %install
193 rm -rf $RPM_BUILD_ROOT
194 install -d $RPM_BUILD_ROOT%{_libdir}/opal-%{version}/lid
195
196 %{__make} install \
197         DESTDIR=$RPM_BUILD_ROOT
198
199 %clean
200 rm -rf $RPM_BUILD_ROOT
201
202 %post   -p /sbin/ldconfig
203 %postun -p /sbin/ldconfig
204
205 %files
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_libdir}/libopal.so.%{version}
208 %if %{without sip_fax_only}
209 %dir %{_libdir}/opal-%{version}
210 %dir %{_libdir}/opal-%{version}/codecs
211 %dir %{_libdir}/opal-%{version}/codecs/audio
212 %{?with_celt:%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/celt_ptplugin.so}
213 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g7221_ptplugin.so
214 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g7222_ptplugin.so
215 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g722_ptplugin.so
216 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g726_ptplugin.so
217 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/gsm0610_ptplugin.so
218 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/gsmamrcodec_ptplugin.so
219 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/iLBC_ptplugin.so
220 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/ima_adpcm_ptplugin.so
221 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/iSAC_ptplugin.so
222 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/lpc10_ptplugin.so
223 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/opus_ptplugin.so
224 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/silk_ptplugin.so
225 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/speex_ptplugin.so
226 %dir %{_libdir}/opal-%{version}/codecs/video
227 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h261_vic_ptplugin.so
228 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h263_ffmpeg_ptplugin.so
229 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h264_video_pwplugin_helper
230 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h264_x264_ptplugin.so
231 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/mpeg4_ffmpeg_ptplugin.so
232 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/openh264_ptplugin.so
233 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/theora_ptplugin.so
234 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/vp8_webm_ptplugin.so
235 %dir %{_libdir}/opal-%{version}/fax
236 %attr(755,root,root) %{_libdir}/opal-%{version}/fax/spandsp_ptplugin.so
237 %endif
238 %dir %{_libdir}/opal-%{version}/lid
239
240 %if %{with vpb}
241 %files lid-vpb
242 %defattr(644,root,root,755)
243 %attr(755,root,root) %{_libdir}/opal-%{version}/lid/vpb_ptplugin.so
244 %endif
245
246 %files devel
247 %defattr(644,root,root,755)
248 %attr(755,root,root) %{_libdir}/libopal.so
249 %{_includedir}/opal
250 %{_pkgconfigdir}/opal.pc
251 %{_datadir}/opal
252
253 %files static
254 %defattr(644,root,root,755)
255 %{_libdir}/libopal_s.a
This page took 0.079125 seconds and 3 git commands to generate.