]> git.pld-linux.org Git - packages/opal.git/blob - opal.spec
2a9ea5c81f5bf594c3fa70528f8c2ab70c87794c
[packages/opal.git] / opal.spec
1 # TODO:
2 #       SBC plugin is missing bluez_sbc subdir
3 #       fix static libname (libopal_s.a)
4 #       MPEG4 rate control correction requires libavcodec sources
5 # NOTE: IPv6 support requires IPv6 support in ptlib
6 #
7 # WARNING: opal version should match Ekiga and ptlib versions
8 #       Recommendations: http://wiki.ekiga.org/index.php/Download_Ekiga_sources
9 #       (for ekiga 4.0.x it's ptlib 2.10.x + opal 3.10.x)
10 #
11 # Conditional build:
12 %bcond_with     sip_fax_only    # minimal build for t38modem + SIP
13 %bcond_without  celt            # CELT codec support
14 %bcond_without  srtp            # SRTP protocol support (mutually exclusive with zrtp)
15 %bcond_with     zrtp            # ZRTP protocol support (mutually exclusive with srtp; broken as of 3.10.9)
16 %bcond_with     capi            # CAPI support
17 %bcond_with     vpb             # Voicetronix VPB support
18 %bcond_with     java            # Java JNI interface (only swig wrapper, Java part not built)
19 %bcond_with     ruby            # Ruby interface (very initial, only swig wrapper)
20 #
21 %if %{with zrtp}
22 %undefine       with_srtp
23 %endif
24 %if %{with sip_fax_only}
25 %undefine       with_java
26 %undefine       with_ruby
27 %undefine       with_srtp
28 %undefine       with_zrtp
29 %endif
30 Summary:        Open Phone Abstraction Library (aka OpenH323 v2)
31 Summary(pl.UTF-8):      Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
32 Name:           opal
33 Version:        3.18.6
34 Release:        1
35 License:        MPL v1.0
36 Group:          Libraries
37 Source0:        http://downloads.sourceforge.net/opalvoip/%{name}-%{version}.tar.bz2
38 # Source0-md5:  0b4dfe603834b3cf2252782f1594403d
39 Patch0:         celt.patch
40 Patch1:         g7221.patch
41 URL:            http://www.opalvoip.org/
42 BuildRequires:  autoconf >= 2.50
43 BuildRequires:  automake
44 %{?with_capi:BuildRequires:     capi4k-utils-devel}
45 %{?with_celt:BuildRequires:     celt-devel}
46 BuildRequires:  expat-devel
47 %{?with_srtp:BuildRequires:     libsrtp2-devel}
48 BuildRequires:  libstdc++-devel
49 %{?with_zrtp:BuildRequires:     libzrtp-devel}
50 BuildRequires:  pkgconfig
51 BuildRequires:  ptlib-devel >= 1:2.18.5
52 BuildRequires:  sed >= 4.0
53 BuildRequires:  speex-devel >= 1:1.2
54 BuildRequires:  speexdsp-devel >= 1.2
55 %if %{without sip_fax_only}
56 BuildRequires:  SDL-devel
57 # libavcodec >= 51.11.0 libavutil
58 BuildRequires:  ffmpeg-devel
59 %{?with_java:BuildRequires:     jdk}
60 BuildRequires:  libgsm-devel
61 BuildRequires:  libtheora-devel
62 %{?with_vpb:BuildRequires:      vpb-devel}
63 # ABI 0.102
64 BuildRequires:  libx264-devel >= 0.1.3-1.20101031_2245.1
65 BuildRequires:  openssl-devel
66 %{?with_ruby:BuildRequires:     ruby-devel}
67 BuildRequires:  spandsp-devel
68 BuildRequires:  swig
69 BuildRequires:  unixODBC-devel
70 BuildRequires:  webrtc-libilbc-devel
71 %endif
72 BuildConflicts: dahdi-linux-devel
73 %requires_eq    ptlib
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %description
77 The OPAL project aims to create a full featured, interoperable, Open
78 Source implementation of the ITU H.323 teleconferencing protocol that
79 can be used by personal developers and commercial users without
80 charge.
81
82 %description -l pl.UTF-8
83 Celem projektu OPAL jest stworzenie w pełni funkcjonalnej i
84 wyposażonej implementacji protokołu telekonferencyjnego ITU H.323,
85 który może być używany przez użytkowników prywatnych i komercyjnych
86 bez opłat.
87
88 %package lid-vpb
89 Summary:        Opal LID plugin for Voicetronix VPB devices
90 Summary(pl.UTF-8):      Wtyczka Opal LID dla urządzeń VPB firmy Voicetronix
91 Group:          Libraries
92 Requires:       %{name} = %{version}-%{release}
93
94 %description lid-vpb
95 Opal LID plugin for Voicetronix VPB devices.
96
97 %description lid-vpb -l pl.UTF-8
98 Wtyczka Opal LID dla urządzeń VPB firmy Voicetronix.
99
100 %package devel
101 Summary:        Opal development files
102 Summary(pl.UTF-8):      Pliki dla developerów Opal
103 Group:          Development/Libraries
104 Requires:       %{name} = %{version}-%{release}
105 %{?with_capi:Requires: capi4k-utils-devel}
106 %{?with_srtp:Requires: libsrtp2-devel}
107 Requires:       libstdc++-devel
108 %{?with_zrtp:Requires: libzrtp-devel}
109 Requires:       ptlib-devel >= 1:2.18.5
110 Requires:       speex-devel >= 1:1.2
111
112 %description devel
113 Header files and libraries for developing applications that use OPAL.
114
115 %description devel -l pl.UTF-8
116 Pliki nagłówkowe i biblioteki konieczne do rozwoju aplikacji
117 używających OPAL.
118
119 %package static
120 Summary:        OPAL static libraries
121 Summary(pl.UTF-8):      Biblioteki statyczne OPAL
122 Group:          Development/Libraries
123 Requires:       %{name}-devel = %{version}-%{release}
124
125 %description static
126 OPAL static libraries.
127
128 %description static -l pl.UTF-8
129 Biblioteki statyczne OPAL.
130
131 %prep
132 %setup -q
133 %patch0 -p1
134 %patch1 -p1
135
136 %build
137 PWLIBDIR=%{_prefix}; export PWLIBDIR
138 OPALDIR=`pwd`; export OPALDIR
139 OPAL_BUILD="yes"; export OPAL_BUILD
140 cd plugins
141 %{__aclocal}
142 %{__autoconf}
143 cd ..
144 # Run  grep '^OPAL_.*=' configure.ac|grep 'yes\|no'  to check current defaults
145 %configure \
146         %{?with_java:JDK_ROOT=%{_jvmdir}/java} \
147 %if %{with sip_fax_only}
148         --disable-aec \
149         --disable-g711plc \
150         --disable-h224 \
151         --disable-h281 \
152         --disable-h323 \
153         --disable-h450 \
154         --disable-h460 \
155         --disable-h501 \
156         --disable-iax \
157         --disable-ivr \
158         --disable-lid \
159         --disable-plugins
160         --disable-rfc4103 \
161         --disable-rfc4175 \
162         --disable-sipim \
163         --disable-video \
164 %else
165         --enable-ixj \
166 %endif
167         %{!?with_capi:--disable-capi} \
168         %{!?with_celt:--disable-celt} \
169         %{!?with_java:--disable-java} \
170         %{!?with_ruby:--disable-ruby} \
171         %{!?with_srtp:--disable-srtp} \
172         %{?with_vpb:--enable-vpb} \
173 %if %{with zrtp}
174         --enable-zrtp \
175         --with-bn-includedir=/usr/include \
176         --with-bn-libdir=%{_libdir} \
177         --with-zrtp-includedir=/usr/include/libzrtp \
178         --with-zrtp-libdir=%{_libdir}
179 %endif
180
181 %{__make} %{?debug:debug}%{!?debug:opt} \
182         CC="%{__cc}" \
183         CPLUS="%{__cxx}" \
184         OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}" \
185         VERBOSE=1
186
187 %install
188 rm -rf $RPM_BUILD_ROOT
189 install -d $RPM_BUILD_ROOT%{_libdir}/opal-%{version}/lid
190
191 %{__make} install \
192         DESTDIR=$RPM_BUILD_ROOT
193
194 %clean
195 rm -rf $RPM_BUILD_ROOT
196
197 %post   -p /sbin/ldconfig
198 %postun -p /sbin/ldconfig
199
200 %files
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/libopal.so.%{version}
203 %if %{without sip_fax_only}
204 %dir %{_libdir}/opal-%{version}
205 %dir %{_libdir}/opal-%{version}/codecs
206 %dir %{_libdir}/opal-%{version}/codecs/audio
207 %{?with_celt:%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/celt_ptplugin.so}
208 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g7221_ptplugin.so
209 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g7222_ptplugin.so
210 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g722_ptplugin.so
211 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g726_ptplugin.so
212 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/gsm0610_ptplugin.so
213 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/gsmamrcodec_ptplugin.so
214 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/iLBC_ptplugin.so
215 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/ima_adpcm_ptplugin.so
216 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/iSAC_ptplugin.so
217 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/lpc10_ptplugin.so
218 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/opus_ptplugin.so
219 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/silk_ptplugin.so
220 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/speex_ptplugin.so
221 %dir %{_libdir}/opal-%{version}/codecs/video
222 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h261_vic_ptplugin.so
223 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h263_ffmpeg_ptplugin.so
224 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h264_video_pwplugin_helper
225 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h264_x264_ptplugin.so
226 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/mpeg4_ffmpeg_ptplugin.so
227 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/theora_ptplugin.so
228 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/vp8_webm_ptplugin.so
229 %dir %{_libdir}/opal-%{version}/fax
230 %attr(755,root,root) %{_libdir}/opal-%{version}/fax/spandsp_ptplugin.so
231 %endif
232 %dir %{_libdir}/opal-%{version}/lid
233
234 %if %{with vpb}
235 %files lid-vpb
236 %defattr(644,root,root,755)
237 %attr(755,root,root) %{_libdir}/opal-%{version}/lid/vpb_ptplugin.so
238 %endif
239
240 %files devel
241 %defattr(644,root,root,755)
242 %attr(755,root,root) %{_libdir}/libopal.so
243 %{_includedir}/opal
244 %{_pkgconfigdir}/opal.pc
245 %{_datadir}/opal/make
246
247 %files static
248 %defattr(644,root,root,755)
249 %{_libdir}/libopal_s.a
This page took 0.066259 seconds and 2 git commands to generate.