]> git.pld-linux.org Git - packages/omniORB.git/blob - omniORB.spec
- formatting
[packages/omniORB.git] / omniORB.spec
1 # TODO:
2 #  - python stuff is wrong
3 #  - move some binaries from main to devel (main should only contain server)
4 #  - ditto for documentation
5 #  - logrotate script
6 #  - enable openssl
7 Summary:        Object Request Broker (ORB) from AT&T (CORBA 2.6)
8 Summary(pl):    Object Request Broker (ORB) z AT&T (CORBA 2.6)
9 Name:           omniORB
10 Version:        4.0.0
11 Release:        0.1
12 License:        GPL/LGPL
13 Group:          Libraries
14 Source0:        http://telia.dl.sourceforge.net/omniorb/%{name}-%{version}.tar.gz
15 # Source0-md5: c5dbd122c992ea1df4f6adf5e72644b1
16 Source1:        %{name}.init
17 URL:            http://omniorb.sf.net/
18 Requires:       %{name}-libs = %{version}-%{release}
19 Requires(post,preun):   /sbin/chkconfig
20 BuildRequires:  gcc-c++
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 omniORB is an Object Request Broker (ORB) which implements
25 specification 2.6 of the Common Object Request Broker Architecture
26 (CORBA).
27
28 %description -l pl
29 omniORB implementuje wersjê 2.6 specyfikacji CORBA.
30
31 %package devel
32 Summary:        Development files for %{name}
33 Summary(pl):    Pliki potrzebne do tworzenia aplikacji z u¿yciem %{name}
34 Requires:       %{name} = %{version}-%{release}
35 Group:          Development/Libraries
36
37 %description devel
38 Development files for %{name}.
39
40 %description devel -l pl
41 Pliki potrzebne do tworzenia aplikacji z u¿yciem %{name}.
42
43 %package libs
44 Summary:        Shared libraries for %{name}
45 Summary(pl):    Dzielone biblioteki dla aplikacji korzystaj±cych z %{name}
46 Group:          Libraries
47
48 %description libs
49 Shared libraries for %{name}.
50
51 %description libs -l pl
52 Dzielone biblioteki dla aplikacji korzystaj±cych z %{name}.
53
54 %package static
55 Summary:        Static files for %{name}
56 Summary(pl):    Statyczne biblioteki dla %{name}
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static files for %{name}.
62
63 %description static -l pl
64 Statyczne biblioteki dla %{name}.
65
66 %prep
67 %setup -q
68
69 %build
70 rm -f missing
71 %{__aclocal}
72 %{__autoconf}
73 %{__autoheader}
74 %configure --with-omniNames-logdir=/var/log/%{name}
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_sysconfdir}/rc.d/init.d,/var/log/%{name}}
80
81 %{__make} install DESTDIR=$RPM_BUILD_ROOT
82
83 install man/man1/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
84 install sample.cfg $RPM_BUILD_ROOT%{_sysconfdir}/omniORB.cfg
85 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/%{name}
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post libs -p /sbin/ldconfig
91 %postun libs -p /sbin/ldconfig
92
93 %post 
94 /sbin/chkconfig --add sensors
95 if [ -f /var/lock/subsys/%{name} ]; then
96         /etc/rc.d/init.d/%{name} restart >&2
97 else
98         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon." >&2
99 fi
100
101 %preun
102 if [ "$1" = "0" ]; then
103         if [ -f /var/lock/subsys/%{name} ]; then
104                 /etc/rc.d/init.d/%{name} stop >&2
105         fi
106         /sbin/chkconfig --del %{name}
107 fi
108
109 %files
110 %defattr(644,root,root,755)
111 %doc ReleaseNotes_%{version}.txt CREDITS README.{FIRST,unix}
112 %attr(755,root,root) %{_bindir}/*
113 %dir /var/log/%{name}
114 %attr(755,root,root) %{_sysconfdir}/rc.d/init.d/*
115 %{_sysconfdir}/%{name}.cfg
116 %{_mandir}/man1/*
117 %attr(755,root,root) %{_libdir}/python*/site-packages/*.so*
118 %{_libdir}/python*/site-packages/omniidl
119 %{_libdir}/python*/site-packages/omniidl_be
120
121 %files libs
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/*.so.*
124
125 %files static
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_libdir}/*.a
128
129 %files devel
130 %defattr(644,root,root,755)
131 %doc doc/*.html doc/omniORB
132 %attr(755,root,root) %{_libdir}/*.so
133 %{_includedir}/*
134 %{_datadir}/idl/%{name}
This page took 0.104665 seconds and 3 git commands to generate.