]> git.pld-linux.org Git - packages/ois.git/blob - ois.spec
80d75551235c7feeeae9ec8fc50158ef34752e32
[packages/ois.git] / ois.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         file_version    %(echo %{version} | tr . -)
6 Summary:        Object Oriented Input System
7 Summary(pl.UTF-8):      Zorientowany obiektowo system wejścia
8 Name:           ois
9 Version:        1.3
10 Release:        1
11 License:        zlib/libpng
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/wgois/%{name}_v%{file_version}.tar.gz
14 # Source0-md5:  9697fead17eac6025151cd2e1fca1518
15 URL:            http://ostatic.com/wgois/
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake >= 1.6
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool >= 2:1.4
20 BuildRequires:  xorg-lib-libXaw-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The goal of OIS is shield the application programmer from having to
25 rewrite input systems from scratch for each project.
26
27 %description -l pl.UTF-8
28 Celem projektu OIS jest ochrona twórcy aplikacji przed przepisywaniem
29 na nowo systemów wejścia w każdym projekcie.
30
31 %package devel
32 Summary:        Header files for OIS library
33 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OIS
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36 Requires:       libstdc++-devel
37 Requires:       xorg-lib-libXaw-devel
38
39 %description devel
40 Header files for OIS library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki OIS.
44
45 %package static
46 Summary:        Static OIS library
47 Summary(pl.UTF-8):      Statyczna biblioteka OIS
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static OIS library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka OIS.
56
57 %prep
58 %setup -q -n %{name}-v%{file_version}
59
60 %build
61 %{__libtoolize}
62 %{__aclocal}
63 %{__autoheader}
64 %{__automake}
65 %{__autoconf}
66 %configure \
67         %{!?with_static_libs:--disable-static}
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %attr(755,root,root) %{_libdir}/libOIS-*.*.*.so
85
86 %files devel
87 %defattr(644,root,root,755)
88 %attr(755,root,root) %{_libdir}/libOIS.so
89 %{_libdir}/libOIS.la
90 %{_includedir}/OIS
91 %{_pkgconfigdir}/OIS.pc
92
93 %if %{with static_libs}
94 %files static
95 %defattr(644,root,root,755)
96 %{_libdir}/libOIS.a
97 %endif
This page took 0.058244 seconds and 2 git commands to generate.