]> git.pld-linux.org Git - packages/ogre.git/blob - ogre.spec
e4dc8705c76fdbbc3931a794a6fa3c104a2cee11
[packages/ogre.git] / ogre.spec
1 #
2 # TODO: - bconds for the rest of the plugins
3 #
4 # Conditional build:
5 %bcond_with     cg              # build with cg
6 %bcond_with     samples         # build samples (not installed anyway)
7
8 %ifnarch %{ix86} %{x8664}
9 %undefine       with_cg
10 %endif
11
12 %define fver    %(echo %{version} | tr . -)
13 Summary:        Object-oriented Graphics Rendering Engine
14 Summary(pl.UTF-8):      OGRE - zorientowany obiektowo silnik renderowania grafiki
15 Name:           ogre
16 Version:        1.8.0
17 Release:        2
18 License:        MIT
19 Group:          Applications
20 Source0:        http://downloads.sourceforge.net/ogre/%{name}_src_v%{fver}.tar.bz2
21 # Source0-md5:  3b9bcd34a39891a8bf0385ae0c5c670b
22 Patch0:         boost-1.50.patch
23 URL:            http://www.ogre3d.org/
24 %{?with_samples:BuildRequires:  CEGUI-devel}
25 BuildRequires:  FreeImage-devel
26 # no makefiles for EXR plugin
27 #BuildRequires: OpenEXR-devel
28 BuildRequires:  OpenGL-GLU-devel
29 BuildRequires:  boost-devel
30 %{?with_cg:BuildRequires:       cg-devel}
31 BuildRequires:  cmake >= 2.6.2
32 BuildRequires:  cppunit-devel >= 1.10.0
33 BuildRequires:  freetype-devel >= 2.1.0
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  rpmbuild(macros) >= 1.600
37 BuildRequires:  xorg-lib-libXaw-devel
38 BuildRequires:  xorg-lib-libXrandr-devel
39 BuildRequires:  xorg-lib-libXxf86vm-devel
40 BuildRequires:  xorg-proto-xf86vidmodeproto-devel
41 BuildRequires:  zlib-devel
42 BuildRequires:  zziplib-devel
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Object-oriented Graphics Rendering Engine.
47
48 %description -l pl.UTF-8
49 OGRE - zorientowany obiektowo silnik renderowania grafiki
50
51 %package devel
52 Summary:        Header files for OGRE library
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OGRE
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       FreeImage-devel
57 Requires:       freetype-devel >= 2.1.0
58 Requires:       libstdc++-devel
59 Requires:       zlib-devel
60 Requires:       zziplib-devel
61 # libOgrePlatform additionally: XFree86-devel/xorg-lib-libX11-devel OpenGL-GLU-devel
62
63 %description devel
64 This is the package containing the header files for OGRE library.
65
66 %description devel -l pl.UTF-8
67 Ten pakiet zawiera pliki nagłówkowe biblioteki OGRE.
68
69 %package examples
70 Summary:        OGRE samples
71 Summary(pl.UTF-8):      Przykłady do OGRE
72 Group:          Applications
73
74 %description examples
75 OGRE samples.
76
77 %description examples -l pl.UTF-8
78 Przykłady do OGRE.
79
80 %prep
81 %setup -q -n %{name}_src_v%{fver}
82 %patch0 -p1
83
84 %build
85 install -d build
86 cd build
87 # "None" is an alias for release, but uses plain CMAKE_CXX_FLAGS; "PLD" build type is not supported
88 %cmake .. \
89         -DCMAKE_BUILD_TYPE=%{?debug:Debug}%{!?debug:None} \
90         %{!?with_samples:-DOGRE_BUILD_SAMPLES=FALSE}
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
98 cp -pr Samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
99
100 %{__make} -C build install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS BUGS COPYING README
112 %attr(755,root,root) %{_bindir}/OgreMeshUpgrader
113 %attr(755,root,root) %{_bindir}/OgreXMLConverter
114 %dir %{_libdir}/OGRE
115 %attr(755,root,root) %{_libdir}/OGRE/*.so*
116 %attr(755,root,root) %{_libdir}/libOgreMain.so.*.*.*
117 %attr(755,root,root) %{_libdir}/libOgrePaging.so.*.*.*
118 %attr(755,root,root) %{_libdir}/libOgreProperty.so.*.*.*
119 %attr(755,root,root) %{_libdir}/libOgreRTShaderSystem.so.*.*.*
120 %attr(755,root,root) %{_libdir}/libOgreTerrain.so.*.*.*
121
122 %files devel
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_libdir}/libOgreMain.so
125 %attr(755,root,root) %{_libdir}/libOgrePaging.so
126 %attr(755,root,root) %{_libdir}/libOgreProperty.so
127 %attr(755,root,root) %{_libdir}/libOgreRTShaderSystem.so
128 %attr(755,root,root) %{_libdir}/libOgreTerrain.so
129 %{_includedir}/OGRE
130 %{_pkgconfigdir}/OGRE.pc
131 %{_pkgconfigdir}/OGRE-PCZ.pc
132 %{_pkgconfigdir}/OGRE-Paging.pc
133 %{_pkgconfigdir}/OGRE-Property.pc
134 %{_pkgconfigdir}/OGRE-RTShaderSystem.pc
135 %{_pkgconfigdir}/OGRE-Terrain.pc
136 %dir %{_libdir}/OGRE
137 %{_libdir}/OGRE/cmake
138
139 %files examples
140 %defattr(644,root,root,755)
141 %{_examplesdir}/%{name}-%{version}
This page took 0.074894 seconds and 2 git commands to generate.