]> git.pld-linux.org Git - packages/ogre.git/blob - ogre.spec
- rebuild with boost 1.57.0
[packages/ogre.git] / ogre.spec
1 #
2 # TODO: - bconds for the rest of the plugins
3 #
4 # Conditional build:
5 %bcond_with     cg              # build with cg
6 %bcond_with     samples         # build samples (not installed anyway)
7
8 %ifnarch %{ix86} %{x8664}
9 %undefine       with_cg
10 %endif
11
12 %define fver    %(echo %{version} | tr . -)
13 Summary:        Object-oriented Graphics Rendering Engine
14 Summary(pl.UTF-8):      OGRE - zorientowany obiektowo silnik renderowania grafiki
15 Name:           ogre
16 Version:        1.8.1
17 Release:        5
18 License:        MIT
19 Group:          Applications
20 Source0:        http://downloads.sourceforge.net/ogre/%{name}_src_v%{fver}.tar.bz2
21 # Source0-md5:  b85e3dcf370a46b3a8624d4fdd722d39
22 Patch0:         boost-1.50.patch
23 URL:            http://www.ogre3d.org/
24 %{?with_samples:BuildRequires:  CEGUI-devel}
25 BuildRequires:  FreeImage-devel
26 # no makefiles for EXR plugin
27 #BuildRequires: OpenEXR-devel
28 BuildRequires:  OpenGL-GLU-devel
29 BuildRequires:  boost-devel >= 1.40
30 %{?with_cg:BuildRequires:       cg-devel}
31 BuildRequires:  cmake >= 2.6.2
32 BuildRequires:  cppunit-devel >= 1.10.0
33 BuildRequires:  freetype-devel >= 2.1.0
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  rpmbuild(macros) >= 1.600
37 BuildRequires:  tinyxml-devel
38 BuildRequires:  xorg-lib-libX11-devel
39 BuildRequires:  xorg-lib-libXaw-devel
40 BuildRequires:  xorg-lib-libXrandr-devel
41 BuildRequires:  xorg-lib-libXt-devel
42 BuildRequires:  xorg-lib-libXxf86vm-devel
43 BuildRequires:  xorg-proto-xf86vidmodeproto-devel
44 BuildRequires:  zlib-devel
45 BuildRequires:  zziplib-devel
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Object-oriented Graphics Rendering Engine.
50
51 %description -l pl.UTF-8
52 OGRE - zorientowany obiektowo silnik renderowania grafiki
53
54 %package devel
55 Summary:        Header files for OGRE library
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OGRE
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       FreeImage-devel
60 Requires:       freetype-devel >= 2.1.0
61 Requires:       libstdc++-devel
62 Requires:       zlib-devel
63 Requires:       zziplib-devel
64 # libOgrePlatform additionally: XFree86-devel/xorg-lib-libX11-devel OpenGL-GLU-devel
65
66 %description devel
67 This is the package containing the header files for OGRE library.
68
69 %description devel -l pl.UTF-8
70 Ten pakiet zawiera pliki nagłówkowe biblioteki OGRE.
71
72 %package examples
73 Summary:        OGRE samples
74 Summary(pl.UTF-8):      Przykłady do OGRE
75 Group:          Applications
76 %if "%{_rpmversion}" >= "5"
77 BuildArch:      noarch
78 %endif
79
80 %description examples
81 OGRE samples.
82
83 %description examples -l pl.UTF-8
84 Przykłady do OGRE.
85
86 %prep
87 %setup -q -n %{name}_src_v%{fver}
88 %patch0 -p1
89
90 %build
91 install -d build
92 cd build
93 # "None" is an alias for release, but uses plain CMAKE_CXX_FLAGS; "PLD" build type is not supported
94 %cmake .. \
95         -DCMAKE_BUILD_TYPE=%{?debug:Debug}%{!?debug:None} \
96         %{!?with_samples:-DOGRE_BUILD_SAMPLES=FALSE}
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
104 cp -pr Samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
105
106 %{__make} -C build install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS BUGS COPYING README
118 %attr(755,root,root) %{_bindir}/OgreMeshUpgrader
119 %attr(755,root,root) %{_bindir}/OgreXMLConverter
120 %attr(755,root,root) %{_libdir}/libOgreMain.so.*.*.*
121 %attr(755,root,root) %{_libdir}/libOgrePaging.so.*.*.*
122 %attr(755,root,root) %{_libdir}/libOgreProperty.so.*.*.*
123 %attr(755,root,root) %{_libdir}/libOgreRTShaderSystem.so.*.*.*
124 %attr(755,root,root) %{_libdir}/libOgreTerrain.so.*.*.*
125 %dir %{_libdir}/OGRE
126 %attr(755,root,root) %{_libdir}/OGRE/Plugin_BSPSceneManager.so*
127 %if %{with cg}
128 %attr(755,root,root) %{_libdir}/OGRE/Plugin_CgProgramManager.so*
129 %endif
130 %attr(755,root,root) %{_libdir}/OGRE/Plugin_OctreeSceneManager.so*
131 %attr(755,root,root) %{_libdir}/OGRE/Plugin_OctreeZone.so*
132 %attr(755,root,root) %{_libdir}/OGRE/Plugin_PCZSceneManager.so*
133 %attr(755,root,root) %{_libdir}/OGRE/Plugin_ParticleFX.so*
134 %attr(755,root,root) %{_libdir}/OGRE/RenderSystem_GL.so*
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/libOgreMain.so
139 %attr(755,root,root) %{_libdir}/libOgrePaging.so
140 %attr(755,root,root) %{_libdir}/libOgreProperty.so
141 %attr(755,root,root) %{_libdir}/libOgreRTShaderSystem.so
142 %attr(755,root,root) %{_libdir}/libOgreTerrain.so
143 %{_includedir}/OGRE
144 %{_pkgconfigdir}/OGRE.pc
145 %{_pkgconfigdir}/OGRE-PCZ.pc
146 %{_pkgconfigdir}/OGRE-Paging.pc
147 %{_pkgconfigdir}/OGRE-Property.pc
148 %{_pkgconfigdir}/OGRE-RTShaderSystem.pc
149 %{_pkgconfigdir}/OGRE-Terrain.pc
150 %{_libdir}/OGRE/cmake
151
152 %files examples
153 %defattr(644,root,root,755)
154 %{_examplesdir}/%{name}-%{version}
This page took 0.085207 seconds and 3 git commands to generate.