]> git.pld-linux.org Git - packages/ogre.git/blob - ogre.spec
3002fc7aefefaf6df488597d9f049ffb719ff81f
[packages/ogre.git] / ogre.spec
1 #
2 # TODO: - bconds for the rest of the plugins
3 #
4 # Conditional build:
5 %bcond_with     cg              # build with cg
6 %bcond_with     samples         # build samples (not installed anyway)
7
8 %ifnarch %{ix86} %{x8664}
9 %undefine       with_cg
10 %endif
11
12 %define fver    %(echo %{version} | tr . -)
13 Summary:        Object-oriented Graphics Rendering Engine
14 Summary(pl.UTF-8):      OGRE - zorientowany obiektowo silnik renderowania grafiki
15 Name:           ogre
16 Version:        1.8.1
17 Release:        1
18 License:        MIT
19 Group:          Applications
20 Source0:        http://downloads.sourceforge.net/ogre/%{name}_src_v%{fver}.tar.bz2
21 # Source0-md5:  b85e3dcf370a46b3a8624d4fdd722d39
22 Patch0:         boost-1.50.patch
23 URL:            http://www.ogre3d.org/
24 %{?with_samples:BuildRequires:  CEGUI-devel}
25 BuildRequires:  FreeImage-devel
26 # no makefiles for EXR plugin
27 #BuildRequires: OpenEXR-devel
28 BuildRequires:  OpenGL-GLU-devel
29 BuildRequires:  boost-devel
30 %{?with_cg:BuildRequires:       cg-devel}
31 BuildRequires:  cmake >= 2.6.2
32 BuildRequires:  cppunit-devel >= 1.10.0
33 BuildRequires:  freetype-devel >= 2.1.0
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  rpmbuild(macros) >= 1.600
37 BuildRequires:  tinyxml-devel
38 BuildRequires:  xorg-lib-libXaw-devel
39 BuildRequires:  xorg-lib-libXrandr-devel
40 BuildRequires:  xorg-lib-libXxf86vm-devel
41 BuildRequires:  xorg-proto-xf86vidmodeproto-devel
42 BuildRequires:  zlib-devel
43 BuildRequires:  zziplib-devel
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Object-oriented Graphics Rendering Engine.
48
49 %description -l pl.UTF-8
50 OGRE - zorientowany obiektowo silnik renderowania grafiki
51
52 %package devel
53 Summary:        Header files for OGRE library
54 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OGRE
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       FreeImage-devel
58 Requires:       freetype-devel >= 2.1.0
59 Requires:       libstdc++-devel
60 Requires:       zlib-devel
61 Requires:       zziplib-devel
62 # libOgrePlatform additionally: XFree86-devel/xorg-lib-libX11-devel OpenGL-GLU-devel
63
64 %description devel
65 This is the package containing the header files for OGRE library.
66
67 %description devel -l pl.UTF-8
68 Ten pakiet zawiera pliki nagłówkowe biblioteki OGRE.
69
70 %package examples
71 Summary:        OGRE samples
72 Summary(pl.UTF-8):      Przykłady do OGRE
73 Group:          Applications
74
75 %description examples
76 OGRE samples.
77
78 %description examples -l pl.UTF-8
79 Przykłady do OGRE.
80
81 %prep
82 %setup -q -n %{name}_src_v%{fver}
83 %patch0 -p1
84
85 %build
86 install -d build
87 cd build
88 # "None" is an alias for release, but uses plain CMAKE_CXX_FLAGS; "PLD" build type is not supported
89 %cmake .. \
90         -DCMAKE_BUILD_TYPE=%{?debug:Debug}%{!?debug:None} \
91         %{!?with_samples:-DOGRE_BUILD_SAMPLES=FALSE}
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
99 cp -pr Samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
100
101 %{__make} -C build install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS BUGS COPYING README
113 %attr(755,root,root) %{_bindir}/OgreMeshUpgrader
114 %attr(755,root,root) %{_bindir}/OgreXMLConverter
115 %dir %{_libdir}/OGRE
116 %attr(755,root,root) %{_libdir}/OGRE/*.so*
117 %attr(755,root,root) %{_libdir}/libOgreMain.so.*.*.*
118 %attr(755,root,root) %{_libdir}/libOgrePaging.so.*.*.*
119 %attr(755,root,root) %{_libdir}/libOgreProperty.so.*.*.*
120 %attr(755,root,root) %{_libdir}/libOgreRTShaderSystem.so.*.*.*
121 %attr(755,root,root) %{_libdir}/libOgreTerrain.so.*.*.*
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libOgreMain.so
126 %attr(755,root,root) %{_libdir}/libOgrePaging.so
127 %attr(755,root,root) %{_libdir}/libOgreProperty.so
128 %attr(755,root,root) %{_libdir}/libOgreRTShaderSystem.so
129 %attr(755,root,root) %{_libdir}/libOgreTerrain.so
130 %{_includedir}/OGRE
131 %{_pkgconfigdir}/OGRE.pc
132 %{_pkgconfigdir}/OGRE-PCZ.pc
133 %{_pkgconfigdir}/OGRE-Paging.pc
134 %{_pkgconfigdir}/OGRE-Property.pc
135 %{_pkgconfigdir}/OGRE-RTShaderSystem.pc
136 %{_pkgconfigdir}/OGRE-Terrain.pc
137 %dir %{_libdir}/OGRE
138 %{_libdir}/OGRE/cmake
139
140 %files examples
141 %defattr(644,root,root,755)
142 %{_examplesdir}/%{name}-%{version}
This page took 0.075543 seconds and 2 git commands to generate.