]> git.pld-linux.org Git - packages/ogdi.git/blob - ogdi.spec
- updated to 4.1.0; dted driver is gone
[packages/ogdi.git] / ogdi.spec
1 # TODO: separate gltpd to -server package, add init script (requires portmap)
2 #
3 # Conditional build:
4 %bcond_without  tcl     # disable gui and nviz
5 %bcond_without  odbc    # disable unixODBC support
6 #
7 Summary:        Open Geographic Datastore Interface
8 Summary(pl.UTF-8):      OGDI - otwarty interfejs do danych geograficznych
9 Name:           ogdi
10 Version:        4.1.0
11 %define tagver  %(echo %{version} | tr . _)
12 Release:        1
13 License:        BSD-like
14 Group:          Applications/Databases
15 #Source0Download: https://github.com/libogdi/ogdi/releases/
16 Source0:        https://github.com/libogdi/ogdi/releases/download/ogdi_%{tagver}/%{name}-%{version}.tar.gz
17 # Source0-md5:  0e6259d55694f90b2099bbd901bdb161
18 Source1:        http://ogdi.sourceforge.net/ogdi.pdf
19 # Source1-md5:  029a8cdcd36bee73df92196ee769040e
20 Patch1:         %{name}-format.patch
21 URL:            http://ogdi.sourceforge.net/
22 BuildRequires:  autoconf
23 BuildRequires:  expat-devel
24 BuildRequires:  libtirpc-devel
25 BuildRequires:  rpmbuild(macros) >= 1.446
26 %{?with_tcl:BuildRequires:      tcl-devel}
27 %{?with_odbc:BuildRequires:     unixODBC-devel}
28 BuildRequires:  zlib-devel
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 OGDI is the Open Geographic Datastore Interface. OGDI is an
33 application programming interface (API) that uses a standardized
34 access methods to work in conjunction with GIS software packages (the
35 application) and various geospatial data products. OGDI uses a
36 client/server architecture to facilitate the dissemination of
37 geospatial data products over any TCP/IP network, and a
38 driver-oriented approach to facilitate access to several geospatial
39 data products/formats.
40
41 %description -l pl.UTF-8
42 OGDI (Open Geographic Datastore Interface) oznacza otwarty interfejs
43 do danych geograficznych. OGDI to API używające ustandaryzowanych
44 metod dostępu do pracy z pakietami oprogramowania GIS i różnymi danymi
45 geograficznymi. OGDI używa architektury klient-serwer aby udostępniać
46 dane po dowolnej sieci TCP/IP oraz podejścia bazującego na
47 sterownikach aby zapewnić dostęp do różnych produktów/formatów danych
48 geograficznych.
49
50 %package devel
51 Summary:        OGDI header files and documentation
52 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja OGDI
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       libtirpc-devel
56
57 %description devel
58 OGDI header files and developer's documentation.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe i dokumentacja programisty do OGDI.
62
63 %package odbc
64 Summary:        ODBC driver for OGDI
65 Summary(pl.UTF-8):      Sterownik ODBC do OGDI
66 Group:          Libraries
67 Requires:       %{name} = %{version}-%{release}
68
69 %description odbc
70 ODBC driver for OGDI.
71
72 %description odbc -l pl.UTF-8
73 Sterownik ODBC do OGDI.
74
75 %package -n tcl-ogdi
76 Summary:        Tcl wrapper for OGDI
77 Summary(pl.UTF-8):      Interfejs Tcl do OGDI
78 Group:          Libraries
79 Requires:       %{name} = %{version}-%{release}
80
81 %description -n tcl-ogdi
82 Tcl wrapper for OGDI.
83
84 %description -n tcl-ogdi -l pl.UTF-8
85 Interfejs Tcl do OGDI.
86
87 %prep
88 %setup -q
89 %patch1 -p1
90
91 cp -f %{SOURCE1} .
92
93 %build
94 TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
95 %configure \
96         --with-expat \
97         --with-zlib
98
99 # bash because of pushd/popd used in makefiles
100 %{__make} -j 1 \
101         SHELL=/bin/bash \
102         INST_LIB=%{_libdir} \
103         OPTIMIZATION="%{rpmcflags}"
104
105 %if %{with tcl}
106 %{__make} -j 1 -C ogdi/tcl_interface \
107         OPTIMIZATION="%{rpmcflags}" \
108         TCL_LINKLIB="-ltcl"
109 %endif
110 %{__make} -j 1 -C contrib/gdal \
111         OPTIMIZATION="%{rpmcflags}"
112 %if %{with odbc}
113 %{__make} -j 1 -C ogdi/attr_driver/odbc \
114         OPTIMIZATION="%{rpmcflags} -DDONT_TD_VOID" \
115         ODBC_LINKLIB="-lodbc"
116 %endif
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
122
123 %{__make} -j 1 install \
124         SHELL=/bin/bash \
125         INST_INCLUDE=$RPM_BUILD_ROOT%{_includedir} \
126         INST_LIB=$RPM_BUILD_ROOT%{_libdir} \
127         INST_BIN=$RPM_BUILD_ROOT%{_bindir}
128
129 # omitted from make install
130 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
131 cp -p ogdi.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
132 install ogdi-config $RPM_BUILD_ROOT%{_bindir}
133
134 %if %{with tcl}
135 %{__make} -j 1 install -C ogdi/tcl_interface \
136         INST_LIB=$RPM_BUILD_ROOT%{_libdir}
137 %endif
138 %{__make} -j 1 install -C contrib/gdal \
139         INST_LIB=$RPM_BUILD_ROOT%{_libdir}
140 %if %{with odbc}
141 %{__make} -j 1 install -C ogdi/attr_driver/odbc \
142         INST_LIB=$RPM_BUILD_ROOT%{_libdir}
143 %endif
144
145 %{__rm} $RPM_BUILD_ROOT%{_bindir}/example?
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -p /sbin/ldconfig
151 %postun -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %doc LICENSE NEWS
156 %attr(755,root,root) %{_bindir}/gltpd
157 %attr(755,root,root) %{_bindir}/ogdi_*
158 %attr(755,root,root) %{_libdir}/libogdi.so.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libogdi.so.4
160 %dir %{_libdir}/ogdi
161 %attr(755,root,root) %{_libdir}/ogdi/libadrg.so
162 %attr(755,root,root) %{_libdir}/ogdi/libgdal.so
163 %attr(755,root,root) %{_libdir}/ogdi/libremote.so
164 %attr(755,root,root) %{_libdir}/ogdi/librpf.so
165 %attr(755,root,root) %{_libdir}/ogdi/libskeleton.so
166 %attr(755,root,root) %{_libdir}/ogdi/libvrf.so
167
168 %files devel
169 %defattr(644,root,root,755)
170 %doc ogdi.pdf
171 %attr(755,root,root) %{_bindir}/ogdi-config
172 %attr(755,root,root) %{_libdir}/libogdi.so
173 %{_includedir}/ecs.h
174 %{_includedir}/ecs_util.h
175 %{_pkgconfigdir}/ogdi.pc
176
177 %if %{with odbc}
178 %files odbc
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/ogdi/liblodbc.so
181 %endif
182
183 %if %{with tcl}
184 %files -n tcl-ogdi
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_libdir}/ogdi/libecs_tcl.so
187 %endif
This page took 0.075914 seconds and 4 git commands to generate.