]> git.pld-linux.org Git - packages/ocsync.git/blob - ocsync.spec
- run ldconfig
[packages/ocsync.git] / ocsync.spec
1 # TODO:
2 # * Add subpackage and complile time flags for plugin packages:
3 #   * smb backend
4 # * Package documentation
5 Summary:        A user level bidirectional client only file synchronizer (owncloud version)
6 Name:           ocsync
7 Version:        0.90.0
8 Release:        0.2
9 License:        GPL v2
10 Group:          Libraries
11 Source0:        http://download.owncloud.com/download/%{name}-%{version}.tar.bz2
12 # Source0-md5:  6f1cfe47d6a7741c6e8df8642de52c0f
13 URL:            http://www.csync.org
14 BuildRequires:  check
15 BuildRequires:  cmake
16 BuildRequires:  doxygen
17 BuildRequires:  iniparser-devel
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  neon-devel
20 BuildRequires:  sqlite3-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 ocsync is the ownCloud version of csync. csync is an implementation of
25 a file synchronizer which provides the feature of roaming home
26 directories for Linux clients.
27
28 %package owncloud
29 Summary:        Plugin files for using ownCloud backend with libraries %{name}
30 Group:          Libraries
31 Requires:       %{name} = %{version}-%{release}
32
33 %description owncloud
34 ocsync is a csync version which is temporarily maintained by the
35 ownCloud community to support the ownCloud client. csync is an
36 implementation of a file synchronizer which provides the feature of
37 roaming home directories for Linux clients. csync makes use of
38 libsmbclient in Samba/Windows environments.
39
40 %package devel
41 Summary:        Development header files and libraries for %{name}
42 Group:          Libraries
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 Development header files and libraries for %{name}
47
48 %prep
49 %setup -q
50
51 %build
52 if test ! -e "build"; then
53         %{__mkdir} build
54 fi
55
56 cd build
57
58 %cmake \
59         -DCMAKE_C_FLAGS:STRING="%{optflags}" \
60         -DCMAKE_CXX_FLAGS:STRING="%{optflags}" \
61         -DCMAKE_SKIP_RPATH=ON \
62         -DCMAKE_BUILD_TYPE=RelWithDebInfo \
63         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
64         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
65         -DPREFIX=%{_prefix} \
66         -DSYSCONFDIR=%{_sysconfdir} \
67         $RPM_BUILD_ROOT/%{name}-%{version} \
68         ..
69
70 %{__make}
71 %{__make} doc
72
73 cd ..
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 cd build
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc AUTHORS COPYING INSTALL README
92 %config(noreplace) %{_sysconfdir}/ocsync/ocsync.conf
93 %config(noreplace) %{_sysconfdir}/ocsync/ocsync_exclude.conf
94 %attr(755,root,root) %{_bindir}/ocsync
95 %dir %{_sysconfdir}/ocsync
96 %attr(755,root,root) %{_libdir}/libocsync.so.*.*.*
97 %ghost %{_libdir}/libocsync.so.0
98 %dir %{_libdir}/ocsync-0
99 %{_mandir}/man1/ocsync.1*
100
101 %files owncloud
102 %defattr(644,root,root,755)
103 %{_libdir}/ocsync-0/ocsync_owncloud.so
104 %{_libdir}/libhttpbflib.a
105
106 %files devel
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_libdir}/libocsync.so
109 %dir %{_includedir}/%{name}
110 %{_includedir}/%{name}/*.h
This page took 0.08596 seconds and 3 git commands to generate.