]> git.pld-linux.org Git - packages/ocserv.git/blob - ocserv.spec
a3d12e0371352c69c42b4dc98ef74a3a54484f13
[packages/ocserv.git] / ocserv.spec
1 # TODO: heimdal support
2 #
3 # Conditional build:
4 %bcond_with     kerberos5       # GSSAPI authentication (currently only MIT krb5 supported)
5 %bcond_without  radius          # RADIUS support
6 #
7 Summary:        OpenConnect VPN server
8 Summary(pl.UTF-8):      Serwer VPN-a OpenConnect
9 Name:           ocserv
10 Version:        0.10.8
11 Release:        1
12 License:        GPL v2+
13 Group:          Applications/Networking
14 Source0:        ftp://ftp.infradead.org/pub/ocserv/%{name}-%{version}.tar.xz
15 # Source0-md5:  665b854377850db535271098a37213f1
16 URL:            http://www.infradead.org/ocserv/
17 BuildRequires:  autogen
18 BuildRequires:  autogen-devel
19 BuildRequires:  dbus-devel >= 1.1.1
20 %{?with_radius:BuildRequires:   freeradius-client-devel >= 1.1.7}
21 BuildRequires:  gnutls-devel >= 3.1.10
22 BuildRequires:  http-parser-devel
23 # pkgconfig(krb5-gssapi)
24 %{?with_kerberos5:BuildRequires:        krb5-devel}
25 BuildRequires:  libnl-devel >= 3.2
26 BuildRequires:  libpcl-devel
27 BuildRequires:  libseccomp-devel
28 %{?with_kerberos5:BuildRequires:        libtasn1-devel >= 3.9}
29 BuildRequires:  libwrap-devel
30 BuildRequires:  lz4-devel
31 BuildRequires:  pam-devel
32 BuildRequires:  pkgconfig
33 BuildRequires:  protobuf-c-devel
34 BuildRequires:  readline-devel
35 BuildRequires:  systemd-devel
36 BuildRequires:  talloc-devel
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  xz
39 Requires:       dbus-libs >= 1.1.1
40 %{?with_radius:Requires:        freeradius-client-libs >= 1.1.7}
41 Requires:       gnutls >= 3.1.10
42 Requires:       libnl >= 3.2
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 OpenConnect server (ocserv) is an SSL VPN server. Its purpose is to be
47 a secure, small, fast and configurable VPN server. It implements the
48 OpenConnect SSL VPN protocol, and has also (currently experimental)
49 compatibility with clients using the AnyConnect SSL VPN protocol. The
50 OpenConnect VPN protocol uses the standard IETF security protocols
51 such as TLS 1.2, and Datagram TLS to provide the secure VPN service.
52 The server is implemented primarily for the GNU/Linux platform but its
53 code is designed to be portable to other UNIX variants as well.
54
55 %description -l pl.UTF-8
56 Serwer OpenConnect (ocserv) to serwer VPN-u SSL. Celem projektu jest
57 bezpieczny, mały, szybki i konfigurowalny serwer VPN. Implementuje
58 protokół VPN-u SSL OpenConnect, zapewnia także (obecnie
59 eksperymentalną) zgodność z klientami wykorzystującymi protokół VPN
60 SSL AnyConnect. Protokół VPN OpenConnect wykorzystuje standardowe
61 protokoły bezpieczeństwa IETF, takie jak TLS 1.2 oraz Datagram TLS w
62 celu zapewnienia bezpieczeństwa usługi VPN. Serwer jest
63 zaimplementowany głównie dla platformy GNU/Linux, ale kod jest
64 zaprojektowany jako zgodny także z innymi wariantami uniksów.
65
66 %prep
67 %setup -q
68
69 %build
70 %configure \
71         --disable-silent-rules \
72         %{!?with_kerberos5:--without-gssapi} \
73         %{!?with_radius:--without-radius}
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc AUTHORS ChangeLog LICENSE NEWS README TODO
88 %attr(755,root,root) %{_bindir}/occtl
89 %attr(755,root,root) %{_bindir}/ocpasswd
90 %attr(755,root,root) %{_sbindir}/ocserv
91 %{_mandir}/man8/occtl.8*
92 %{_mandir}/man8/ocpasswd.8*
93 %{_mandir}/man8/ocserv.8*
This page took 0.050986 seconds and 2 git commands to generate.