]> git.pld-linux.org Git - packages/ocaml-xmlm.git/blob - ocaml-xmlm.spec
new, version 1.1.1
[packages/ocaml-xmlm.git] / ocaml-xmlm.spec
1 #
2 # Conditional build:
3 %bcond_without  opt             # build opt
4
5 %define         pkgname xmlm
6 %define         debug_package   %{nil}
7 Summary:        OCaml xml manipulation module
8 Name:           ocaml-%{pkgname}
9 Version:        1.1.1
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 Source0:        http://erratique.ch/software/xmlm/releases/%{pkgname}-%{version}.tbz
14 # Source0-md5:  357025dd1a9fc87b6e50ac21eb0eb2b1
15 URL:            http://erratique.ch/software/xmlm
16 BuildRequires:  ocaml >= 3.10
17 BuildRequires:  ocaml-findlib >= 1.4
18 %requires_eq    ocaml-runtime
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Xmlm allows the OCaml programmer to manipulate xml data. Its
23 complexity is half-way between the easy xml-light module and a full
24 parsing of xml data. It is also very simple to updgrade existing code
25 using xml-light in order to use xmlm.
26
27 %description -l pl.UTF-8
28 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
29 używających tej biblioteki.
30
31 %package devel
32 Summary:        xmlm binding for OCaml - development part
33 Summary(pl.UTF-8):      Wiązania xmlm dla OCamla - cześć programistyczna
34 Group:          Development/Libraries
35 #Requires:      %{name} = %{version}-%{release}
36 %requires_eq    ocaml
37
38 %description devel
39 This package contains all the development stuff you need to develop
40 OCaml programs which use xmlm.
41
42 %description devel -l pl.UTF-8
43 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
44 tej biblioteki.
45
46 %prep
47 %setup -q -n %{pkgname}-%{version}
48
49 %build
50 ocaml setup.ml -configure
51 ocaml setup.ml -build
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/{xmlm,stublibs}
56 install _build/src/*.cm[ixa]* _build/src/*.a $RPM_BUILD_ROOT%{_libdir}/ocaml/xmlm
57
58 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/xmlm
59 cat > $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/xmlm/META <<EOF
60 requires = ""
61 version = "%{version}"
62 directory = "+xmlm"
63 archive(byte) = "xmlm.cma"
64 archive(native) = "xmlm.cmxa"
65 linkopts = ""
66 EOF
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files devel
72 %defattr(644,root,root,755)
73 %doc README CHANGES src/*.mli
74 %dir %{_libdir}/ocaml/xmlm
75 %{_libdir}/ocaml/xmlm/*.cm[ixa]*
76 %{_libdir}/ocaml/xmlm/*.a
77 %{_libdir}/ocaml/site-lib/xmlm
This page took 0.058923 seconds and 3 git commands to generate.