]> git.pld-linux.org Git - packages/ocaml-ulex.git/blob - ocaml-ulex.spec
- disable debug packages
[packages/ocaml-ulex.git] / ocaml-ulex.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 Summary:        Lexer generator for Unicode and OCaml
11 Summary(pl.UTF-8):      Lexer dla OCamla i Unicode
12 Name:           ocaml-ulex
13 Version:        1.1
14 Release:        6
15 License:        MIT
16 Group:          Development/Tools
17 Source0:        http://www.cduce.org/download/ulex-%{version}.tar.gz
18 # Source0-md5:  ce49a013bc4a0e085977a9fe157017bf
19 Patch0:         %{name}-fix-bytes.patch
20 URL:            http://www.cduce.org/ulex/
21 BuildRequires:  ocaml >= 1:3.10.0
22 BuildRequires:  ocaml-findlib-devel
23 %requires_eq    ocaml-runtime
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         debug_package   %{nil}
27
28 %description
29 ulex is a lexer generator for Unicode and OCaml.
30
31 %description -l pl.UTF-8
32 ulex jest lexerem dla OCamla i Unicode.
33
34 %prep
35 %setup -q -n ulex-%{version}
36 %patch0 -p1
37
38 %build
39 %{__make} -j1 all %{?with_ocaml_opt:all.opt}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/ulex
44
45 %{__make} install \
46         OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc CHANGES LICENSE README
54 %dir %{_libdir}/ocaml/ulex
55 %{_libdir}/ocaml/ulex/META
56 %{_libdir}/ocaml/ulex/*.cma
57 %{_libdir}/ocaml/ulex/*.cmi
58 %if %{with ocaml_opt}
59 %{_libdir}/ocaml/ulex/ulexing.a
60 %{_libdir}/ocaml/ulex/*.cmx
61 %{_libdir}/ocaml/ulex/*.cmxa
62 %endif
63 %{_libdir}/ocaml/ulex/ulexing.mli
64 %{_libdir}/ocaml/ulex/utf8.mli
This page took 0.051843 seconds and 3 git commands to generate.