]> git.pld-linux.org Git - packages/ocaml-stdio.git/blob - ocaml-stdio.spec
efacac7c3360d6fc7ce7daeb754e46423afeb61e
[packages/ocaml-stdio.git] / ocaml-stdio.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 Summary:        Standard IO library for OCaml
11 Summary(pl.UTF-8):      Biblioteka standardowego we/wy dla OCamla
12 Name:           ocaml-stdio
13 Version:        0.14.0
14 Release:        2
15 License:        MIT
16 Group:          Libraries
17 #Source0Download: https://github.com/janestreet/stdio/releases
18 Source0:        https://github.com/janestreet/stdio/archive/v%{version}/stdio-%{version}.tar.gz
19 # Source0-md5:  ee81f65acbab0ac762181aa6ceb926b1
20 URL:            https://github.com/janestreet/stdio
21 BuildRequires:  ocaml >= 1:4.04.2
22 BuildRequires:  ocaml-base-devel >= 0.14
23 BuildRequires:  ocaml-base-devel < 0.15
24 BuildRequires:  ocaml-dune-devel >= 2.0.0
25 %requires_eq    ocaml-runtime
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         debug_package   %{nil}
29
30 %description
31 Stdio provides input/output functions for OCaml. It re-exports the
32 buffered channels of the stdlib distributed with OCaml but with some
33 improvements.
34
35 This package contains files needed to run bytecode executables using
36 stdio library.
37
38 %description -l pl.UTF-8
39 Stdio udostępnia funkcje wejścia/wyjścia dla OCamla. Re-eksportuje
40 buforowane kanały z stdlib rozprowadzanej wraz OCamlem, ale z kilkoma
41 usprawnieniami.
42
43 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
44 używających biblioteki stdio.
45
46 %package devel
47 Summary:        Standard IO library for OCaml - development part
48 Summary(pl.UTF-8):      Biblioteka standardowego we/wy dla OCamla - cześć programistyczna
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       ocaml-base-devel >= 0.14
52 %requires_eq    ocaml
53
54 %description devel
55 This package contains files needed to develop OCaml programs using
56 stdio library.
57
58 %description devel -l pl.UTF-8
59 Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
60 używających biblioteki stdio.
61
62 %prep
63 %setup -q -n stdio-%{version}
64
65 %build
66 dune build --verbose
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 dune install --destdir=$RPM_BUILD_ROOT
72
73 # sources
74 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stdio/*.ml
75 # packaged as %doc
76 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/stdio
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc CHANGES.md LICENSE.md README.org
84 %dir %{_libdir}/ocaml/stdio
85 %{_libdir}/ocaml/stdio/META
86 %{_libdir}/ocaml/stdio/*.cma
87 %if %{with ocaml_opt}
88 %attr(755,root,root) %{_libdir}/ocaml/stdio/*.cmxs
89 %endif
90
91 %files devel
92 %defattr(644,root,root,755)
93 %{_libdir}/ocaml/stdio/*.cmi
94 %{_libdir}/ocaml/stdio/*.cmt
95 %{_libdir}/ocaml/stdio/*.cmti
96 %{_libdir}/ocaml/stdio/*.mli
97 %if %{with ocaml_opt}
98 %{_libdir}/ocaml/stdio/*.a
99 %{_libdir}/ocaml/stdio/*.cmx
100 %{_libdir}/ocaml/stdio/*.cmxa
101 %endif
102 %{_libdir}/ocaml/stdio/dune-package
103 %{_libdir}/ocaml/stdio/opam
This page took 0.103689 seconds and 2 git commands to generate.