]> git.pld-linux.org Git - packages/ocaml-sqlite.git/blob - ocaml-sqlite.spec
- updated to 5.1.0
[packages/ocaml-sqlite.git] / ocaml-sqlite.spec
1 # TODO
2 # - odoc
3 # - tests. W: Tests are turned off, consider enabling with 'ocaml setup.ml -configure --enable-tests'
4 #
5 # Conditional build:
6 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
7
8 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
9 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
10 %undefine       with_ocaml_opt
11 %endif
12
13 %if %{without ocaml_opt}
14 %define         _enable_debug_packages  0
15 %endif
16
17 %define         module  sqlite3
18 Summary:        SQLite 3 binding for OCaml
19 Summary(pl.UTF-8):      Wiązanie SQLite 3 dla OCamla
20 Name:           ocaml-sqlite
21 Version:        5.1.0
22 Release:        1
23 License:        MIT
24 Group:          Libraries
25 #Source0Download: https://github.com/mmottl/sqlite3-ocaml/releases
26 Source0:        https://github.com/mmottl/sqlite3-ocaml/releases/download/%{version}/sqlite3-%{version}.tbz
27 # Source0-md5:  5d7b2c5d9d16ede92745425d99185371
28 URL:            http://mmottl.github.io/sqlite3-ocaml/
29 BuildRequires:  ocaml >= 1:4.12
30 BuildRequires:  ocaml-dune >= 2.7
31 BuildRequires:  sqlite3-devel
32 %requires_eq    ocaml-runtime
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 SQLite 3 database library wrapper for OCaml.
37
38 %description -l pl.UTF-8
39 Obudowanie biblioteki baz danych SQLite 3 dla OCamla.
40
41 %package devel
42 Summary:        SQLite 3 binding for OCaml - development part
43 Summary(pl.UTF-8):      Wiązanie SQLite 3 dla OCamla - część programistyczna
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 %requires_eq    ocaml
47
48 %description devel
49 This package contains files needed to develop OCaml programs using
50 ocaml-sqlite3 library.
51
52 %description devel -l pl.UTF-8
53 Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
54 używających biblioteki ocaml-sqlite3.
55
56 %prep
57 %setup -q -n sqlite3-%{version}
58
59 %build
60 dune build --verbose @install
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 dune install --destdir=$RPM_BUILD_ROOT
66
67 # sources
68 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/%{module}/*.ml
69 # packaged as %doc
70 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/%{module}
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc CHANGES.md LICENSE.md README.md TODO.md pre-v4.2.0-CHANGES.txt
78 %dir %{_libdir}/ocaml/%{module}
79 %{_libdir}/ocaml/%{module}/META
80 %{_libdir}/ocaml/%{module}/*.cma
81 %if %{with ocaml_opt}
82 %attr(755,root,root) %{_libdir}/ocaml/%{module}/*.cmxs
83 %endif
84 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsqlite3_stubs.so
85
86 %files devel
87 %defattr(644,root,root,755)
88 %{_libdir}/ocaml/%{module}/libsqlite3_stubs.a
89 %{_libdir}/ocaml/%{module}/*.cmi
90 %{_libdir}/ocaml/%{module}/*.cmt
91 %{_libdir}/ocaml/%{module}/*.cmti
92 %{_libdir}/ocaml/%{module}/*.mli
93 %if %{with ocaml_opt}
94 %{_libdir}/ocaml/%{module}/sqlite3.a
95 %{_libdir}/ocaml/%{module}/*.cmx
96 %{_libdir}/ocaml/%{module}/*.cmxa
97 %endif
98 %{_libdir}/ocaml/%{module}/dune-package
99 %{_libdir}/ocaml/%{module}/opam
This page took 0.05517 seconds and 3 git commands to generate.