]> git.pld-linux.org Git - packages/ocaml-sqlite.git/blob - ocaml-sqlite.spec
c1549c2607a429615c9c530431195eda5ff552a5
[packages/ocaml-sqlite.git] / ocaml-sqlite.spec
1 # TODO
2 # - tests. W: Tests are turned off, consider enabling with 'ocaml setup.ml -configure --enable-tests'
3 #
4 # Conditional build:
5 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
6
7 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
8 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
9 %undefine       with_ocaml_opt
10 %endif
11
12 %if %{without ocaml_opt}
13 %define         _enable_debug_packages  0
14 %endif
15
16 %define         module  sqlite3
17 Summary:        SQLite 3 binding for OCaml
18 Summary(pl.UTF-8):      Wiązanie SQLite 3 dla OCamla
19 Name:           ocaml-sqlite
20 Version:        4.4.1
21 Release:        1
22 License:        MIT
23 Group:          Libraries
24 #Source0Download: https://github.com/mmottl/sqlite3-ocaml/releases
25 Source0:        https://github.com/mmottl/sqlite3-ocaml/releases/download/%{version}/sqlite3-%{version}.tbz
26 # Source0-md5:  93763885a3606252aa8004f7662dd161
27 URL:            http://mmottl.github.io/sqlite3-ocaml/
28 BuildRequires:  ocaml >= 1:4.05
29 BuildRequires:  ocaml-dune >= 1.4.0
30 BuildRequires:  ocaml-findlib-devel
31 BuildRequires:  ocaml-stdio-devel
32 BuildRequires:  sqlite3-devel
33 %requires_eq    ocaml-runtime
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 SQLite 3 database library wrapper for OCaml.
38
39 %description -l pl.UTF-8
40 Obudowanie biblioteki baz danych SQLite 3 dla OCamla.
41
42 %package devel
43 Summary:        SQLite 3 binding for OCaml - development part
44 Summary(pl.UTF-8):      Wiązanie SQLite 3 dla OCamla - część programistyczna
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 %requires_eq    ocaml
48
49 %description devel
50 This package contains files needed to develop OCaml programs using
51 ocaml-sqlite3 library.
52
53 %description devel -l pl.UTF-8
54 Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
55 używających biblioteki ocaml-sqlite3.
56
57 %prep
58 %setup -q -n sqlite3-%{version}
59
60 %build
61 dune build --verbose
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 dune install --destdir=$RPM_BUILD_ROOT
67
68 # sources
69 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/%{module}/*.ml
70 # packaged as %doc
71 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/%{module}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc CHANGES.md LICENSE.md README.md TODO.md pre-v4.2.0-CHANGES.txt
79 %dir %{_libdir}/ocaml/%{module}
80 %{_libdir}/ocaml/%{module}/META
81 %{_libdir}/ocaml/%{module}/*.cma
82 %if %{with ocaml_opt}
83 %attr(755,root,root) %{_libdir}/ocaml/%{module}/*.cmxs
84 %endif
85 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllsqlite3_stubs.so
86
87 %files devel
88 %defattr(644,root,root,755)
89 %{_libdir}/ocaml/%{module}/libsqlite3_stubs.a
90 %{_libdir}/ocaml/%{module}/*.cmi
91 %{_libdir}/ocaml/%{module}/*.cmt
92 %{_libdir}/ocaml/%{module}/*.cmti
93 %{_libdir}/ocaml/%{module}/*.mli
94 %if %{with ocaml_opt}
95 %{_libdir}/ocaml/%{module}/sqlite3.a
96 %{_libdir}/ocaml/%{module}/*.cmx
97 %{_libdir}/ocaml/%{module}/*.cmxa
98 %endif
99 %{_libdir}/ocaml/%{module}/dune-package
100 %{_libdir}/ocaml/%{module}/opam
This page took 0.064513 seconds and 2 git commands to generate.