]> git.pld-linux.org Git - packages/ocaml-splittable_random.git/blob - ocaml-splittable_random.spec
15ff8d8f1f47f18dcdd6d97a9fc599cd2d472f26
[packages/ocaml-splittable_random.git] / ocaml-splittable_random.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 Summary:        PRNG that can be split into independent streams
11 Summary(pl.UTF-8):      PRNG pozwalający na dzielenie na niezależne strumienie
12 Name:           ocaml-splittable_random
13 Version:        0.14.0
14 Release:        1
15 License:        MIT
16 Group:          Libraries
17 #Source0Download: https://github.com/janestreet/splittable_random/tags
18 Source0:        https://github.com/janestreet/splittable_random/archive/v%{version}/splittable_random-%{version}.tar.gz
19 # Source0-md5:  5e557d49f4a14230e18d86aef98379a0
20 URL:            https://github.com/janestreet/splittable_random
21 BuildRequires:  ocaml >= 1:4.04.2
22 BuildRequires:  ocaml-base-devel >= 0.14
23 BuildRequires:  ocaml-base-devel < 0.15
24 BuildRequires:  ocaml-dune >= 2.0.0
25 BuildRequires:  ocaml-ppx_assert-devel >= 0.14
26 BuildRequires:  ocaml-ppx_assert-devel < 0.15
27 BuildRequires:  ocaml-ppx_bench-devel >= 0.14
28 BuildRequires:  ocaml-ppx_bench-devel < 0.15
29 BuildRequires:  ocaml-ppx_inline_test-devel >= 0.14
30 BuildRequires:  ocaml-ppx_inline_test-devel < 0.15
31 BuildRequires:  ocaml-ppx_sexp_message-devel >= 0.14
32 BuildRequires:  ocaml-ppx_sexp_message-devel < 0.15
33 BuildRequires:  ocaml-ppxlib-devel >= 0.11.0
34 %requires_eq    ocaml-runtime
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         debug_package   %{nil}
38
39 %description
40 A splittable pseudo-random number generator (SPRNG) functions like a
41 PRNG in that it can be used as a stream of random values; it can also
42 be "split" to produce a second, independent stream of random values.
43
44 This library implements a splittable pseudo-random number generator
45 that sacrifices cryptographic-quality randomness in favour of
46 performance.
47
48 This package contains files needed to run bytecode executables using
49 splittable_random library.
50
51 %description -l pl.UTF-8
52 SPRNG (Splittable Pseudo-Random Number Generator) funkcjonuje tak, jak
53 generator liczb pseudolosowych, który można używać jako strumień
54 wartości losowych; można go także "rozdzielić" aby utworzyć drugi,
55 niezależny strumień wartości losowych.
56
57 Ta biblioteka implementuje podzielny generator liczb pseudolosowych
58 poświęcający losowość kryptograficznej jakości na rzecz wydajności.
59
60 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
61 używających biblioteki splittable_random.
62
63 %package devel
64 Summary:        PRNG that can be split into independent streams - development part
65 Summary(pl.UTF-8):      PRNG pozwalający na dzielenie na niezależne strumienie - cześć programistyczna
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 %requires_eq    ocaml
69 Requires:       ocaml-base-devel >= 0.14
70 Requires:       ocaml-ppx_assert-devel >= 0.14
71 Requires:       ocaml-ppx_bench-devel >= 0.14
72 Requires:       ocaml-ppx_inline_test-devel >= 0.14
73 Requires:       ocaml-ppx_sexp_message-devel >= 0.14
74 Requires:       ocaml-ppxlib-devel >= 0.11.0
75
76 %description devel
77 This package contains files needed to develop OCaml programs using
78 splittable_random library.
79
80 %description devel -l pl.UTF-8
81 Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
82 używających biblioteki splittable_random.
83
84 %prep
85 %setup -q -n splittable_random-%{version}
86
87 %build
88 dune build --verbose
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 dune install --destdir=$RPM_BUILD_ROOT
94
95 # sources
96 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/splittable_random/*.ml
97 # packaged as %doc
98 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/splittable_random
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(644,root,root,755)
105 %doc CHANGES.md LICENSE.md README.md
106 %dir %{_libdir}/ocaml/splittable_random
107 %{_libdir}/ocaml/splittable_random/META
108 %{_libdir}/ocaml/splittable_random/*.cma
109 %if %{with ocaml_opt}
110 %attr(755,root,root) %{_libdir}/ocaml/splittable_random/*.cmxs
111 %endif
112
113 %files devel
114 %defattr(644,root,root,755)
115 %{_libdir}/ocaml/splittable_random/*.cmi
116 %{_libdir}/ocaml/splittable_random/*.cmt
117 %{_libdir}/ocaml/splittable_random/*.cmti
118 %{_libdir}/ocaml/splittable_random/*.mli
119 %if %{with ocaml_opt}
120 %{_libdir}/ocaml/splittable_random/splittable_random.a
121 %{_libdir}/ocaml/splittable_random/*.cmx
122 %{_libdir}/ocaml/splittable_random/*.cmxa
123 %endif
124 %{_libdir}/ocaml/splittable_random/dune-package
125 %{_libdir}/ocaml/splittable_random/opam
This page took 0.053916 seconds and 2 git commands to generate.