]> git.pld-linux.org Git - packages/ocaml-pxp.git/blob - ocaml-pxp.spec
d7da85c9219670d4021bd498d6f057d11247c623
[packages/ocaml-pxp.git] / ocaml-pxp.spec
1 %define         ocaml_ver       1:3.09.2
2 Summary:        Polimorphic XML Parser for OCaml
3 Summary(pl.UTF-8):      Polimorficzny analizator składniowy XML-a dla OCamla
4 Name:           ocaml-pxp
5 Version:        1.2.3
6 Release:        1
7 License:        distributable
8 Group:          Libraries
9 Source0:        http://download.camlcity.org/download/pxp-%{version}.tar.gz
10 # Source0-md5:  83347420dae0ee495bb0ac2fbab7b74b
11 URL:            http://projects.camlcity.org/projects/pxp.html
12 BuildRequires:  ocaml >= %{ocaml_devel}
13 BuildRequires:  ocaml-findlib
14 BuildRequires:  ocaml-ocamldoc-devel
15 BuildRequires:  ocaml-net-netstring-devel >= 1.1.1-2
16 BuildRequires:  ocaml-ulex
17 BuildRequires:  sed >= 4.0
18 %requires_eq    ocaml-ulex
19 %requires_eq    ocaml-runtime
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 PXP is a validating parser for XML 1.0 which has been written entirely
24 in Objective Caml.
25
26 PXP means "Polymorphic XML Parser" and emphasizes its most useful
27 property: that the API is polymorphic and can be configured such that
28 different objects are used to store different types of elements.
29
30 %description -l pl.UTF-8
31 PXP jest walidującym analizatorem składniowym XML-a 1.0, napisanym w
32 całości w OCamlu.
33
34 PXP oznacza "Polymorphic XML Parser" (polimorficzny analizator
35 składniowy XML-a), co podkreśla jego najbardziej użyteczną własność:
36 API jest polimorficzne i może być skonfigurowane tak, że różne obiekty
37 są używane do przechowywania różnych typów elementów.
38
39 %package devel
40 Summary:        Polimorphic XML Parser for OCaml - development part
41 Summary(pl.UTF-8):      Polimorficzny analizator składniowy XML-a dla OCamla - cześć programistyczna
42 Group:          Development/Libraries
43 %requires_eq    ocaml
44 %requires_eq    ocaml-net-netstring-devel
45 %requires_eq    ocaml-wlex-devel
46
47 %description devel
48 PXP is a validating parser for XML 1.0 which has been written entirely
49 in Objective Caml.
50
51 PXP means "Polymorphic XML parser" and emphasizes its most useful
52 property: that the API is polymorphic and can be configured such that
53 different objects are used to store different types of elements.
54
55 This package contains files needed to develop OCaml programs using the
56 PXP library.
57
58 %description devel -l pl.UTF-8
59 PXP jest walidującym analizatorem składniowym XML-a 1.0, napisanym w
60 całości w OCamlu.
61
62 PXP oznacza "Polymorphic XML Parser" (polimorficzny analizator
63 składniowy XML-a), co podkreśla jego najbardziej użyteczną własność:
64 API jest polimorficzne i może być skonfigurowane tak, że różne obiekty
65 są używane do przechowywania różnych typów elementów.
66
67 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
68 biblioteki PXP.
69
70 %prep
71 %setup -q -n pxp-%{version}
72
73 %build
74 ./configure \
75         -with-lex \
76         -with-ulex \
77         -without-wlex \
78         -with-pp
79
80 sed -i -e 's/-g//' Makefile.rules
81 %{__make} -j1 \
82         all opt
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/{site-lib,pxp}
88 OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib %{__make} install
89 dir=`pwd`
90 cd $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib
91 for f in * ; do
92         echo 'directory = "+pxp"' >> $f/META
93         if [ "`echo $f/*.*`" != "$f/*.*" ]; then
94                 mv $f/*.* $RPM_BUILD_ROOT%{_libdir}/ocaml/pxp
95         fi
96 done
97 cd $dir
98 rm $RPM_BUILD_ROOT%{_libdir}/ocaml/pxp/*.{o,mli}
99
100 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
101 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %files devel
107 %defattr(644,root,root,755)
108 %doc doc/DEV doc/README doc/SPEC
109 %doc doc/design.txt doc/manual/html
110 %dir %{_libdir}/ocaml/pxp
111 %{_libdir}/ocaml/pxp/*
112 %{_examplesdir}/%{name}-%{version}
113 %{_libdir}/ocaml/site-lib/*
This page took 0.083339 seconds and 2 git commands to generate.