]> git.pld-linux.org Git - packages/ocaml-pxp.git/blob - ocaml-pxp.spec
949b661079d4d80d7f2a04b449009cf65244954d
[packages/ocaml-pxp.git] / ocaml-pxp.spec
1 %define         ocaml_ver       1:3.09.2
2 Summary:        Polimorphic XML Parser for OCaml
3 Summary(pl.UTF-8):      Polimorficzny analizator składniowy XML-a dla OCamla
4 Name:           ocaml-pxp
5 Version:        1.1.6
6 Release:        10
7 License:        distributable
8 Group:          Libraries
9 Source0:        http://www.ocaml-programming.de/packages/pxp-%{version}.tar.gz
10 # Source0-md5:  8f1c26e348405fb7f064b4bc2584ab59
11 URL:            http://www.ocaml-programming.de/programming/pxp.html
12 BuildRequires:  ocaml >= %{ocaml_devel}
13 BuildRequires:  ocaml-findlib
14 BuildRequires:  ocaml-net-netstring-devel >= 1.1.1-2
15 BuildRequires:  ocaml-wlex-devel
16 BuildRequires:  sed >= 4.0
17 %requires_eq    ocaml-wlex
18 %requires_eq    ocaml-runtime
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 PXP is a validating parser for XML 1.0 which has been written entirely
23 in Objective Caml.
24
25 PXP means "Polymorphic XML Parser" and emphasizes its most useful
26 property: that the API is polymorphic and can be configured such that
27 different objects are used to store different types of elements.
28
29 %description -l pl.UTF-8
30 PXP jest walidującym analizatorem składniowym XML-a 1.0, napisanym w
31 całości w OCamlu.
32
33 PXP oznacza "Polymorphic XML Parser" (polimorficzny analizator
34 składniowy XML-a), co podkreśla jego najbardziej użyteczną własność:
35 API jest polimorficzne i może być skonfigurowane tak, że różne obiekty
36 są używane do przechowywania różnych typów elementów.
37
38 %package devel
39 Summary:        Polimorphic XML Parser for OCaml - development part
40 Summary(pl.UTF-8):      Polimorficzny analizator składniowy XML-a dla OCamla - cześć programistyczna
41 Group:          Development/Libraries
42 %requires_eq    ocaml
43 %requires_eq    ocaml-net-netstring-devel
44 %requires_eq    ocaml-wlex-devel
45
46 %description devel
47 PXP is a validating parser for XML 1.0 which has been written entirely
48 in Objective Caml.
49
50 PXP means "Polymorphic XML parser" and emphasizes its most useful
51 property: that the API is polymorphic and can be configured such that
52 different objects are used to store different types of elements.
53
54 This package contains files needed to develop OCaml programs using the
55 PXP library.
56
57 %description devel -l pl.UTF-8
58 PXP jest walidującym analizatorem składniowym XML-a 1.0, napisanym w
59 całości w OCamlu.
60
61 PXP oznacza "Polymorphic XML Parser" (polimorficzny analizator
62 składniowy XML-a), co podkreśla jego najbardziej użyteczną własność:
63 API jest polimorficzne i może być skonfigurowane tak, że różne obiekty
64 są używane do przechowywania różnych typów elementów.
65
66 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
67 biblioteki PXP.
68
69 %prep
70 %setup -q -n pxp-%{version}
71
72 %build
73 ./configure \
74         -with-lex-iso88591 \
75         -with-lex-utf8 \
76         -with-wlex
77
78 sed -i -e 's/-g//' Makefile.rules
79 %{__make} -j1 \
80         all opt
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/{site-lib,pxp}
86 OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib %{__make} install
87 dir=`pwd`
88 cd $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib
89 for f in * ; do
90         echo 'directory = "+pxp"' >> $f/META
91         if [ "`echo $f/*.*`" != "$f/*.*" ]; then
92                 mv $f/*.* $RPM_BUILD_ROOT%{_libdir}/ocaml/pxp
93         fi
94 done
95 cd $dir
96 rm $RPM_BUILD_ROOT%{_libdir}/ocaml/pxp/*.{o,mli}
97
98 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
99 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %files devel
105 %defattr(644,root,root,755)
106 %doc doc/ABOUT-FINDLIB doc/EXTENSIONS doc/README doc/RELEASE-NOTES doc/SPEC
107 %doc doc/design.txt LICENSE doc/manual/html
108 %dir %{_libdir}/ocaml/pxp
109 %{_libdir}/ocaml/pxp/*
110 %{_examplesdir}/%{name}-%{version}
111 %{_libdir}/ocaml/site-lib/*
This page took 0.077889 seconds and 3 git commands to generate.