]> git.pld-linux.org Git - packages/ocaml-ppx_typerep_conv.git/blob - ocaml-ppx_typerep_conv.spec
- new
[packages/ocaml-ppx_typerep_conv.git] / ocaml-ppx_typerep_conv.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 Summary:        Generation of runtime types from type declarations
11 Summary(pl.UTF-8):      Generowanie typów uruchomieniowych z deklaracji typów
12 Name:           ocaml-ppx_typerep_conv
13 Version:        0.14.2
14 Release:        1
15 License:        MIT
16 Group:          Libraries
17 #Source0Download: https://github.com/janestreet/ppx_typerep_conv/tags
18 Source0:        https://github.com/janestreet/ppx_typerep_conv/archive/v%{version}/ppx_typerep_conv-%{version}.tar.gz
19 # Source0-md5:  33ce6d705b7323772379712511daac0b
20 URL:            https://github.com/janestreet/ppx_typerep_conv
21 BuildRequires:  ocaml >= 1:4.04.2
22 BuildRequires:  ocaml-base-devel >= 0.14
23 BuildRequires:  ocaml-base-devel < 0.15
24 BuildRequires:  ocaml-dune >= 2.0.0
25 BuildRequires:  ocaml-ppxlib-devel >= 0.22.0
26 BuildRequires:  ocaml-typerep-devel >= 0.14
27 BuildRequires:  ocaml-typerep-devel < 0.15
28 %requires_eq    ocaml-runtime
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         debug_package   %{nil}
32
33 %description
34 Automatic generation of runtime types from type definitions.
35
36 This package contains files needed to run bytecode executables using
37 ppx_typerep_conv library.
38
39 %description -l pl.UTF-8
40 Automatyczne generowanie typów uruchomieniowych z definicji typów.
41
42 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
43 używających biblioteki ppx_typerep_conv.
44
45 %package devel
46 Summary:        Generation of runtime types from type declarations - development part
47 Summary(pl.UTF-8):      Generowanie typów uruchomieniowych z deklaracji typów - część programistyczna
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 %requires_eq    ocaml
51 Requires:       ocaml-base-devel >= 0.14
52 Requires:       ocaml-ppxlib-devel >= 0.22.0
53 Requires:       ocaml-typerep-devel >= 0.14
54
55 %description devel
56 This package contains files needed to develop OCaml programs using
57 ppx_typerep_conv library.
58
59 %description devel -l pl.UTF-8
60 Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
61 używających biblioteki ppx_typerep_conv.
62
63 %prep
64 %setup -q -n ppx_typerep_conv-%{version}
65
66 %build
67 dune build --verbose
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 dune install --destdir=$RPM_BUILD_ROOT
73
74 # sources
75 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/ppx_typerep_conv/*.ml
76 # packaged as %doc
77 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/ppx_typerep_conv
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc CHANGES.md LICENSE.md README.md
85 %dir %{_libdir}/ocaml/ppx_typerep_conv
86 %{_libdir}/ocaml/ppx_typerep_conv/META
87 %{_libdir}/ocaml/ppx_typerep_conv/*.cma
88 %if %{with ocaml_opt}
89 %attr(755,root,root) %{_libdir}/ocaml/ppx_typerep_conv/*.cmxs
90 %endif
91
92 %files devel
93 %defattr(644,root,root,755)
94 %{_libdir}/ocaml/ppx_typerep_conv/*.cmi
95 %{_libdir}/ocaml/ppx_typerep_conv/*.cmt
96 %{_libdir}/ocaml/ppx_typerep_conv/*.cmti
97 %{_libdir}/ocaml/ppx_typerep_conv/*.mli
98 %if %{with ocaml_opt}
99 %{_libdir}/ocaml/ppx_typerep_conv/ppx_typerep_conv.a
100 %{_libdir}/ocaml/ppx_typerep_conv/*.cmx
101 %{_libdir}/ocaml/ppx_typerep_conv/*.cmxa
102 %endif
103 %{_libdir}/ocaml/ppx_typerep_conv/dune-package
104 %{_libdir}/ocaml/ppx_typerep_conv/opam
This page took 0.091563 seconds and 3 git commands to generate.