]> git.pld-linux.org Git - packages/ocaml-ppx_string.git/blob - ocaml-ppx_string.spec
- typo
[packages/ocaml-ppx_string.git] / ocaml-ppx_string.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 Summary:        A ppx extension for string interpolation
11 Summary(pl.UTF-8):      Rozszerzenie ppx do interpolacji łańcuchów znaków
12 Name:           ocaml-ppx_string
13 Version:        0.14.1
14 Release:        1
15 License:        MIT
16 Group:          Libraries
17 #Source0Download: https://github.com/janestreet/ppx_string/tags
18 Source0:        https://github.com/janestreet/ppx_string/archive/v%{version}/ppx_string-%{version}.tar.gz
19 # Source0-md5:  5765a8ca47970b2290fbd7c5d589b449
20 URL:            https://github.com/janestreet/ppx_string
21 BuildRequires:  ocaml >= 1:4.04.2
22 BuildRequires:  ocaml-base-devel >= 0.14
23 BuildRequires:  ocaml-base-devel < 0.15
24 BuildRequires:  ocaml-dune >= 2.0.0
25 BuildRequires:  ocaml-ppx_base-devel >= 0.14
26 BuildRequires:  ocaml-ppx_base-devel < 0.15
27 BuildRequires:  ocaml-ppxlib-devel >= 0.11.0
28 BuildRequires:  ocaml-stdio-devel >= 0.14
29 BuildRequires:  ocaml-stdio-devel < 0.15
30 %requires_eq    ocaml-runtime
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         debug_package   %{nil}
34
35 %description
36 A ppx extension for string interpolation.
37
38 This package contains files needed to run bytecode executables using
39 ppx_string library.
40
41 %description -l pl.UTF-8
42 Rozszerzenie ppx do interpolacji łańcuchów znaków.
43
44 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
45 używających biblioteki ppx_string.
46
47 %package devel
48 Summary:        A ppx extension for string interpolation - development part
49 Summary(pl.UTF-8):      Rozszerzenie ppx do interpolacji łańcuchów znaków - część programistyczna
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 %requires_eq    ocaml
53 Requires:       ocaml-base-devel >= 0.14
54 Requires:       ocaml-ppx_base-devel >= 0.14
55 Requires:       ocaml-ppxlib-devel >= 0.11.0
56 Requires:       ocaml-stdio-devel >= 0.14
57
58 %description devel
59 This package contains files needed to develop OCaml programs using
60 ppx_string library.
61
62 %description devel -l pl.UTF-8
63 Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
64 używających biblioteki ppx_string.
65
66 %prep
67 %setup -q -n ppx_string-%{version}
68
69 %build
70 dune build --verbose
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 dune install --destdir=$RPM_BUILD_ROOT
76
77 # sources
78 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/ppx_string/*.ml
79 # packaged as %doc
80 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/ppx_string
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc LICENSE.md
88 %dir %{_libdir}/ocaml/ppx_string
89 %attr(755,root,root) %{_libdir}/ocaml/ppx_string/ppx.exe
90 %{_libdir}/ocaml/ppx_string/META
91 %{_libdir}/ocaml/ppx_string/*.cma
92 %if %{with ocaml_opt}
93 %attr(755,root,root) %{_libdir}/ocaml/ppx_string/*.cmxs
94 %endif
95
96 %files devel
97 %defattr(644,root,root,755)
98 %{_libdir}/ocaml/ppx_string/*.cmi
99 %{_libdir}/ocaml/ppx_string/*.cmt
100 %{_libdir}/ocaml/ppx_string/*.cmti
101 %{_libdir}/ocaml/ppx_string/*.mli
102 %if %{with ocaml_opt}
103 %{_libdir}/ocaml/ppx_string/ppx_string.a
104 %{_libdir}/ocaml/ppx_string/*.cmx
105 %{_libdir}/ocaml/ppx_string/*.cmxa
106 %endif
107 %{_libdir}/ocaml/ppx_string/dune-package
108 %{_libdir}/ocaml/ppx_string/opam
This page took 0.055336 seconds and 3 git commands to generate.