]> git.pld-linux.org Git - packages/ocaml-ppx_stable.git/blob - ocaml-ppx_stable.spec
- new
[packages/ocaml-ppx_stable.git] / ocaml-ppx_stable.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 Summary:        Stable types conversions generator
11 Summary(pl.UTF-8):      Generowanie konwersji typów stabilnych
12 Name:           ocaml-ppx_stable
13 Version:        0.14.1
14 Release:        1
15 License:        MIT
16 Group:          Libraries
17 #Source0Download: https://github.com/janestreet/ppx_stable/tags
18 Source0:        https://github.com/janestreet/ppx_stable/archive/v%{version}/ppx_stable-%{version}.tar.gz
19 # Source0-md5:  78fd32fd0e72ebfd8e522008949066b5
20 URL:            https://github.com/janestreet/ppx_stable
21 BuildRequires:  ocaml >= 1:4.04.2
22 BuildRequires:  ocaml-base-devel >= 0.14
23 BuildRequires:  ocaml-base-devel < 0.15
24 BuildRequires:  ocaml-dune >= 2.0.0
25 BuildRequires:  ocaml-ppxlib-devel >= 0.14.0
26 %requires_eq    ocaml-runtime
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         debug_package   %{nil}
30
31 %description
32 A ppx extension for easier implementation of conversion functions
33 between almost identical types.
34
35 This package contains files needed to run bytecode executables using
36 ppx_stable library.
37
38 %description -l pl.UTF-8
39 Rozszerzenie ppx do łatwej implementacji funkcji konwersji między
40 prawie identycznymi typami.
41
42 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
43 używających biblioteki ppx_stable.
44
45 %package devel
46 Summary:        Stable types conversions generator - development part
47 Summary(pl.UTF-8):      Generowanie konwersji typów stabilnych - cześć programistyczna
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 %requires_eq    ocaml
51 Requires:       ocaml-base-devel >= 0.14
52 Requires:       ocaml-ppxlib-devel >= 0.14.0
53
54 %description devel
55 This package contains files needed to develop OCaml programs using
56 ppx_stable library.
57
58 %description devel -l pl.UTF-8
59 Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
60 używających biblioteki ppx_stable.
61
62 %prep
63 %setup -q -n ppx_stable-%{version}
64
65 %build
66 dune build --verbose
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 dune install --destdir=$RPM_BUILD_ROOT
72
73 # sources
74 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/ppx_stable/*.ml
75 # packaged as %doc
76 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/ppx_stable
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc CHANGES.md LICENSE.md README.md
84 %dir %{_libdir}/ocaml/ppx_stable
85 %{_libdir}/ocaml/ppx_stable/META
86 %{_libdir}/ocaml/ppx_stable/*.cma
87 %if %{with ocaml_opt}
88 %attr(755,root,root) %{_libdir}/ocaml/ppx_stable/*.cmxs
89 %endif
90
91 %files devel
92 %defattr(644,root,root,755)
93 %{_libdir}/ocaml/ppx_stable/*.cmi
94 %{_libdir}/ocaml/ppx_stable/*.cmt
95 %{_libdir}/ocaml/ppx_stable/*.cmti
96 %{_libdir}/ocaml/ppx_stable/*.mli
97 %if %{with ocaml_opt}
98 %{_libdir}/ocaml/ppx_stable/ppx_stable.a
99 %{_libdir}/ocaml/ppx_stable/*.cmx
100 %{_libdir}/ocaml/ppx_stable/*.cmxa
101 %endif
102 %{_libdir}/ocaml/ppx_stable/dune-package
103 %{_libdir}/ocaml/ppx_stable/opam
This page took 0.091935 seconds and 3 git commands to generate.