]> git.pld-linux.org Git - packages/ocaml-ppx_sexp_value.git/blob - ocaml-ppx_sexp_value.spec
- typo
[packages/ocaml-ppx_sexp_value.git] / ocaml-ppx_sexp_value.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 Summary:        A ppx rewriter that simplifies building S-expressions from OCaml values
11 Summary(pl.UTF-8):      Moduł przepisujący ppx upraszczający budowanie S-wyrażeń z wartości w OCamlu
12 Name:           ocaml-ppx_sexp_value
13 Version:        0.14.0
14 Release:        1
15 License:        MIT
16 Group:          Libraries
17 #Source0Download: https://github.com/janestreet/ppx_sexp_value/tags
18 Source0:        https://github.com/janestreet/ppx_sexp_value/archive/v%{version}/ppx_sexp_value-%{version}.tar.gz
19 # Source0-md5:  ef47fa8e25308e645552ad7bf5c06d28
20 URL:            https://github.com/janestreet/ppx_sexp_value
21 BuildRequires:  ocaml >= 1:4.04.2
22 BuildRequires:  ocaml-base-devel >= 0.14
23 BuildRequires:  ocaml-base-devel < 0.15
24 BuildRequires:  ocaml-dune >= 2.0.0
25 BuildRequires:  ocaml-ppx_here-devel >= 0.14
26 BuildRequires:  ocaml-ppx_here-devel < 0.15
27 BuildRequires:  ocaml-ppx_sexp_conv-devel >= 0.14
28 BuildRequires:  ocaml-ppx_sexp_conv-devel < 0.15
29 BuildRequires:  ocaml-ppxlib-devel >= 0.11.0
30 %requires_eq    ocaml-runtime
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         debug_package   %{nil}
34
35 %description
36 A ppx rewriter that simplifies building S-expressions from OCaml
37 values.
38
39 This package contains files needed to run bytecode executables using
40 ppx_sexp_value library.
41
42 %description -l pl.UTF-8
43 Moduł przepisujący ppx upraszczający budowanie S-wyrażeń z wartości w
44 OCamlu.
45
46 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
47 używających biblioteki ppx_sexp_value.
48
49 %package devel
50 Summary:        A ppx rewriter that simplifies building S-expressions from OCaml values - development part
51 Summary(pl.UTF-8):      Moduł przepisujący ppx upraszczający budowanie S-wyrażeń z wartości w OCamlu - część programistyczna
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 %requires_eq    ocaml
55 Requires:       ocaml-base-devel >= 0.14
56 Requires:       ocaml-ppx_here-devel >= 0.14
57 Requires:       ocaml-ppx_sexp_conv-devel >= 0.14
58 Requires:       ocaml-ppxlib-devel >= 0.11.0
59
60 %description devel
61 This package contains files needed to develop OCaml programs using
62 ppx_sexp_value library.
63
64 %description devel -l pl.UTF-8
65 Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
66 używających biblioteki ppx_sexp_value.
67
68 %prep
69 %setup -q -n ppx_sexp_value-%{version}
70
71 %build
72 dune build --verbose
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 dune install --destdir=$RPM_BUILD_ROOT
78
79 # sources
80 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/ppx_sexp_value/*.ml
81 # packaged as %doc
82 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/ppx_sexp_value
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc CHANGES.md LICENSE.md README.md
90 %dir %{_libdir}/ocaml/ppx_sexp_value
91 %attr(755,root,root) %{_libdir}/ocaml/ppx_sexp_value/ppx.exe
92 %{_libdir}/ocaml/ppx_sexp_value/META
93 %{_libdir}/ocaml/ppx_sexp_value/*.cma
94 %if %{with ocaml_opt}
95 %attr(755,root,root) %{_libdir}/ocaml/ppx_sexp_value/*.cmxs
96 %endif
97
98 %files devel
99 %defattr(644,root,root,755)
100 %{_libdir}/ocaml/ppx_sexp_value/*.cmi
101 %{_libdir}/ocaml/ppx_sexp_value/*.cmt
102 %{_libdir}/ocaml/ppx_sexp_value/*.cmti
103 %{_libdir}/ocaml/ppx_sexp_value/*.mli
104 %if %{with ocaml_opt}
105 %{_libdir}/ocaml/ppx_sexp_value/ppx_sexp_value.a
106 %{_libdir}/ocaml/ppx_sexp_value/*.cmx
107 %{_libdir}/ocaml/ppx_sexp_value/*.cmxa
108 %endif
109 %{_libdir}/ocaml/ppx_sexp_value/dune-package
110 %{_libdir}/ocaml/ppx_sexp_value/opam
This page took 0.0645 seconds and 3 git commands to generate.