]> git.pld-linux.org Git - packages/ocaml-ppx_sexp_conv.git/blob - ocaml-ppx_sexp_conv.spec
- new
[packages/ocaml-ppx_sexp_conv.git] / ocaml-ppx_sexp_conv.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 Summary:        Deriving plugin to generate S-expression conversion functions
11 Summary(pl.UTF-8):      Wtyczka wywodząca do generowania funkcji konwersji S-wyrażeń
12 Name:           ocaml-ppx_sexp_conv
13 Version:        0.14.3
14 Release:        1
15 License:        MIT
16 Group:          Libraries
17 #Source0Download: https://github.com/janestreet/ppx_sexp_conv/releases
18 Source0:        https://github.com/janestreet/ppx_sexp_conv/archive/v%{version}/ppx_sexp_conv-%{version}.tar.gz
19 # Source0-md5:  25caf01245e0113e035ccefe275f85d9
20 URL:            https://github.com/janestreet/ppx_sexp_conv
21 BuildRequires:  ocaml >= 1:4.04.2
22 BuildRequires:  ocaml-base-devel >= 0.14
23 BuildRequires:  ocaml-base-devel < 0.15
24 BuildRequires:  ocaml-dune-devel >= 2.0.0
25 BuildRequires:  ocaml-ppxlib-devel >= 0.22.0
26 BuildRequires:  ocaml-sexplib0-devel >= 0.14
27 BuildRequires:  ocaml-sexplib0-devel < 0.15
28 %requires_eq    ocaml-runtime
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         debug_package   %{nil}
32
33 %description
34 ppx_sexp_conv is a PPX syntax extension that generates code for
35 converting OCaml types to and from S-expressions, as defined in the
36 sexplib library.
37
38 This package contains files needed to run bytecode executables using
39 ppx_sexp_conv library.
40
41 %description -l pl.UTF-8
42 ppx_sexp_conv to rozszerzenie składni PPX generujące kod do konwersji
43 typów OCamla do i z S-wyrażeń zgodnie z definicją w bibliotece
44 sexplib.
45
46 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
47 używających biblioteki ppx_sexp_conv.
48
49 %package devel
50 Summary:        ppx_sexp_conv binding for OCaml - development part
51 Summary(pl.UTF-8):      Wiązania ppx_sexp_conv dla OCamla - cześć programistyczna
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 %requires_eq    ocaml
55 Requires:       ocaml-base-devel >= 0.14
56 Requires:       ocaml-dune-devel >= 2.0.0
57 Requires:       ocaml-ppxlib-devel >= 0.22.0
58 Requires:       ocaml-sexplib0-devel >= 0.14
59
60 %description devel
61 This package contains files needed to develop OCaml programs using
62 ppx_sexp_conv library.
63
64 %description devel -l pl.UTF-8
65 Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
66 używających biblioteki ppx_sexp_conv.
67
68 %prep
69 %setup -q -n ppx_sexp_conv-%{version}
70
71 %build
72 dune build --verbose
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 dune install --destdir=$RPM_BUILD_ROOT
78
79 # sources
80 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/ppx_sexp_conv/*.ml
81 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/ppx_sexp_conv/*/*.ml
82 # packaged as %doc
83 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/ppx_sexp_conv
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc CHANGES.md LICENSE.md README.org
91 %dir %{_libdir}/ocaml/ppx_sexp_conv
92 %{_libdir}/ocaml/ppx_sexp_conv/META
93 %{_libdir}/ocaml/ppx_sexp_conv/*.cma
94 %dir %{_libdir}/ocaml/ppx_sexp_conv/expander
95 %{_libdir}/ocaml/ppx_sexp_conv/expander/*.cma
96 %dir %{_libdir}/ocaml/ppx_sexp_conv/runtime-lib
97 %{_libdir}/ocaml/ppx_sexp_conv/runtime-lib/*.cma
98 %if %{with ocaml_opt}
99 %attr(755,root,root) %{_libdir}/ocaml/ppx_sexp_conv/*.cmxs
100 %attr(755,root,root) %{_libdir}/ocaml/ppx_sexp_conv/expander/*.cmxs
101 %attr(755,root,root) %{_libdir}/ocaml/ppx_sexp_conv/runtime-lib/*.cmxs
102 %endif
103
104 %files devel
105 %defattr(644,root,root,755)
106 %{_libdir}/ocaml/ppx_sexp_conv/*.cmi
107 %{_libdir}/ocaml/ppx_sexp_conv/*.cmt
108 %{_libdir}/ocaml/ppx_sexp_conv/*.cmti
109 %{_libdir}/ocaml/ppx_sexp_conv/*.mli
110 %{_libdir}/ocaml/ppx_sexp_conv/expander/*.cmi
111 %{_libdir}/ocaml/ppx_sexp_conv/expander/*.cmt
112 %{_libdir}/ocaml/ppx_sexp_conv/expander/*.cmti
113 %{_libdir}/ocaml/ppx_sexp_conv/expander/*.mli
114 %{_libdir}/ocaml/ppx_sexp_conv/runtime-lib/*.cmi
115 %{_libdir}/ocaml/ppx_sexp_conv/runtime-lib/*.cmt
116 %if %{with ocaml_opt}
117 %{_libdir}/ocaml/ppx_sexp_conv/ppx_sexp_conv.a
118 %{_libdir}/ocaml/ppx_sexp_conv/*.cmx
119 %{_libdir}/ocaml/ppx_sexp_conv/*.cmxa
120 %{_libdir}/ocaml/ppx_sexp_conv/expander/ppx_sexp_conv_expander.a
121 %{_libdir}/ocaml/ppx_sexp_conv/expander/*.cmx
122 %{_libdir}/ocaml/ppx_sexp_conv/expander/*.cmxa
123 %{_libdir}/ocaml/ppx_sexp_conv/runtime-lib/ppx_sexp_conv_lib.a
124 %{_libdir}/ocaml/ppx_sexp_conv/runtime-lib/*.cmx
125 %{_libdir}/ocaml/ppx_sexp_conv/runtime-lib/*.cmxa
126 %endif
127 %{_libdir}/ocaml/ppx_sexp_conv/dune-package
128 %{_libdir}/ocaml/ppx_sexp_conv/opam
This page took 0.104265 seconds and 3 git commands to generate.