]> git.pld-linux.org Git - packages/ocaml-ppx_let.git/blob - ocaml-ppx_let.spec
0987c9dd64364300dc96d02d1b071ce910b89e4c
[packages/ocaml-ppx_let.git] / ocaml-ppx_let.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 Summary:        Monadic let-bindings
11 Summary(pl.UTF-8):      Monadowe wiązania let
12 Name:           ocaml-ppx_let
13 Version:        0.14.0
14 Release:        1
15 License:        MIT
16 Group:          Libraries
17 #Source0Download: https://github.com/janestreet/ppx_let/tags
18 Source0:        https://github.com/janestreet/ppx_let/archive/v%{version}/ppx_let-%{version}.tar.gz
19 # Source0-md5:  6ded2e26e4207d0c9bf38ee71b4940c7
20 URL:            https://github.com/janestreet/ppx_let
21 BuildRequires:  ocaml >= 1:4.04.2
22 BuildRequires:  ocaml-base-devel >= 0.14
23 BuildRequires:  ocaml-base-devel < 0.15
24 BuildRequires:  ocaml-dune >= 2.0.0
25 BuildRequires:  ocaml-ppxlib-devel >= 0.11.0
26 %requires_eq    ocaml-runtime
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         debug_package   %{nil}
30
31 %description
32 A ppx rewriter for monadic and applicative let bindings, match
33 expressions, and if expressions.
34
35 This package contains files needed to run bytecode executables using
36 ppx_let library.
37
38 %description -l pl.UTF-8
39 Moduł przepisujący ppx do monadowych oraz aplikatywnych wiązań let,
40 wyrażeń match i wyrażeń if.
41
42 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
43 używających biblioteki ppx_let.
44
45 %package devel
46 Summary:        Monadic let-bindings - development part
47 Summary(pl.UTF-8):      Monadowe wiązania let - cześć programistyczna
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 %requires_eq    ocaml
51 Requires:       ocaml-base-devel >= 0.14
52 Requires:       ocaml-ppxlib-devel >= 0.11.0
53
54 %description devel
55 This package contains files needed to develop OCaml programs using
56 ppx_let library.
57
58 %description devel -l pl.UTF-8
59 Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
60 używających biblioteki ppx_let.
61
62 %prep
63 %setup -q -n ppx_let-%{version}
64
65 %build
66 dune build --verbose
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 dune install --destdir=$RPM_BUILD_ROOT
72
73 # sources
74 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/ppx_let/*.ml
75 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/ppx_let/*/*.ml
76 # packaged as %doc
77 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/ppx_let
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc CHANGES.md LICENSE.md README.md
85 %dir %{_libdir}/ocaml/ppx_let
86 %attr(755,root,root) %{_libdir}/ocaml/ppx_let/ppx.exe
87 %{_libdir}/ocaml/ppx_let/META
88 %{_libdir}/ocaml/ppx_let/*.cma
89 %dir %{_libdir}/ocaml/ppx_let/expander
90 %{_libdir}/ocaml/ppx_let/expander/*.cma
91 %if %{with ocaml_opt}
92 %attr(755,root,root) %{_libdir}/ocaml/ppx_let/*.cmxs
93 %attr(755,root,root) %{_libdir}/ocaml/ppx_let/expander/*.cmxs
94 %endif
95
96 %files devel
97 %defattr(644,root,root,755)
98 %{_libdir}/ocaml/ppx_let/*.cmi
99 %{_libdir}/ocaml/ppx_let/*.cmt
100 %{_libdir}/ocaml/ppx_let/*.cmti
101 %{_libdir}/ocaml/ppx_let/*.mli
102 %{_libdir}/ocaml/ppx_let/expander/*.cmi
103 %{_libdir}/ocaml/ppx_let/expander/*.cmt
104 %{_libdir}/ocaml/ppx_let/expander/*.cmti
105 %{_libdir}/ocaml/ppx_let/expander/*.mli
106 %if %{with ocaml_opt}
107 %{_libdir}/ocaml/ppx_let/ppx_let.a
108 %{_libdir}/ocaml/ppx_let/*.cmx
109 %{_libdir}/ocaml/ppx_let/*.cmxa
110 %{_libdir}/ocaml/ppx_let/expander/ppx_let_expander.a
111 %{_libdir}/ocaml/ppx_let/expander/*.cmx
112 %{_libdir}/ocaml/ppx_let/expander/*.cmxa
113 %endif
114 %{_libdir}/ocaml/ppx_let/dune-package
115 %{_libdir}/ocaml/ppx_let/opam
This page took 0.059911 seconds and 2 git commands to generate.