]> git.pld-linux.org Git - packages/ocaml-ppx_js_style.git/blob - ocaml-ppx_js_style.spec
- typo
[packages/ocaml-ppx_js_style.git] / ocaml-ppx_js_style.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 Summary:        Code style checker for Jane Street Packages
11 Summary(pl.UTF-8):      Sprawdzanie stylu kodu dla pakietów Jane Street
12 Name:           ocaml-ppx_js_style
13 Version:        0.14.1
14 Release:        1
15 License:        MIT
16 Group:          Libraries
17 #Source0Download: https://github.com/janestreet/ppx_js_style/tags
18 Source0:        https://github.com/janestreet/ppx_js_style/archive/v%{version}/ppx_js_style-%{version}.tar.gz
19 # Source0-md5:  2d79afa4f954aeafb81b64ecfc11c3fb
20 URL:            https://github.com/janestreet/ppx_js_style
21 BuildRequires:  ocaml >= 1:4.04.2
22 BuildRequires:  ocaml-base-devel >= 0.14
23 BuildRequires:  ocaml-base-devel < 0.15
24 BuildRequires:  ocaml-dune >= 2.0.0
25 BuildRequires:  ocaml-octavius-devel
26 BuildRequires:  ocaml-ppxlib-devel >= 0.11.0
27 %requires_eq    ocaml-runtime
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         debug_package   %{nil}
31
32 %description
33 ppx_js_style is an identity ppx rewriter that enforces Jane Street
34 coding styles.
35
36 This package contains files needed to run bytecode executables using
37 ppx_js_style library.
38
39 %description -l pl.UTF-8
40 ppx_js_style to identycznościowy moduł przepisujący ppx, wymuszający
41 styl kodowania Jane Street.
42
43 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
44 używających biblioteki ppx_js_style.
45
46 %package devel
47 Summary:        Code style checker for Jane Street Packages - development part
48 Summary(pl.UTF-8):      Sprawdzanie stylu kodu dla pakietów Jane Street - część programistyczna
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 %requires_eq    ocaml
52 Requires:       ocaml-base-devel >= 0.14
53 Requires:       ocaml-octavius-devel
54 Requires:       ocaml-ppxlib-devel >= 0.11.0
55
56 %description devel
57 This package contains files needed to develop OCaml programs using
58 ppx_js_style library.
59
60 %description devel -l pl.UTF-8
61 Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
62 używających biblioteki ppx_js_style.
63
64 %prep
65 %setup -q -n ppx_js_style-%{version}
66
67 %build
68 dune build --verbose
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 dune install --destdir=$RPM_BUILD_ROOT
74
75 # sources
76 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/ppx_js_style/*.ml
77 # packaged as %doc
78 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/ppx_js_style
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc CHANGES.md LICENSE.md README.md
86 %dir %{_libdir}/ocaml/ppx_js_style
87 %attr(755,root,root) %{_libdir}/ocaml/ppx_js_style/ppx.exe
88 %{_libdir}/ocaml/ppx_js_style/META
89 %{_libdir}/ocaml/ppx_js_style/*.cma
90 %if %{with ocaml_opt}
91 %attr(755,root,root) %{_libdir}/ocaml/ppx_js_style/*.cmxs
92 %endif
93
94 %files devel
95 %defattr(644,root,root,755)
96 %{_libdir}/ocaml/ppx_js_style/*.cmi
97 %{_libdir}/ocaml/ppx_js_style/*.cmt
98 %{_libdir}/ocaml/ppx_js_style/*.cmti
99 %{_libdir}/ocaml/ppx_js_style/*.mli
100 %if %{with ocaml_opt}
101 %{_libdir}/ocaml/ppx_js_style/ppx_js_style.a
102 %{_libdir}/ocaml/ppx_js_style/*.cmx
103 %{_libdir}/ocaml/ppx_js_style/*.cmxa
104 %endif
105 %{_libdir}/ocaml/ppx_js_style/dune-package
106 %{_libdir}/ocaml/ppx_js_style/opam
This page took 0.309779 seconds and 3 git commands to generate.