]> git.pld-linux.org Git - packages/ocaml-ppx_hash.git/blob - ocaml-ppx_hash.spec
- new
[packages/ocaml-ppx_hash.git] / ocaml-ppx_hash.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 Summary:        A ppx rewriter that generates hash functions from type expressions and definitions
11 Summary(pl.UTF-8):      Moduł przepisujący ppx generujący funkcje haszujące z wyrażeń i definicji typów
12 Name:           ocaml-ppx_hash
13 Version:        0.14.0
14 Release:        1
15 License:        MIT
16 Group:          Libraries
17 #Source0Download: https://github.com/janestreet/ppx_hash/tags
18 Source0:        https://github.com/janestreet/ppx_hash/archive/v%{version}/ppx_hash-%{version}.tar.gz
19 # Source0-md5:  e7a369576b35065102f3505246315c58
20 URL:            https://github.com/janestreet/ppx_hash
21 BuildRequires:  ocaml >= 1:4.04.2
22 BuildRequires:  ocaml-base-devel >= 0.14
23 BuildRequires:  ocaml-base-devel < 0.15
24 BuildRequires:  ocaml-dune >= 2.0.0
25 BuildRequires:  ocaml-ppx_compare-devel >= 0.14
26 BuildRequires:  ocaml-ppx_compare-devel < 0.15
27 BuildRequires:  ocaml-ppx_sexp_conv-devel >= 0.14
28 BuildRequires:  ocaml-ppx_sexp_conv-devel < 0.15
29 BuildRequires:  ocaml-ppxlib-devel >= 0.11.0
30 %requires_eq    ocaml-runtime
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         debug_package   %{nil}
34
35 %description
36 A ppx writer that generates hash functions from type expressions and
37 definitions.
38
39 This package contains files needed to run bytecode executables using
40 ppx_hash library.
41
42 %description -l pl.UTF-8
43 Moduł przepisujący generujący funkcje haszujące z wyrażeń i definicji
44 typów.
45
46 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
47 używających biblioteki ppx_hash.
48
49 %package devel
50 Summary:        A ppx rewriter that generates hash functions from type expressions and definitions - development part
51 Summary(pl.UTF-8):      Moduł przepisujący ppx generujący funkcje haszujące z wyrażeń i definicji typów - cześć programistyczna
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 %requires_eq    ocaml
55 Requires:       ocaml-base-devel >= 0.14
56 Requires:       ocaml-ppx_compare-devel >= 0.14
57 Requires:       ocaml-ppx_sexp_conv-devel >= 0.14
58 Requires:       ocaml-ppxlib-devel >= 0.11.0
59
60 %description devel
61 This package contains files needed to develop OCaml programs using
62 ppx_hash library.
63
64 %description devel -l pl.UTF-8
65 Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
66 używających biblioteki ppx_hash.
67
68 %prep
69 %setup -q -n ppx_hash-%{version}
70
71 %build
72 dune build --verbose
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 dune install --destdir=$RPM_BUILD_ROOT
78
79 # sources
80 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/ppx_hash/*.ml
81 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/ppx_hash/*/*.ml
82 # packaged as %doc
83 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/ppx_hash
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc CHANGES.md LICENSE.md README.md doc/design.notes
91 %dir %{_libdir}/ocaml/ppx_hash
92 %{_libdir}/ocaml/ppx_hash/META
93 %{_libdir}/ocaml/ppx_hash/*.cma
94 %dir %{_libdir}/ocaml/ppx_hash/expander
95 %{_libdir}/ocaml/ppx_hash/expander/*.cma
96 %dir %{_libdir}/ocaml/ppx_hash/runtime-lib
97 %{_libdir}/ocaml/ppx_hash/runtime-lib/*.cma
98 %if %{with ocaml_opt}
99 %attr(755,root,root) %{_libdir}/ocaml/ppx_hash/*.cmxs
100 %attr(755,root,root) %{_libdir}/ocaml/ppx_hash/expander/*.cmxs
101 %attr(755,root,root) %{_libdir}/ocaml/ppx_hash/runtime-lib/*.cmxs
102 %endif
103
104 %files devel
105 %defattr(644,root,root,755)
106 %{_libdir}/ocaml/ppx_hash/*.cmi
107 %{_libdir}/ocaml/ppx_hash/*.cmt
108 %{_libdir}/ocaml/ppx_hash/*.cmti
109 %{_libdir}/ocaml/ppx_hash/*.mli
110 %{_libdir}/ocaml/ppx_hash/expander/*.cmi
111 %{_libdir}/ocaml/ppx_hash/expander/*.cmt
112 %{_libdir}/ocaml/ppx_hash/expander/*.cmti
113 %{_libdir}/ocaml/ppx_hash/expander/*.mli
114 %{_libdir}/ocaml/ppx_hash/runtime-lib/*.cmi
115 %{_libdir}/ocaml/ppx_hash/runtime-lib/*.cmt
116 %if %{with ocaml_opt}
117 %{_libdir}/ocaml/ppx_hash/ppx_hash.a
118 %{_libdir}/ocaml/ppx_hash/*.cmx
119 %{_libdir}/ocaml/ppx_hash/*.cmxa
120 %{_libdir}/ocaml/ppx_hash/expander/ppx_hash_expander.a
121 %{_libdir}/ocaml/ppx_hash/expander/*.cmx
122 %{_libdir}/ocaml/ppx_hash/expander/*.cmxa
123 %{_libdir}/ocaml/ppx_hash/runtime-lib/ppx_hash_lib.a
124 %{_libdir}/ocaml/ppx_hash/runtime-lib/*.cmx
125 %{_libdir}/ocaml/ppx_hash/runtime-lib/*.cmxa
126 %endif
127 %{_libdir}/ocaml/ppx_hash/dune-package
128 %{_libdir}/ocaml/ppx_hash/opam
This page took 0.210699 seconds and 3 git commands to generate.