]> git.pld-linux.org Git - packages/ocaml-ppx_fixed_literal.git/blob - ocaml-ppx_fixed_literal.spec
- typo
[packages/ocaml-ppx_fixed_literal.git] / ocaml-ppx_fixed_literal.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # native optimized binaries (bytecode is always built)
4
5 # not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 Summary:        Simpler notation for fixed point literals
11 Summary(pl.UTF-8):      Prostsza notacja dla stałych stałoprzecinkowych
12 Name:           ocaml-ppx_fixed_literal
13 Version:        0.14.0
14 Release:        1
15 License:        MIT
16 Group:          Libraries
17 #Source0Download: https://github.com/janestreet/ppx_fixed_literal/tags
18 Source0:        https://github.com/janestreet/ppx_fixed_literal/archive/v%{version}/ppx_fixed_literal-%{version}.tar.gz
19 # Source0-md5:  52c54456db2017363e0bcaaaca90fcea
20 URL:            https://github.com/janestreet/ppx_fixed_literal
21 BuildRequires:  ocaml >= 1:4.04.2
22 BuildRequires:  ocaml-base-devel >= 0.14
23 BuildRequires:  ocaml-base-devel < 0.15
24 BuildRequires:  ocaml-dune >= 2.0.0
25 BuildRequires:  ocaml-ppxlib-devel >= 0.11.0
26 %requires_eq    ocaml-runtime
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         debug_package   %{nil}
30
31 %description
32 A ppx rewriter that rewrites fixed point literal of the form 1.0v to
33 conversion functions currently in scope.
34
35 This package contains files needed to run bytecode executables using
36 ppx_fixed_literal library.
37
38 %description -l pl.UTF-8
39 Moduł przepisujący ppx przepisujący literały stałoprzecinkowe postaci
40 1.0v na obecne w kontekście funkcje konwersji.
41
42 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
43 używających biblioteki ppx_fixed_literal.
44
45 %package devel
46 Summary:        Simpler notation for fixed point literals - development part
47 Summary(pl.UTF-8):      Prostsza notacja dla stałych stałoprzecinkowych - część programistyczna
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 %requires_eq    ocaml
51 Requires:       ocaml-base-devel >= 0.14
52 Requires:       ocaml-ppxlib-devel >= 0.11.0
53
54 %description devel
55 This package contains files needed to develop OCaml programs using
56 ppx_fixed_literal library.
57
58 %description devel -l pl.UTF-8
59 Pakiet ten zawiera pliki niezbędne do tworzenia programów w OCamlu
60 używających biblioteki ppx_fixed_literal.
61
62 %prep
63 %setup -q -n ppx_fixed_literal-%{version}
64
65 %build
66 dune build --verbose
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 dune install --destdir=$RPM_BUILD_ROOT
72
73 # sources
74 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/ppx_fixed_literal/*.ml
75 # packaged as %doc
76 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc/ppx_fixed_literal
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc LICENSE.md
84 %dir %{_libdir}/ocaml/ppx_fixed_literal
85 %attr(755,root,root) %{_libdir}/ocaml/ppx_fixed_literal/ppx.exe
86 %{_libdir}/ocaml/ppx_fixed_literal/META
87 %{_libdir}/ocaml/ppx_fixed_literal/*.cma
88 %if %{with ocaml_opt}
89 %attr(755,root,root) %{_libdir}/ocaml/ppx_fixed_literal/*.cmxs
90 %endif
91
92 %files devel
93 %defattr(644,root,root,755)
94 %{_libdir}/ocaml/ppx_fixed_literal/*.cmi
95 %{_libdir}/ocaml/ppx_fixed_literal/*.cmt
96 %{_libdir}/ocaml/ppx_fixed_literal/*.cmti
97 %{_libdir}/ocaml/ppx_fixed_literal/*.mli
98 %if %{with ocaml_opt}
99 %{_libdir}/ocaml/ppx_fixed_literal/ppx_fixed_literal.a
100 %{_libdir}/ocaml/ppx_fixed_literal/*.cmx
101 %{_libdir}/ocaml/ppx_fixed_literal/*.cmxa
102 %endif
103 %{_libdir}/ocaml/ppx_fixed_literal/dune-package
104 %{_libdir}/ocaml/ppx_fixed_literal/opam
This page took 0.062326 seconds and 3 git commands to generate.